OnePlus One bacon WiFi Issue



  • Dear all,

    Foremost, I want to congratulate the Ubuntu Touch developers on creating a truly fantastic OS.

    I installed Ubuntu Touch 16.04 on my OPO bacon device and WiFi detection does not seem to be working.

    I can see the WiFi icon on the top bar, but clicking on it does not show any of the available networks or a (I assume there is one) a WiFi toggle switch.

    Everything else seems to be working fine, I can browse the web, download apps...

    I've rebooted the phone and even reflashed, but no luck.

    Any ideas?

    Thanks in advance



  • @User1993 Pull/swipe down in that top bar to see available networks. Toggling Flight Mode on and off might bring them up.



  • @Lakotaubp

    Thanks for the reply!

    I take it back. The WiFi icon only shows if I turn airplane mode on, otherwise just the cellular signal bar shows...

    I tried turning airplane mode on and off repeatedly, but no dice.

    Will flashing a newer or older build help?

    Thanks again



  • @User1993 Have you just tried System Settings (grey gear cog)? The connected WiFi should be highlighted. Not sure if your saying you have working WiFi or not. Try using System Settings, Updates and change the update channel to RC and see if that fixes it.
    You'll be getting that anyway next week if your on stable as OTA-12.



  • Good morning, everyone.

    Name here is Mike, and I am total Noob to Ubuntu Touch. (And very excited about it!)
    I have the same issue as User1993.
    I purchased a Oneplus One to experiment with; and after installing the firmware I have no WiFi.

    I can get access to the WiFi screen with no issues; but it simply shows that no WiFi networks are detected.
    I KNOW it's not the phone, because it was running android when I first received it, and tested the phone.
    I also know it's not my WiFi because I have several other devices running on it.

    Based on the about screen:
    Ubuntu 16.04 (OTA-12)
    Last updated 1/24/70 (Huh??? LOL!)

    And of course, I cannot check for updates; it has no network connection.

    Any thoughts or suggestions?
    And thank you all in advance for taking my ignorance of this system into consideration.
    Please be patient with me as I learn something new.

    Thanks!

    Mike
    Hillsboro, OR









  • the OPO sometimes has trouble detecting wifi, try and turn the wifi off anf on via the indicator and it might show up, sorry if youve already tried that.



  • *Please disregard the Date stamp LOL above... Brain-fart on my part.
    I just realized that of COURSE it won't get the date / time info; it has no connection!
    SMH...

    Sorry.*



  • OK if someone feels like it re-connect to the installer and this time try installing the development channel and see if that fixes it. If it does you can change back to stable using system settings. Or if you didn't the first time reinstall stable but with the wipe option ticked.
    Please remember if you have installed any files or info you want to keep don't select the wipe option.



  • @PhoenixLandPirat: No worries; suggest away. That's why I ask.
    I have tried that, but no joy. I also tried looking at the update channels as shown above,
    but of course that doesn't work either... (Cannot check for updates; no internet connection).

    Thanks!

    @Lakotaubp: I will try that next. Thank you for the suggestion, and I will post an update after trying.



  • @Lakotaubp : No Joy, sorry. Loaded the developer profile, but nothing changed.
    I will keep poking at it and see if I can figure out what's going on.
    In the meantime, everyone is welcome to keep sending suggestions.

    Thanks!



  • CONFIRMED.
    I'm dead in the water at the moment.

    Several reinstall attempts, with SIM and without SIM.
    Dev channel, RC channel, Secure channel... No change.
    (Wiped every time and re-setup... Currently on Dev Channel.)

    Again, I'll keep poking at it, but for the moment I'm at a dead stop.
    Yes, I am currently an Ubuntu Wonder-dummy; but I will use this as an opportunity to learn.

    (I'm actually an RF engineer for a worldwide communications company; so anything new I can learn is good!)

    So, if there are any amazing updates or breakthroughs, please let me know.
    Thanks again to all!

    Mike



  • @w4mic Do you get the option to connect to wifi during the initial setup?



  • @w4mic Thoughts like this:

    Is your box or hotspot being detected by another phone or device?

    If yes, I don't know if it's gonna help, but it doesn't cost anything to try:

    • On your ubuntu phone, start by disabling bluetooth, location, and wifi.
    • Reboot your phone.
    • Reboot your box or hotspot wifi source.
    • activate the wifi of your phone and see....


  • @domubpkm: You are speaking of my Wifi Router, yes?

    If so, then yes... I am using it on two laptops, two other phones (one iPhone and one Pixel 2), 2 cameras and several home automation devices. Plus, when I first received the phone, it had Android OS installed and was functional on the WiFi. I was able to surf the web, etc... No issues.

    I have disabled everything I can think of and performed reboots of both the phone and my WiFi.
    Nothing (so far) has helped.

    My next step will be to completely wipe the handset, reinstall a different OS (Android), and then retest the WiFi.
    After that, I will reinstall Ubuntu and try again.

    Thanks!
    ~ Mike



  • @Lakotaubp: Yes, I get the option.
    However, at that point there are NO WiFi networks being show as available.
    (SCREENSHOT: Picture 2 above.)



  • @w4mic My advice to you is not to put again Androïd to your phone but to use the

    CyanogenMod 14.1 (Android 7.1):
    https://archive.org/download/cm14los14.1bacon/cm-14.1-20161225-NIGHTLY-bacon.zip

    I used this TWRP
    https://archive.org/download/twrp-3.3.1-0-bacon/twrp-3.3.1-0-bacon.img
    But you can choose another TWRP here

    This can help how to :
    https://wiki.lineageos.org/devices/bacon/install

    And after to reflash UT. it has worked for me.
    Good Luck !

    And IF it doesn't work you put your phone in.....😀



  • @domubpkm: I will do so.
    Thank you very much!

    Have a wonderful evening!

    ~ Mike


Log in to reply