OnePlus One bacon WiFi Issue



  • @PhoenixLandPirat: No worries; suggest away. That's why I ask.
    I have tried that, but no joy. I also tried looking at the update channels as shown above,
    but of course that doesn't work either... (Cannot check for updates; no internet connection).

    Thanks!

    @Lakotaubp: I will try that next. Thank you for the suggestion, and I will post an update after trying.



  • @Lakotaubp : No Joy, sorry. Loaded the developer profile, but nothing changed.
    I will keep poking at it and see if I can figure out what's going on.
    In the meantime, everyone is welcome to keep sending suggestions.

    Thanks!



  • CONFIRMED.
    I'm dead in the water at the moment.

    Several reinstall attempts, with SIM and without SIM.
    Dev channel, RC channel, Secure channel... No change.
    (Wiped every time and re-setup... Currently on Dev Channel.)

    Again, I'll keep poking at it, but for the moment I'm at a dead stop.
    Yes, I am currently an Ubuntu Wonder-dummy; but I will use this as an opportunity to learn.

    (I'm actually an RF engineer for a worldwide communications company; so anything new I can learn is good!)

    So, if there are any amazing updates or breakthroughs, please let me know.
    Thanks again to all!

    Mike



  • @w4mic Do you get the option to connect to wifi during the initial setup?



  • @w4mic Thoughts like this:

    Is your box or hotspot being detected by another phone or device?

    If yes, I don't know if it's gonna help, but it doesn't cost anything to try:

    • On your ubuntu phone, start by disabling bluetooth, location, and wifi.
    • Reboot your phone.
    • Reboot your box or hotspot wifi source.
    • activate the wifi of your phone and see....


  • @domubpkm: You are speaking of my Wifi Router, yes?

    If so, then yes... I am using it on two laptops, two other phones (one iPhone and one Pixel 2), 2 cameras and several home automation devices. Plus, when I first received the phone, it had Android OS installed and was functional on the WiFi. I was able to surf the web, etc... No issues.

    I have disabled everything I can think of and performed reboots of both the phone and my WiFi.
    Nothing (so far) has helped.

    My next step will be to completely wipe the handset, reinstall a different OS (Android), and then retest the WiFi.
    After that, I will reinstall Ubuntu and try again.

    Thanks!
    ~ Mike



  • @Lakotaubp: Yes, I get the option.
    However, at that point there are NO WiFi networks being show as available.
    (SCREENSHOT: Picture 2 above.)



  • @w4mic My advice to you is not to put again Androïd to your phone but to use the

    CyanogenMod 14.1 (Android 7.1):
    https://archive.org/download/cm14los14.1bacon/cm-14.1-20161225-NIGHTLY-bacon.zip

    I used this TWRP
    https://archive.org/download/twrp-3.3.1-0-bacon/twrp-3.3.1-0-bacon.img
    But you can choose another TWRP here

    This can help how to :
    https://wiki.lineageos.org/devices/bacon/install

    And after to reflash UT. it has worked for me.
    Good Luck !

    And IF it doesn't work you put your phone in.....😀



  • @domubpkm: I will do so.
    Thank you very much!

    Have a wonderful evening!

    ~ Mike



  • Sorry to say, a certain batch of OPOs has a different persistent storage, so the MAC address i snot initialized correctly, leading to a faileed driver load.

    If some of the devs could get hands-on such a device its probably a matter of a few days to fix it, but so far all of our models are "working" ones. Though we get those reports since over a year now. I have no idea how to fix it, other than pointing you here: https://github.com/ubports/ubuntu-touch/issues/995 -> you need to create the mentioned config file in /persist partition of your device. Boot in recovery, mount /persist and then do the steps that are scattered in this thread 🙂 - If you could write a better HowTo would be grand.


Log in to reply