Getting started with OnePlus 3T

  • @Lakotaubp
    While it is 'sending files the installer notification pops up saying:
    Error: Systemimage: Error: Error failed to push file 2: Stdout : Adb: Error: Failed to copy 'C:\users\user\appdata\roaming\ubports\pool\device-1e[etc, device number]ac.tar.xz' to cache/recovery/device.tar.xz: remote write failed: Read only file system c:\users\user\appdata\Rom
    0 files pushed, 0 skipped. 27.8

    I decided to copy the adb files (.dll) to c:\users\user\downloads\adb-ll by promoting the zipp file (, which was successful.

    Now my explorer shows two folders in appdata\roaming , being 'ubports' and 'ubports-installer' Then I copied the .tar.xz to have it in both folders. Renamed the TWR file 'recovery.img' from downloads and copies that to the ubports folder.

    When activating the UBports installer again (with 3T off), pressing volume + and on/off button did nothing. When turning the 3T on and selecting 'fastboot mode' at first it failed ('connection to the device lost'). Tried the exact same and the strangest thing happened:

    The UBports installer kept going until it showed

    and below stating
    Ubuntu touch successfully installed!

    At first I was very happy, took a photo of that screen image, eagerly awaiting the 5 minutes to go by to have the 3T doing its booting thing (as it says in the Succes description text).

    Well....nothing happens....
    The 3T display still shows:

    Android Recovery

    • reboot system now
    • Ubuntu action
    • Android action

    PC shows successful installation, while - after almost an hour watching that 3T display in 'Android Recover' I have no clue which of the three options to select. [edit:] and won't reboot by itself despite the installer stating that it will and I can/could begin to explore Ubuntu Touch....

    Please advise.......

  • @3T_Ed That recovery is correct as far as I know it's the same as my OP3. Try restarting everything again after using Android actions to clear the cache. Then if that fails try without the Bootstrap option ticked. If that fails I would post in the main OP3/3T thread mentioned in this thread, I am no expert at all and may well be missing something obvious. Sorry I can't help further.

  • @Lakotaubp

    In the menu I selected 'Android Actions' and since there was no option for clearing cache I then selected 'Advanced', no option for clearing cache either. I decided to select the option 'Wipe Android Partitions' thinking I would not need those anymore now that Ubuntu Touch was successfully installed.

    Rebooted the OPO 3T and now it does not go passed the boot up 'Powered by Android' screen. Rebooting again, I checked both boxes in UBports installer (wiping and bootstrap), at 'preparing system-image' connection to device is lost.

    Rebooted ->option menu -> Recovery -> Ubuntu Touch successfully installed -> 3T booting up by itself -> O-ring appear -> rebooting itself after appr 1 min. -> boot up screen appears -> UBUNTU TOUCH appears!!

    I could not be happier! Thank you very much for your support @Lakotaubp , I was really afraid that my ignorance regarding flashing would make me end up with a paper weight rather than a fully functional Ubuntu Touch device. You helped me through this process, much appreciated.

    Happy days are here!

    Thanks again, hope to interact with you and all other enthusiasts on this forum.

    Have a wonderful weekend!!

  • @3T_Ed Keep forgetting the recovery is different on OP3/3T. You sorted that out by sticking with it. Well done. If I remember from the other day you may need an external keyboard to enter some account details, bluetooth works fine by the way and if an app (notes was one) does not start check the Openstore for the Stable version then you should be fine. You can mark this as SOLVED by the way now. Under your first post click on Topic tools, Ask as Question. It will then be marked UNSOLVED. Do the same again to mark as SOLVED.
    You can do this with all questions you post in the future. It will help others trying to find answers to issues.

  • @Lakotaubp

    Luckily I was very persistent, just wanted UT and ditch the mainstream OS's . Firt step was an extra desktop unit running the latest Ubuntu LTS, now Ubuntu Touch on the Oneplus 3T (goodbye MS Lumia 950).

    The UT looking very good and hopefully getting better by the day thanks to the wonderful devs and other people in this community like yourself. Thanks for the heads up re external keyboard although I have not had the need for that yet, running smooth so far. Coming from Windows 10 Mobile there's some learning curve as have all OS's. Enjoying this and a relief I'm on a good OS now with the backup of a great community.

    Maybe someday someone else can benefit from my experience as a newbie, the issue and way to find the solution (and not give up that easy) o make Ubuntu Touch work on the Oneplus 3(T). It's worth it!

    PS The 'Solved' option is not available to me. Am I overlooking something ? Could it be that it's due to the fact that I'm not the OP?

  • @3T_Ed Will sort out the solved bit and keep enjoying UT.

  • Thanks for highjacking my post by the way.
    I guess my thread is finished when my initial questions are answered?

    Is it possible to install UBports in an Multirom enviroment on the OP 3T?
    -> No

    How could I restore TWRP if I would like to switch back to an Android ROM?
    -> Basic TWRP installation tutorial works

    If I understand this correctly i have to install gst-droid to use the camera. But it says that "by installing packages via ubports-qa or apt, you should not install system updates via the system settings app anymore". Does "sudo apt update and sudo apt upgrade" also upgrade apps from the OpenStore? And is it still possible to install apps from OpenStore afterwards?
    -> ???

  • @JimmyPesto

    Since the header has a somewhat general description, as a newcomer to this forum, I was under the impression it would be a good thread for my question. My bad and I'm truly sorry for hijacking your thread, my apologies.

  • Never mind, I would just like to get the answer to my last question as this is still bothering me.

  • @JimmyPesto Firstly sorry for the hijack lost track of who's it was. After rereading that part. I'm guessing app updates will work as normal but using system settings to update the system will in some way overide or corrupt the changes you have made until the fix is merged into the main system.
    I would ask in the thread for for the perfect answer.

  • @JimmyPesto said in Getting started with OnePlus 3T:

    Does "sudo apt update and sudo apt upgrade" also upgrade apps from the OpenStore?

    You'll have to update the apps using the open store.

    As @Lakotaubp said, the system upgrade will deleted any modification made to the rootfs that's why after such a hack it's not recommended to run system updates.

    But what IS recommended is to keep the rootfs intact so you can benefit from updates.
    IDK about gst-droid and the camera issue so I guess it's a hard choice you'll have to make 😉

  • Because I'm short in time I will keep my OnePlus One as main phone for the moment. Never change a running system.
    When I got time or the OP1 will stop working I will give the OP 3T a try.
    Thanks for your feedback. I really really enjoy this great OS as it is growing to be a really great alternative to Android for me.

Log in to reply