Music app UTTT prevent app suspension

  • I've set UTTT to prevent Music app suspension, but it doesn't work. I think it was working in the past.
    (Nexus 4, OTA 12)

    My requirement is to be able to play a podcast mp3 with audio suspension blocked and screen suspension enabled. This configuration should give long battery life for 90 minute podcasts.

    Previously I have been able to do this, (maybe using Active Screen app?), but now I can't.

  • Is the mp3 being played by music app or by podbird?

    The music app is excepted from suspension by default already, fwiw, but it shouldn't need to be in any case, as the audio file is actually played by a background service which does not get suspended.

  • Hi Rodney, thanks for your reply.
    The mp3 file is being played by the music app. It plays for 3 minutes and then both screen and audio cut out together.
    When I press the power button, screen and audio re-start instantly from the point at which at which they suspended.
    I'm sure in the past, the screen would suspend whilst the audio would continue. This is the configuration I want to get back to.

  • @dtarrant Yes, the "former" description is how it is supposed to work. It sounds like you are hitting a problem that was perhaps introduced with OTA-12. You can try switching to rc or devel channel perhaps to see if it is resolved.

  • Are you sure are in stable channel? Because I think I read somewhere that there seems to be a problem with suspension in devel related to repowerd I believe.

  • @dobey I am on release candidate at present. I will try switching to devel channel to see what happens.

  • I also wanted to add I am having the same issue with all Audio apps on my Pinephone as well. As soon as the screen powers off whatever was playing stops whether I'm using Flas or Podbird. I'm on the latest OTA in the stable channel.

    EDIT: Also wanted to add that I have installed UT Tweaks and have toggled the suspend setting for both of the mentioned apps.

  • @kugiigi I am on release candidate channel and I will try stable and development channels as you and dobey suggest.

  • @tnywatkns I'm still waiting for for my pinephone 😞
    I've also discovered that I have the same issue with my M10 tablet.

  • @dtarrant I hope yours arrives soon! I've been having fun distro hopping on the phone. Already tried SailfishOS and PostmarketOS. After some days of use with those three UBPorts is the closest to daily driver status. SailfishOS is a very close second though.

  • @dobey Yay! Problem resolved! Just switched my N4 to devel channel and now music app suspends screen but continues to play audio. Perfect 🙂
    Thank you everyone for your help. Now to listen to my Soldersmoke podcast.

  • @tnywatkns Cool! Do you have the Pinephone UBports Community Edition?

  • @tnywatkns Sadly, Pinephone's issue is a bit different as it has its own set of issues. The issue seems to be fixed in devel now but that's only for android-based devices so the pinephone might need to wait a bit longer for a proper fix.

  • @kugiigi For the record, I just switched my M10 from rc to devel and there is a new problem: the music app now doesn't suspend at all 😞

  • @dtarrant @kugiigi @dobey M10 problem solved! The trouble was the 'Lock when idle' setting was 5 minutes and not 3 minutes as on my N4. Took me a long while to find the config utility:
    Battery Indicator / Lock when idle / After 3 minutes
    Easy when you know how 🙂

Log in to reply