Google Pixel 3a (sargo)

  • @fredldotme said in Google Pixel 3a (sargo):

    @dieharddan In case something went wrong with the config you can re-install without wiping using the Installer of course, but what you could do to get some details is (in the running system, ie not the recovery):

    setprop 1
    sudo reboot

    And after the device is back up:

    sudo env LD_LIBRARY_PATH=/vendor/lib64:/system/lib64 /system/bin/logcat -b all

    It hopefully shows what the error in your case is, else you would have to figure out a way to debug on your own.

    Btw, does your device report itself as bonito or sargo in the recovery adb shell and in system-settings?

    Here is the output from those commands, I tried this a couple times and there was ALOT of text, so I only copied some of the bottom after sending a few consecutive texts to myself

  • So I was playing around with this again this morning and I found that if I toggle airplane mode, I can send and receive sms as normal for about 30 seconds maybe.... after that it quits until I toggle airplane mode again which gives me another 30 sec of working sms

  • @dieharddan I'm starting to assume it is premature powersaving at fault here, I've changed the ril_subscription.conf again for other reasons, including device state management. Will send you the new one to change manually again soon.

    Edit: check the config here, especially deviceStateTracking and the last two lines:

  • My ril_subscription.conf says:
    and I do not have the last 2 lines that you have

    I tried to copy the new file over with the file manager to test but don't have write permission on the ofono folder

  • @dieharddan What could work is the following:

    • Reboot into recovery
    • run:
    adb shell mount /system_root
    adb shell mount /system_root/var/lib/lxc/android/android-rootfs.img /tmp
    adb shell rm /tmp/system/halium/etc/ofono/ril_subscription.conf
    adb shell umount /tmp
    adb shell reboot

    In the booted system you can then remount read-write and replace the preset:

    wget -O ril_subscription.conf
    adb push ril_subscription.conf /home/phablet/ril_subscription.conf
    adb shell

    In the shell enter:

    sudo mount -o remount,rw /
    sudo mv ril_subscription.conf /etc/ofono/ril_subscription.conf

    After that: reboot.

    This will be overwritten by updates until confirmed it fixes your issue, then I will merge it. It seems to provide much more stable connectivity on sargo with my provider.

  • @fredldotme Can you elaberate on the "remount read-write and replace the preset:"
    I entered the "wget -O ril_subscription.conf" on the phone terminal which worked, but not the
    adb push ril_subscription.conf /home/phablet/ril_subscription.conf

  • nevermind i got it to copy over

  • @fredldotme Doesn't seem to have made any difference, I still have to toggle airplane mode to get sms to work

  • @dieharddan I can only suggest experimenting with the config or, if that doesn't fix it, adding fallback behavior to ofono in case receiving SMS fails.

  • @fredldotme Ok, let me know if you come up with any other ideas; I will pllay around with that file but not being any kind of developer, I probably won't be able to accomplish much lol

  • @dieharddan What you might also want to try is the two properties &, these might change the behavior of the power savings mode.

    • Reboot into recovery
    • Connect phone to PC
    • Open an adb shell with adb shell
    • Enter the following commands:
    mount /system_root
    mount /system_root/var/lib/lxc/android/android-rootfs.img /tmp
    busybox vi /tmp/system/etc/init/on-post-fs.rc
    • In vi enter edit mode by pressing 'i' on your keyboard once
    • Paste the following content at the end:
    on init
        setprop 0
        setprop 1
    • Save and exit by pressing ESC + entering :wq
    • Run umount /tmp
    • Reboot

  • @fredldotme No change😧 Is there something I can capture via log while i toggle airplane mode and send texts

  • @dieharddan
    Based on what you describe I think that some process or daemon crashes after some time.
    When switching to flight mode you probably kill clean this faulty code.
    And when activating the modem again it works... until it crashes again.

    I cannot help debugging that because I know nothing about it. But best bet is you can find errors in some log.

    Best of luck

  • I can't seem to get the os working or to boot on my pixel 3a. The ubports installer says sargo isn't supported

  • @Duhjoker it's not officially in the installer yet. What you can do instead is follow this mini guide right here to force the installer:

  • @Duhjoker the Pixel 3a is now officially in the installer, should be easy to get going now! Make sure to downgrade your phone as per instructions first.

  • This post is deleted!

  • @fredldotme after various attempts installed it on GP 3a with the ubports-installer. But having the incoming sms problem described by @dieharddan. Also, Airplane mode on/off enables incoming sms temporarily. Any ideas on how to fix it?

  • Hi, im new here hello to everyone, i just flashed on my sargo from the UB installer beta 0.7.2 on windows, and im happy to say that everything is working well for now, no problem with sms sync and cellular data at the moment, the only thing is that mms not working but maybe its my apn settings.
    iam happy to try it very good works thanks.

  • @Etn i can confirm now that mms work send and receive

Log in to reply