webapp generator .clicks to get installed in the phone?

  • Because this is more a support question so this is a copy from https://forums.ubports.com/topic/291/web-app-generator/17

    So first time I tried the webabb generator 🙂
    Unfortunately without access 😞

    Can maybe someone tell me what I have done wrong:

    I downloaded and unzipped https://github.com/Winael/ubuntu/blob/master/ubuntuphone/webapps/Reboot/alternate-webapp-generator.zip to my ubuntu 16.04 desktop
    I made the alternate-webapp-generator.sh file executable
    I edited the config.cfg
    # config.cfg
    export namespace="BastosNamespace"
    export app_name="xxAppname"
    export app_title="xxAppTitle"
    export app_url="http://xx.de"
    export app_description="A webapp client for xx.de."
    export app_UA="Mozilla/5.0 (Linux; Android 5.0; Nexus 5) AppleWebkit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.102 Mobile Safari/537.36"
    export app_version="0.1"
    export maintainer_name="xxx"
    export maintainer_email="xxx@gallehr.de"
    export icon_path="/home/xxx/xxx.png"
    In terminal I cd to the right folder and run . alternate-webapp-generator.sh
    Everything went with success, I get a .click file created
    I copied the .click file to my phone
    With UT Tweak Tool I installed the .click with sucess

    BUT unfortunately the webapp doesnt show up at my apps even not after restart.

  • And today I tried with another app again. Same result...

  • Hi.
    Can you try to create some web-app that doesn't contain any of your personal data and send the config file and created click package to me.
    I will try to install the click package and see if it works, if not I will try to create the click package with help of your config file.
    That may give us some clue where the problem is.

  • @Vehi_MV Yes. Because I have no rights to upload sth. here, I uploaded it to my OwnCloud: https://x15.id4net.de/owncloud/s/um7z9IzmIe0asRr

  • Hi,
    So I tried to install the click package you created and had the same problems as you. I get a message that webapp is installed successfully, but there is no icon.

    After some trial and error runs with your config file I managed to get a wrking click package.

    It looks like the namespace and app_name should not start with capital letter.

    Try to change:
    export namespace="Nampespace"
    export app_name="Riot"
    export namespace="nampespace"
    export app_name="riot"

    and you should get a working click package.

  • @Vehi_MV said in webapp generator .clicks to get installed in the phone?:

    export namespace="nampespace"
    export app_name="riot"

    That has been the bug! Now my matrix Riot-webapp works!

    Thank you very much!

  • @Bastos
    You are welcome. I'm glad I was able to solve your problem.

Log in to reply