Camera app not working on Fairphone 2



  • @Rob_S said in Camera app not working on Fairphone 2:

    Does snybody know if the forward and backward camera are the same piece of hardware or not?

    Definitely not the same hardware. One camera for the front, another for the back.
    In between the hardware and the blob used it can be anything, but probably two devices...



  • @AppLee Ok thx, figured as much.



  • Can anyone tell me how / where app permissions are stored in UT? Or else where I can go to find this info? I'd like to go in through the terminal and just add the camera permission to the camera app somehow, and see if this gets it working.



  • @Rob_S
    It's something like: Settings/Security and privacy/App permission



  • @AppLee Thanks. I know how to do it through the interface but it won't let me, as it is greyed out and says that 0 apps have granted permission to the camera. I want to override this through a terminal, by editing the appropriate config file, or database entry or whatever. I am new to Ubuntu Touch, and my background is in PHP and MySQL, so how to do this is a bit of a mystery to me. I do have extensive experience with Ubuntu 16.04 though, and using the command line.



  • @Rob_S
    Oh, so I don't know.

    What I do know is that I had this problem with my Nexus5 and without thinking too much about it solved it by rebooting the device.
    While thinking about it, I suppose that the driver crashed/froze and that a reboot fixed all this.
    It happened only a couple time in OTA 10 or 11, never since OTA 12, but who knows.



  • @AppLee same here on FP2



  • Hello. I have an FP2 on rc channel and camera woks as expected.

    Some time ago I had some camera issues. Everything went alright only after full reinstall with installer, without wipe. If not working after, try full reinstall with wipe as last resort (after some backup).

    There was also the "can't play videos I recorded" issue sometimes. I don't fully recall how I fixed it, but I think, reinstall and/or some cache deletion was involved. Maybe I can write te instructions down, if it happens again (and I don't forget).



  • @jezek OK great, I didn't know that was an option. I'll give it a go.



  • @Rob_S Hello, is your issue resolved?

    Today I was able the first time to make pictures and videos with my VollaPhone/GS290.

    This means to switch from photo to video in camera app and create a video without freezing.
    The issue, occurs when the aspect ratio of the image sections is different between photo and video.

    This problem has not fully fixed yet (because of course they can differ) but here is a workaround. Please find the settings I made in camera app. I don´t want to state that these are the only one. They are just working. So never change a running system. 🙂

    Photo: Storage: Save to sd-card; 16:9 (9.4MP); Normal quality; HDR: off

    Video: Storage: Save to sd-card; 1080p

    Flash light currently not available for VollaPhone.

    Remark: Not sure that it has an effect where to store the pictures & videos. But I assume it is better to have them in the same place... .
    Ubuntu 16.04 (2020-09-26)


Log in to reply