Nexus 5 Marshmallow



  • Hello,
    Last week, I bought (online) a refurbished LG Nexus 5 smartphone, in order to install Ubuntu Touch on it. Unfortunately, the version of this Nexus 5 is Marshmallow (Android 6.0.1 Build M4B30Z)!
    Can you confirm that it is therefore impossible to install Ubuntu Touch on this smartphone? Or can I force the installation (manual installation option)? Do you have a solution or should I definitely give up the idea of installing Ubuntu Touch on it?
    Thank you in advance for your answers and solutions.



  • Marshmallow was the last OEM update available for Nexus 5, so you should be good to go. Just enable developer mode and USB debugging, and unlock the bootloader, UBports installer should find it and install.



  • Okay, I'm very happy. But what I didn't know is that on the bootloader/fastboot mode screen it says: Product Name = Hammerhead! Otherwise, I wouldn't have asked the question.
    I activated the "developer mode" and then enabled the "USB debugging", but there was not the "unlock bootloader" option?! So, I had to use "Platform-Tools" and simple command lines (under Linux Mint)... After that, the device was successfully unlocked.
    Always under Linux Mint, I run UBports. There were an error message and I clicked on "try again"... (I took screenshots of the process) During some minutes, it was indicated "Downloading Ubuntu Touch" and after that "Preparing... preparing system-image".
    But after 2 hours, the installation was still not finished! I stopped everything, I will start again tomorrow.
    (sorry for my English which is not very good)



  • Hello,
    I tried the installation a second time.

    • On the PC screen this error message:
      Error: systemimage: Error: Error: {"error":{"killed":false,"code":1,"signal":null,"cmd":""/opt/ubports-installer/resources/app.asar.unpacked/node_modules/android-tools-bin/dist/linux/x86/adb" -P 5037 shell echo ."},"stdout":"","stderr":"adb: device unauthorized.\nThis adb server's $ADB_VENDOR_KEYS is not set\nTry 'adb kill-server' if that seems wrong.\nOtherwise check for a confirmation dialog on your device."}
    • And on the smartphone screen, a list of choices offered by "UBports Recovery". Not knowing what to choose, I preferred to select "power down".
      Note: if I then turn the Nexus on, it gets stuck on a black screen with Google in the middle and an open padlock at the bottom!
      What are the solutions? Do I have to do the installation without UBports installer?
      Thank you very much for your help.


  • @John-Wolf said in Nexus 5 Marshmallow:

    it says: Product Name = Hammerhead!

    That's exactly what you should have on a N5 ^^
    See here : https://devices.ubuntu-touch.io/
    That's the manufacturer codename for N5.

    For installation fail, what version of ubport installer did you use?

    @John-Wolf said in Nexus 5 Marshmallow:

    "adb: device unauthorized

    Sounds like bootloader is not unlocked.

    Did you do the "fastboot oem unlock" command before trying to flash?

    See here : https://forum.xda-developers.com/google-nexus-5/general/guide-nexus-5-how-to-unlock-bootloader-t2507905



  • @Keneda said in Nexus 5 Marshmallow:

    "adb: device unauthorized

    Can also mean that he did not connect his computer after clicking Allow USB Debugging and clicking the allow this computer prompt on his android screen. He should have done this before installing UT.

    He can try two things:

    • Use fastboot in recovery to flash back to stock, or load TWRP from fastboot to wipe everything and flash back to android stock. Then start from the beginning

    -Use the Nexus 5 flashing tool that can be found in the Nexus 5 vs 5x thread. It can likely get him back on track from where he is now and finish the job.



  • Hello,
    Thank you for your answer. I never use this Nexus 5 to communicate or something else, I bought it only to install Ubuntu Touch. And it is the first time I do that. I hope that these 4 pictures will give you what you need to help me.
    Thank you.
    1
    John_1.png
    2
    John_2.png
    3
    John_3.png
    4
    John_4.png
    Pictures are often better than text...



  • @rocket2nfinity Hello rocket2nfinity,
    I did what you suggested, such as installing TWRP Recovery.
    This is fantastic! I no longer have the problems caused by UBports Recovery. Now I will study everything that is possible to do with TWRP?
    I think I can handle it on my own.
    Thanks again.



  • @John-Wolf By the excellent graphics you posted, it appears your usb settings in android - under developer settings is set to usb power mode, not file transfer. That was probably the hang up. Change that setting, it's quite a bit down in the developer menu, and then try the installer again



  • @rocket2nfinity Dear rocket2nfinity,

    I haven't forgotten anything (USB settings, etc.). In fact, there is a big problem right after the recovery installation! Why and where? I removed UBports Recovery and replaced it with TWRP. Also, android is no longer bootable. I have completely re-installed once more with the latest version of UBports (0.7.2). But still the same problem in the same place!
    So I reinstalled TWRP then I installed LuneOS (WebOS) and everything works well 👍 . But I don't like this OS 👎 .
    Too bad it is not possible to install Ubuntu Touch without using the installer... 😢

    I think this will be my last post. Thank you.



  • @John-Wolf I'm not sure you're following the procedure correctly. You should be:

    -Using TWRP to wipe all partitions. This is important.

    -Use TWRP or plain fastboot to install stock android 7.1.2 from the google factory images from google's factory image site. The full image is best, the OTA can work.

    -Boot android, enable developer options, select usb debugging, select MTP file transfer mode, unplug and replug device into your computer. ACCEPT ALLOW THIS COMPUTER to connect ALWAYS prompt.

    -Reboot to recovery. Load TWRP- Just run, do not install. Wipe Data and cache < VERY IMPORTANT or UT will not install

    -Reboot to bootloader and run installer

    First boot will take 5 to 10 minutes to boot after install



  • @John-Wolf If you've chosen to give up, Postmarket also runs on the N5.

    And it is possible to install UT without the installer, you can find out how in the Nexus 5 threads. Basically, you flash halium, then rootfs system image manually.



  • Ubuntu Touch is installed!

    Yesterday, at the end of the afternoon, I wanted to restart the installation.
    In a few words, here's what I did.
    I downloaded the image of hammerhead for nexus 5 (v. 6.0.1 full OTA M4B30Z = 588 Mo).
    Then I installed it with TWRP > ADB Sideload.
    After that, I activated again: Developer Mode, USB Debugging, MTP File Transfer Mode.
    With the hammerhead version, unlike the marshmallow version, the Nexus 5 was immediately detected by UBports Installer.

    Now, everything works perfectly, Ubuntu Touch is fantastic, goodbye android.
    Thank you very much rocket2nfinity for all you gave to me.
    John Wolf from France



  • @John-Wolf Happy you got it working. Enjoy.


Log in to reply