No GPS fix



  • I have been unable to get a GPS fix with Puremaps on my Nexus 5 today in a location (open countryside for an hour,) where there is normally no problem in doing so. The only change I can think of since the previous successful use of Puremaps at that location was the change from OTA-13 to OTA-14. Could there be any other factor at work?



  • @cliffcoggin
    I didn't have the opportunity to test the GPS before.

    I did a quick test and couldn't get a fix.
    But I will try again later to see if I have a better result.



  • @cliffcoggin
    So I charged my phone enough (50%).
    I turned it off.
    Then turned it back on after few minutes.
    I started a route with PureMaps and left the phone by the window for about 15 minutes and it got a fix.

    Side note: I noticed uNav didn't "filled" the GPS icon to show it tried to access the GPS.
    I'll try uNav and see if it works...



  • @AppLee
    I tried restarting the phone indoors and could not get a fix with Puremaps, but that isn't a reliable indication.

    Unav is a good idea. I'll test it now indoors, but a real comparison will not be until tomorrow when I can test it outside.



  • @cliffcoggin
    Indoor it probably won't work.
    I put the phone outside to get a fix.

    uNav worked, it was simply that permission to access the GPS was denied.
    A simple switch in the settings and all was well.



  • That's odd. Mine was also set to prevent location detection. I never altered that setting so I assume it must have happened during the upgrade to OTA-14. I shall report back after more testing.



  • My problem has been resolved in both Puremaps and Unav. It only needed location detection to be enabled again. That's something to watch for at the next OTA update.


Log in to reply