Unable to install UBPorts on bq M10



  • I tried to install UBPorts on my bq Aquaris M10 FHD using the Magic-Device-Tool. Before this, I used MDT to install UBPorts on my bq Aquaris E5 HD without any issue. However, this time when coming to wipe, the MDT says that it cannot detect a device. I have the tablet connected to the laptop via the data cable and I can even see the tablet folders on my laptop, so I know it is connected.

    I even tried running MDT in sudo (sudo su and sudo bash) as per the Read Me, but this did not work.

    Has anyone come across this before and does anyone know how I can install UBPorts on my M10 using MDT?



  • @UKPhil Do you have the device in the correct mode when trying to wipe it?



  • Other than the obvious developer mode on and idle mode to never cant remember any issues with the m10. I guess you've tried a couple of times. Only other thing when you say you can seethe files on PC I take it this is not while using MDT if so shut that down window. There is more info on this site somewhere will try and find it and let you know thing the thread was flashing ubports or something.



  • Yep I select the 'legacy' option and then with my M10 in 'reboot to bootloader' mode, I select Yes. However, the the MDT tried to detect the device, but it cannot find it, so it returns me back to the main menu.



  • @UKPhil Hi Phil, The thread is under support and is called 'cant get my M10 fhd to take the flash' have a look. The other thing the mode the tablet mode is recovery I think volume up + power up held together.


  • Community

    I've moved this topic to the Support subforum. The porting subforum is for help porting Ubuntu Touch or Halium to new devices, not installation questions.

    Thanks!



  • @Lakota Thanks will have a look at it and see if I can get it to work. The funny thing is that it took me ages to decide to install UBPorts on my M10, as Touch was working nice. Not that I have decided to move over, I cannot.

    I will try it the server way, as I cannot get the magic-device-tool to work. One question, in the post that you suggested, the first bit refers to the IMG file. I am not aware of this, do you know where I get it?

    On further investigation the error message the guy is receiving here is "Cache formatting was not successful, flashing may fail, check your partitions on device". For me I can and have cleared down the Cache. My error message is "No device detected" and then it goes back to the main menu.



  • @UKPhil
    This would get you to the old Ubuntu touch,then you are set right to put in ubports (don't forget dev mode)

    I had the best success with bq's hard reset tool on win 10 and my chuwi lap book, you need to authorize the drivers, then run folder,:Drivers ADB : Then run the folder :Drivers Hard Reset: Then go in the MT Flash Tool,folder,click on,flash_tool,application,to run it
    change download only to,FIRMWARE UPGRADE
    make sure your sound is on
    Do not connect your device,until after you have clicked on the big green arrow with download underneath it
    After you have clicked it,plug your device in,,,,,listen and watch for the color bars on the bottom edge,when the yellow bars is finished you should get a green arrow for success
    You need to do the the other stuff it tells you,,but the plugging in after clicking the download is the biggie..

    Sorry phil,i think you were already on touch,,but this may help some one,it gets past the security stuff.
    It works the same going back to android.



  • @UKPhil If you want to get back to the original Ubuntu touch that file is on the Bq website. If I remember correctly all the info was also on the Ubuntu Forum pages under the touch section it would be sometime back now but was still there. That thread has alsorts of info and links inti.
    I guess you've tried different usb ports and cables on your pc/laptop think a usb 3 port was mentioned. I often have device not detected etc messages from my Ubuntu laptop if I us the wrong port or knock the cable. Sorry if this is blindingly obvious. Or is the micro usb damaged on the tablet as I think you had issues charging it as well.



  • @UKPhil There is also the telegram group for the MDT. You could always ask a question on there for more specific info



  • Thanks guys, I tried again today and on both the M10 tablets I get the same returned 'Device not found'.

    I checked all ports on my laptop and still nothing. I even used a few cables and nothing. I thought that it may be the cable but it I was not connected, I would not be able to see my folders.

    This is where I stop:

    Flashing legacy channel

    Please press Power and Volume Up (+)
    wait until your tablet is in recovery

    select 'reboot to bootloader' and confirm by pressing the power button

    You should see '=> FASTBOOT mode...' in the lower right corner

    Is your tablet in bootloader/fastboot mode now? [Y]

    • I press y and Return and get the following:

    Detecting Device
    Device not found
    Back to menu

    This is where it all stops....

    I have the tablet in Developer Mode and idle set to never.



  • @Lakota Thanks for the link, I followed the steps in ('cant get my M10 fhd to take the flash) so I downloaded the img into downloads and then executed the following in my laptops terminal:

    sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=/home/uklaptop/Downloads/recovery-frieza.img

    The output that I get here is this:

    root@uklaptop:~# sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=/home/uklaptop/Downloads/recovery-frieza.img
    sudo: unable to resolve host uklaptop
    2017/09/19 21:52:44 Expecting the device to be in the bootloader... waiting
    2017/09/19 21:52:44 Device is |frieza|
    2017/09/19 21:52:44 Flashing version 12 from ubports-touch/legacy channel and server https://system-image.ubports.com/ to device frieza
    28.19 KB / 321.93 MB [] 0.01 % 46.90 KB/s 1h57m7s2017/09/19 21:52:46 Waiting for device to enter recovery mode ...
    2.47 MB / 104.46 MB [
    __] 2.36 % 42.74 KB/s 40m43sFailed to enter Recovery



  • Can you please use

    sudo strace -f -o /tmp/ubuntu-device-flash.tr ubuntu-device-flash

    and upload the resulting file somewhere, or send it to me and I will put it on my webserver for review.



  • Sorry this is above what I can help with. I'm sure someone here will have the info. Try the Ubuntu forum touch section there is advice on this on there on flashing to ubports and back again andon github. I don't remember having any issues so lacking advice. I think there is also another thread on this forum about thus issue but again not sure where try searching m10 andsee what comes up. Will have a nose around myself later. Last bit of blindingly obvious info the image your trying to flash is the one for the m10 fhd. I'm sure it will be but you never know. Apologies if this is more hinderance than help.



  • @guru This is the output that I get:

    sudo strace -f -o /tmp/ubuntu-device-flash.tr ubuntu-device-flash
    sudo: unable to resolve host uklaptop
    Unknown command `ubuntu-device-flash'. Please specify one command of: core, personal, query or touch



  • @Lakota Thanks, I look forward to getting UBPorts on my M10's



  • @UKPhil Lokate where the command 'ubuntu-device-flash' is exactly and call it with full pathname. ANd ofc you must add all the other flags you posted.



  • This post is deleted!


  • I have exactly the same result than UKphil when using the same command Line for m10 fhd migration :
    Waiting for device to enter recovery mode ...
    2.47 MB / 104.46 MB [__] 2.36 % 42.74 KB/s 40m43sFailed to enter Recovery
    Please if someone finds a solution, send us the infos



  • @H+ said in Unable to install UBPorts on bq M10:

    I have exactly the same result than UKphil when using the same command Line for m10 fhd migration :
    Waiting for device to enter recovery mode ...
    2.47 MB / 104.46 MB [__] 2.36 % 42.74 KB/s 40m43sFailed to enter Recovery
    Please if someone finds a solution, send us the infos

    How long is the time frame between 'Waiting for device to enter recover mode ...' message and the 'Failed to enter...' message?

    As I said two days ago, I would use the tool 'strace' to sniff-up what is exactly the problem. If the above time is long enough, let's say some 10 secs, one could fire up the tracing from another terminal session, if not one must launch the full command below strace.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.