Version check



  • Hi,

    I have updated my BQ Aquaris 4.5 device for the second time today.
    I followed the procedure (Install using MDT ). Everything ran smoothly.( I guess?!)
    Anyway, I am not sure that I am on the last (OTA-2) of the UBPorts version.
    Can you please indicate the correct method to confirm that I'm running the UBPort version ?
    The OS in parameters:Ubuntu 15.04 (OTA-15)
    Please note that I'm running debian on my computer.



  • @Rico You go System Settings -> About -> OS, on the phone, and it should say "Ubuntu 15.04 (r2)" for latest UBports.



  • Thank you for the fast reply.
    That's what I thought. I'm not up to date then :(



  • @Rico said in Version check:

    Hi,

    I have updated my BQ Aquaris 4.5 device for the second time today.
    I followed the procedure (Install using MDT ). Everything ran smoothly.( I guess?!)
    Anyway, I am not sure that I am on the last (OTA-2) of the UBPorts version.
    Can you please indicate the correct method to confirm that I'm running the UBPort version ?
    The OS in parameters:Ubuntu 15.04 (OTA-15)
    Please note that I'm running debian on my computer.

    OTA-15 is the last one from Canonical. Your update must have went wrong.



  • Indeed! Do you think the fact that I have debian installed could be the reason why it failed ?



  • @Rico said in Version check:

    Indeed! Do you think the fact that I have debian installed could be the reason why it failed ?

    Re/ Debian. I don't know.I have had to use an older Ubuntu 15.04 and have had to fix the shellscripts of the update tools in some places because they used flags, for example of wget which my version did not understood. I would call this a bug in the scripts. One should check the version and call commands accordingly or restrict himself to flags which are understand by all versions. I make production software and such tools chould be written in a portable form. Just my $0.02



  • @guru I installed An ubuntu VM on my debian.
    I tried from the VM it itook much longer and it worked! :)
    I'm passing from r1 to r2 at the moment.
    My debian was involved thus!
    Thanks for the help


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.