Can't flash my BQ M10 FHD with UBports



  • Hello,

    I'm trying to flash my new M10 FHD with UBports Frieza using Magic-device-tool but I can't make it !
    (but it wouldn't work either with system image server)
    I've enable and unlock the OEM and USB options via the developper tools of the device.
    I reboot into fastboot mode and then follow the steps of the MDT, but it stops after a few seconds with the message :

    Inode size: 256
    Journal blocks: 6144
    Label: 
    Blocks: 393216
    Block groups: 12
    Reserved block group size: 95
    Created filesystem with 11/98304 inodes and 12897/393216 blocks target reported max download size of 134217728 bytes
    erasing 'system'...
    FAILED (remote: format for partition 'system' is not allowed)
    finished. total time: 0.003s
    erasing 'recovery'...
    FAILED (remote: format for partition 'recovery' is not allowed)
    finished. total time: 0.004s
    rebooting into bootloader...
    OKAY [  0.003s]
    finished. total time: 0.053s
    Please wait
    rm: cannot remove '/home/xxx/snap/magic-device-tool/299/.cache/magic-device-tool/recovery-frieza.img': No such file or directory
    recovery-frieza.img            100%[====================================================>]  11.18M  2.55MB/s    in 4.5s    
    
    
    2017/12/02 18:00:32 Device is |frieza|
    2017/12/02 18:00:32 Flashing version 12 from ubports-touch/legacy channel and server http://system-image.ubports.com to device frieza
    381.65 KB / 104.46 MB [___________________________________________________________________________] 0.36 % 953.06 KB/s 1m51scan't flash recovery image
    
    Wait until it reboots on its own!
    Do not reboot manually!
    
    Cleaning up..
    
    Exiting magic-device-tool. Bye Bye
    

    Does anyone had this message before?
    Thank you,

    Emmelyne



  • @Emmelyne Just a check that developer mode us enabled via system settings. Also check the cache gas enough space. There are other posts in the support section about m10 flashing issues.
    There should be some gray lettering st the bottom of this thread page with a number after them they should take you to them.
    Also you say new m10, is it on android at present? Not sure but you might need to flash with the original Bq Ubuntu touch version first before flashing ubports. If so its on the Bq website also try github for info. Sorry but can't remember now where it all is.



  • Hi @Lakota,
    thanks for your answer.
    Yes my m10 is on Android 6.0
    and yes, I've already enabled the developer mode on the tablet.
    For the cache I've wiped it from de recovery menu, I hope that' enough...

    I've try to flash Ubuntu Touch but I can't install the SP flash tool !
    I'll try again and let you know.
    thanks



  • @Emmelyne Just copied this from another post.

    Use this to check the cache BQ M10 FHD. I tried it how many times in different ways and always the same result.
    Marius G. guide me, so that it was successful in the end.
    This are the steps I made:

    Put your device into recovery mode. (Volume up + Power on)

    Connect it by USB to your computer

    Open terminal on your computer and type:
    adb shell "df -h"
    My output in the last line was following:
    /dev/block/platform/mtk-msdc.0/by-name/system
    3.8G 3.7G 52.4M 99% /cache
    So there was no space left on the cache partition.

    just a test:
    adb shell "ls /cache"
    ls: /cache/lost+found: No such file or directory

    Then I created a new filesystem on the cache partition by the command in terminal:
    adb shell "make_ext4fs /dev/block/platform/mtk-msdc.0/by-name/system"

    Now rebooting the device by the command:
    adb reboot recovery

    After device is up in recovery mode again, enter the command again:
    adb shell "df -h"
    /dev/block/platform/mtk-msdc.0/by-name/system
    3.8G 8.1M 3.8G 0% /cache
    Now the space on the /cache partition is available.

    Just another test:
    adb shell "ls /cache/"
    Output was:
    lost+found recovery

    Now reboot the device:
    adb reboot bootloader

    After that I was able to install UBports without problems. The device is running fine.cache

    To install adb
    sudo apt install android-tools-adb android-tools-fastboot
    There is also a dev version of MDT (sudo snap install magic-device-tool --devmode) that works in other cases. There is much more info on the support pages. Also a MDT telegram group for further help.



  • @Lakota, thanks
    Yes, I've seen this post before !
    But when I connect my m10 in recovery mode and try to run the commands on terminal, I get a "could detect device" (or something close).
    Whereas when I run the MDT, it says "device detected"...



  • Hi @Emmelyne,
    i suggest to use/try the UBPorts installer (https://github.com/ubports/ubports-installer/releases). Is simple to use, is only necessary place the device in Development mode (and backup your data) the device is auto-detected by the installer. I have used it successfully to Install UBPorts on my BQ M10 FHD removing the Ubuntu Touch by Canonical.
    I suppose should work also install UBPorts removing an Android version as in your case-



  • Flashing Android M10 FHD:
    The above post from 31/07/17 is the last thing I can think of. (tried to copy it as a link on my phone but couldn't so you will have to look it up). It has a few links etc in it.
    Good luck you will get it sorted one way or the other, someone on this forum will know how or have sorted it.The post also mentions the telegram supergroup which will help.



  • Ok, thank you both!
    I'll try some of the mention solutions and let you know.



  • Hi @fulvio
    I've tried the UBPorts installer, which seems really simple indeed!
    But when I connect my BQ M10 FHD, I've got the message that "Device Aquaris_M10_FHD" is not supported (see image ).
    Any idea why?
    Thank you!!
    0_1512585110338_DeviceNotSupported.png



  • @Emmelyne I think its because yours is running Android not Ubuntu touch, so the installer does not recognize it. Could be wrong but look up the posts by polylux they had similar issue.



  • HI @Emmelyne
    i agree with @Lakota. I have just tested the installer with my M10 FHD (with UBPports already installed using it) and it is detected in automatic (see attached screenshot).
    I think you could open an issue: https://github.com/ubports/ubports-installer/issues
    maybe the author can solve the issue.
    Sorry but i haven't any other possible solution.
    0_1512591516582_Schermata del 2017-12-06 21-11-05.png



  • I think I get rid of one of the problem: my OEM wasn't properly unlock and after having doing it well I was able to run the magic-device-tool!
    But I'm now stuck with the recovery mode of frieza and when I choose the reboot the device, I getting the powered by android image with the Orange state alert and nothing happens...
    So I try to follow the post of 29 may 2017 07:28 of this topic :Can't get the M10 FHD to take the flash, but when I run the "df -h" I can see (image) that my system partition is only 1.5G and the userdata one is only 774.9M!
    How could that be?
    Thanks again

    0_1512592466373_M10DevicePartitions.png



  • @Emmelyne Jamesp on 25th Jun from the same thread mentions using Bq's own flash tool to install the latest Bq version of Ubuntu touch. Then Ubports.That might be the way to go.
    You could try sending a message to Marius via the MDT telegram group or webpage for help. It could be the cache or Android thats the issue.
    From rereading the thread there doesn't seem to be one way of doing things, so its a matter of working through them. I know I had to install things a couple of times to get them to work, but you will get there.🙃
    Someone out there must have abit more advice for you.



  • SP flash tool is what I forgot to mention used it to put flyme back on a mx 4.



  • Hi, just to say that I eventually managed to install Ubuntu touch using the BQ's flash tool and firmware!
    I haven't work on upgrading to UBports yet, but I'll try soon...
    Thanks all for your help!



  • @emmelyne look at how much memory UT is using and remember ,so you can compare, when you flash UB,look again,sometimes it doesn't wipe UT,uses a lot of memory up.





  • @gerben Flash tool is in the Hard Reset folder on BQ site.





  • @marathon2422 said in Can't flash my BQ M10 FHD with UBports:

    Flash tool is in the Hard Reset folder on BQ

    Thank you for the quick reply. Where can I find the Hard reset folder?


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.