OnePlus One model 64 GB Sandstone black A0001 not compatible!!!!!



  • I have just wasted about +250 euro for a brand new OnePlus One 64 GB Sandstone black A0001 model and when I connect it to UBPorts installer (runned from .deb in Debian 9) it says the model A0001 is not supported...
    Are you serious?? why on the website you do not specify this???
    WHY a new OnePlus One 64 gb is not compatible as it should be???
    PLEASE HELP ME :-((((


  • Community

    Whoa there, let's take this down about ten notches.

    The Oneplus One is definitely supported. The UBports Installer is still a beta product and sometimes misidentifies devices. Could I get you to try the 0.1.9 AppImage? If it doesn't work on the first try, try running the AppImage from the terminal.


  • Community

    Hey there, sorry about that, you probably downloaded the installer from the website, there's still a link to an older version. I notified our website team. In the meantime, please try the latest version of the installer.

    Before installation, please update to the latest version of android to make sure you have the required version of all firmware blobs that we can not distribute.

    Please let us know how it goes!



  • I also have a OPO that said, in the UBports installer, that A0001 was not supported. I clicked "Select device manually," (I'm not sure that those are the actual words now, but that was the general sense of it) and everything worked perfectly. The device was found and UBports installer installed UT successfully.



  • I runned the new updated app, and clicked on select device manually, it asked me to enter in bootloader and when I did it downloaded 2 files before make enter my opo in recovery mode.
    Actually it is still freezed saying: Waiting for device to enter recovery mode...
    Flashing recovery and boot images

    But device is already in recovery mode and there is not any percentual bar which makes me understand if it is working or just stucked.....
    Anyway more I go deep in this and more I see how it is all designed very bad, there is not order and cleanliness....
    So what now? Should I wait ages for it or has it again gone wrong?



  • Hi,

    The oneplus one is definately supported. I have run it myself. Installing UBPorts can happen in a breeze but might also be problematic. As you will undoubtedly have seen this when searching in this forum. There are various ways to install it. One of them seems not to work for you. So you can try another one or find out why this one does not work.

    For me the installers did not work since my phone could not be accessed using adb. It remained 'unauthorized'. In the end I used the script the UBPorts developers use but this is considered a last resort.

    So I would suggest to first verify your phone is accessible by adb when in recovery mode.



  • Okay at end It worked BUT DAMNATION!!! It was a f###### nightmare :-S

    It installed the whole thing by the new app, but the problem is basically the way you have to go through.
    The real working way is not in anyway listed or showed in the website (maybe in forum).

    1)It doesn't say you need install and run team win recovery project to unlock the smartphone.
    2)Than it doesn't show you the right updated UBPorts installer to use (very very very bad).
    3)It doesn't say you need plug in your smartphone in FastBoot mode even before open the UBPorts installer or it will stucks in "waiting for your device for recovery"
    4)All the 4 methods listed to flash the rom are outdated and not working!!! especially the magic-device-tools from github which installs you a totally instable version.

    Well although the whole big drama I am very happy I can finally have ubuntu touch in 4G (I was stucked a way too long with BQ Aquarius in 3G). Thank you for that :-)
    BUT still for all the frustation please revise the website in order to make it run smoothly as it should really be with a simple application. JUST KEEP IT UPDATED!!!!



  • The path to freedom has never been an easy one.



  • @mark-volpetti you can contribute then to make it more clear :). You can start by filing a bug
    https://github.com/ubports/devices.ubports.com (not sure if it is that one)
    or even better, propose a Pull Request



  • It seems Ubuntu touch cannot exchange files via usb with a pc;
    When I click bacon it says: Unable to access "bacon"
    Unable to open MTP device [usb:003,003]

    On my pc (Debian 9) I installed the mtp-tools package but nothing changed.
    Anyone found a solution for this or can I connect only with Putty?



  • I looked for alternatives ways to connect my smartphone to my pc.
    By bluetooth I can send files from pc to bacon but not the opposite.
    With WifiTransfer (Ubuntu Store or OpenStore) you can connect to your phone from pc as a server by ftp.
    LOL it's a bit extreme and funny but okay :-) , the important is to solve the necessary needs in some way


  • Infrastructure

    @mark-volpetti this is a known issue since May: https://github.com/ubports/ubuntu-touch/issues/13

    BTW help wanted on this bug!

    BR



  • @flohack From May?
    That's very sad :-(
    I should buy a bluetooth headset (only one ear) in few days, does anyone know if Ubuntu touch connects it normally or if actually is not possible?



  • Wooow I just found out that to change my account password on Ubuntu touch the only possible way to go is using the terminal LoL :-))
    No Gui for this X-D
    I see Ubuntu touch doesn't like easy ways to do things, well, that's funny and interesting :-)
    So for change the password (called passphrase) you need open terminal and type passwd just as you do on the general linux desktop distributions



  • Awww, wifi doesn't remember connections, or better it does but it doesn't allow connect automatically or manually to it, so the bypass is just to open the old saved connection, read and write the password in a line than copy and paste it in the empty line field for a new wifi connection.

    I see there are few bugs to fix for the next update of Ubuntu touch


  • Community

    @mark-volpetti

    Bluetooth is not very stable, it's a pain point that we plan to improve on. You can search the forums to find reports of different devices that may or may not work.

    You can change your passcode by going to settings, security and privacy, locking and unlocking, lock security. Pick "No security" to disable your passphrase then pick "Passphrase" to set a new one.

    For Wifi, check if the networks are appearing in the "Previous Networks" settings screen.



  • @unisuperbox Okay, I have just bought this mono bluetooth headset from Amazon:
    https://www.amazon.it/gp/product/B072R2ML2H/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1
    I will post results as soon as I try it on my OPO.
    I just hope to use basic functions.
    For the rest Ubuntu touch seems work fine for the moment, wifi is working better, not asking anymore for passwords :-)



  • can we change the title of the subject ? :)



  • @ernest Nope, for only one reason, that's the installation part of ubuntu touch which actually is still not updated (just checked) , so if a new opo user try to install ubuntu following the website could still find it impossible.
    Still too many links but nothing working.
    Why don't they just post the app installer link page they gave me on this topic as unique method?
    That's working 100%

    https://github.com/ubports/ubports-installer/releases/tag/0.1.9-beta



  • @mark-volpetti Mark, this a community project, so there are no "they" and "we", there is only "we". You can go to the web-site repository and open a ticket ("issue"):

    https://github.com/ubports/ubports.com


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.