Wireless convergence on FP2 : black screen



  • Hello !
    To try convergence on my FP2 I bought a HDMI wireless dongle with a button to switch between two modes: Miracast and DLNA.
    I plugged it on a TV, connected my UbuntuTouch FP2 device to it remotely. The dongle appeared in the available external displays. Once selected, the screen on the TV became black (instead of the dongle's welcome screen) and the screen on my FP2 grey with a message "you can use this touchscreen as a pointer".
    Waiting a couple minutes didn't change anything, the TV screen remained desperately black...

    What is funny it that I decided to take a screenshot (vol +& vol -) and once back in the "smartphone mode", I opened it: the image show the desktop of a big screen, with my UT apps displayed! So somehow UbuntuTouch was able to switch to "convergence mode" but not to correctly send the signal to the dongle...
    How can I debug this?

    Best regards,
    Olivier

    Note: I didn't connected any wireless mouse/keyboard, is it necessary?
    Note2: I tested both Miracast and DLNA screencasting on LineageOS and it worked, so the dongle is not defect.



  • @oli-sax
    Hi Oliver,
    I guess your dongle works on Android, but not on UBports/Ubuntu-Touch.
    I have the Microsoft Dongle and it works already fine with Ubuntu, before UBports was released.
    See here: "Known working Sink devices"
    https://wiki.ubuntu.com/Touch/DisplayCasting
    Before I tried this one http://amzn.to/2D0XlSa but it didn't work, and I send it back.
    Then I bought this one: http://amzn.to/2D1anjH
    and every thing works fine...
    PS: This was already in August 2016 when I tried this with my BQ M10 FHD
    See my German YouTube Video, where I show this: https://youtu.be/gWsr2gq9OUs

    Alex



  • Thank you for your answer, @WLBI !
    I find quite funny that Ubuntu needs a Microsoft device for convergence ;-)

    Anyway, as you also first tried with an incompatible device, it seems that the protocol is not as universal as I initially tough...


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.