[solved] OpenVPN VPNSecure connected but no network

  • Hi, I'm struggling to setup my VPN - tried Mullvad and VPNSecure, both are working fine on all my other devices.
    As I can switch them on after the initial setup and the button turns green I assume I didn't do everything the wrong way, but after connecting the VPN there is no more network connection - neither internet not home network.
    Surely I'm missing something that should be done but I tried everything I could imagine without success ...
    Many thanks for any help!

  • Hi! I'm interested in setting up VPN on UT. But no one else has tips for that... Could you post pictures of your installation? The GUI is not as simple as connecting to a VPN through the terminal ..
    Thanks 😉

  • Try to tune the setup with the app enclosed https://github.com/ubports/ubuntu-touch/issues/46

    look also in advanced setting

  • @ernest thanks, I already used this app to try different settings ...no success ...

  • I am also interested on this, specially because I use Mullvad as my vpn too!

  • Today I tried the terminal way - both VPN scripts are running and are ending with > Initialization Sequence Completed < but there is no working VPN tunnel as the ip is still the one from my provider ... - in addition the terminal is stuck on > Initialization Sequence Completed < only a reboot kills the process
    As said same behavior with two different VPN providers and two different approaches (mullvad is password and VPNS is with keys ...)
    All terminal outputs seem ok, no errors - but no VPN tunnel (but still working network though 😉 )

    any ideas? thx

  • did you try with sudo ?

  • @ernest yes

  • @elastic
    Can you try to activate verbose mode and share the logs (after removing sensitive data) ?

  • @ernest

    log deleted

  • Thanks,
    Next time you share log please use : https://paste.ubuntu.com/

    So it seems that the connection is set it up correctly and also it's normal that your browser doesn't get the VPN ip. My phone has the same behavior while connecting from phablet-shell.

    I guess the issue remains in your system setting config. Open the VPN editor app and took a screenshot of each page your vpn setting with personal data hidden.

  • @ernest sorry for the late response - had to work ...

    pics deleted

  • So, look in the header of your .ovpn file, all the info should be present in the client config.

    For instance are you sure about no additional TLS auth ?

    my header look like

    dev tun
    proto udp
    remote utouch.org 8080
    resolv-retry infinite
    key-direction 1
    remote-cert-tls server
    tls-version-min 1.2
    verify-x509-name server_retefdr434534erger34345 name
    cipher AES-256-CBC
    auth SHA256
    verb 1

    See below the config matching





    Ps don't forget to create/copy paste your key and ca correctly in a dedicated file.

  • @ernest
    thanks again, yes, I'm sure about the TLS auth it's not needed.

    anyway I got the VPNSecure to work - I have just no idea how because I changed nothing in my config ... - what I did was running the ovpn in terminal - reboot - opened the GUI VPN config and closed it again, rebooted and suddenly it worked ...

    After that I was able to configure several VPN servers at the same provider (different countries ...) but hat to reboot after every single setup to get it working - if I setup two servers without a reboot between only the latest was working ...

    Maybe I should note that it has been like this on SailfishOS before they fixed their VPN-setup-UI (after a year or so ...)

    sadly no success with Mullvad (work on Sailfish so the config is ok ...) but for now I'm happy with one working VPN

  • Not sure if I should post this here or start a new post as this is VPN-related but maybe a different problem.

    I’ve also been having difficulties getting VPN working correctly. However, the problem was different to what I’ve seen mentioned in this and other posts about VPN problems.

    My VPN provider is VyprVPN.

    First I tried setting things up using the standard VPN GUI, and it seemed to be working. After setting up the details in the GUI, and then flipping the switch, the switch turned green. However, opening a browser and navigating to a site that displays my IP address showed the IP address of my ISP and not my VPN proxy server, so clearly the VPN tunnel was not being used.

    I installed the enhanced GUI app of Pete Woods and tried using that, but the result was the same. So I resorted to the command line. I hadn’t used openvpn before, so before trying it on the phone I tried it on my Ubuntu 16.04 computer. Using the .ovpn file downloaded from the VyprVPN website, I was able to get the VPN connection working fine with sudo openvpn Config.ovpn on the computer, so I tried the same on my phone.

    Unfortunately, I got the same result as with the GUI. The connection appears to be established without any errors or warnings in the log, which finishes with ‘Initialization Sequence Completed‘, but checking my IP in a web browser gives the same result as above. Also, closing the connection in the terminal with CTRL+C reported a few errors when trying to delete routes, saying RTNETLINK answers: No such process, ERROR: Linux route delete command failed: external program exited with error status 2.

    After a lot of searching, I inserted the line ‘route-delay 5’ at the end of my config.ovpn file and this solved the problem. The forum where I found the suggestion didn’t give much explanation, so I am not sure what the exact problem was or why this solves it. I’m certainly no expert in openvpn.

    Sorry for the long post, but hopefully this may help anyone else having a similar problem or maybe the Ubports developers working on the VPN gui app. I can post log files if anyone wants.

Log in to reply