SDK installation error: Stopping containers

  • @karstong said in SDK installation error: Stopping containers:

    Hello everybody,

    many thanks for your replies. For clarification: I followed the installation guide from mimecar and I installed and configured lxd too. The error still remains. I have no idea.

    Maybe I should go with the hint of kugiigi. But there is the next thing I don't understand. Should I install qt creator first or clickable? Could you be so kind and explain the necessary steps to install such an app devel environment? Thanx again!

    Did you follow the instructions from here?
    There is a comment further down that encourages you to install the LXD snap package instead of the LXD deb LXD package like I suggested. This can be done with:

    $ sudo snap install lxd

    It might also be a good idea to remove the older LXD deb package.

    $ sudo apt remove lxd
    $ sudo apt --purge autoremove

    Let me know if you hit any obstacles.

  • Hello @arubislander

    No, I did indeed not find the error page from mimecar.

    So, I followed your instructions and installed the LXD snap package and tried to get the SDK started. The same error occurs. Then I removed the older LXD deb package. This also removed the Ubuntu-SDK.... See the picture below.


    What am I doing wrong?

  • I noticed that I did forget to migrate the existing data from LXD to snap LXD. By doing "sudo lxd.migrate" I encouter another error:

    "The following packages depend on lxd: ubuntu-sdk-tools, ubuntu-sdk-ide"

    Any ideas?

  • In my opinion, since he's just starting, why not go directly with something supported and future-proof than make something work then after sometime you have to adjust again and make that work again.

    I don't mind if you still push with the Ubuntu SDK IDE, it's not really a bad idea but if you think you're taking too much time with it, try using what I suggested.

    I think clickable is an easy tool to use. It's not an IDE per-se. It's actually a tool to compile your app into a click package and install to your device or ,recently implemented, run directly on your desktop.

    I can try to help you setup Qt Creator + clickable. Just want to share, I've been developing my app directly on my Nexus 5 these past few weeks. I have Qt creator installed and use bash script to use clickable to compile. I do it in x forwarding session or directly connected to monitor aka #Convergence 😄

  • Thank you @kugiigi for your suggestion. It is hard to me to say whether this or that way might be the best since I am a beginner. But I actually would prefer to start with the easier way for coding which seems to be the SDK. If I do not manage to get this thing started I would like to get back to your suggestion. Thank you again.

  • That sounds like an interesting setup you have there @kugiigi.
    @karstong: I will setup a quick virtual machine to check the correct sequence of instructions and get back to you.

  • OK, so I installed a clean build of Ubuntu 16.04 in a virtual machine.
    Then installed the Ubuntu SDK with:

    $ sudo apt-add-repository ppa:ubuntu-sdk-team/ppa
    $ sudo apt update && sudo apt install ubuntu-sdk

    It pulled in a host of dependent packages and took a little while, but at the end I tried launching the SDK from the dash.
    I was presented with this error:

    The current user can not access the LXD server which is required for the Ubuntu SDK.
    Make sure the user is part of the lxd group, relogin and restart the IDE.

    Following that advice I did:

    $ sudo usermod -a -G lxd $USER

    Then logged out and back in. After I launched the SDK again I got a dialog box asking to create the default configuration. I clicked on YES. After prompting for my password it showed a log informing me that that I should run sudo lxd init, so I did:

    $ sudo lxd init

    I pressed ENTER at every prompt accepting the defaults. At the end it told me that LXD has been successfully configured

    After restarting the SDK I got the prompt to create the default configuration again. I clicked on YES and I got the same error as the OP. So I launched the SDK for the third time, but this time clicked NO at the prompt to create the default configuration.
    The SDK started and I created a new Project. I chose QML App with Simple UI (qmake). The wizard started. Under Location, I chose a name and location. Under Click package parameters for Framework I chose the hightest SDK framework available.
    Then I came to the interesting part: Under Build targets there was a big button: Create new Kit. I clicked on that and created kits for desktop (amd64 15.04) and for devices and emulator (armhf 15.04). What this does is create lxc containers using lxd to run the software you develop with the SDK in.
    After creating the Kits I selected them in the next step and finished the wizard.

    So my previous instructions were in error. You should remove the lxd snap:

    $ sudo snap remove lxd

    and reinstall the Ubuntu SDK with the instructions above.

  • @arubislander: Thank you for the time you took to help me.

    I removed the snap package as well as apt lxd. Finally I reinstallled ubuntu-sdk as indicated (and as I did before). Then I re-initialized lxd as I did many times before. I have chosen (as you said) all the defaults. But there comes the next error:


    When I try to activate "lxd.socket" with or without sudo the expression cannot be found. So, it think my lxd configuration might be damaged.

  • The message about the lxd.service is not an error. Just a warning. You do not need to do anything about it. Just launch the SDK and follow along as I have tried to explain.

  • If you are starting you can download the virtual machine I prepared for the programming course. It has everything set up and you don't have to make any modifications to the system to start working. You can connect to a phone / tablet even if you use the virtual machine.

  • @arubislander : Unfortunately, I get the same error as in the title...

  • @mimecar: I will try this out when I have cleaned up my hard disk for the 13 gb needed. Thank you.

Log in to reply