Need help in porting Halium/Ubports to Galaxy S4 jfltexx



  • @suoko you can select all your text and click on that </> icon to make it more readable, or you can add 3 backticks (```) at the beginning and the at end of your text 🙂



  • @suoko Edited your post as @advocatux recommended. Hope you don't mind.


  • Infrastructure

    @suoko said in Need help in porting Halium/Ubports to Galaxy S4 jfltexx:

    hardware/samsung/AdvancedDisplay/Android.mk:34: frameworks/base/packages/SettingsLib/common.mk: No such file or directory

    This seems to be a Java application, try to get rid of AdvancedDisplay fully.



  • @Flohack i did it, i flashed it but now it boot loops.
    No signs of ubuntu touch, it just reboots after a minute of black screen and no way to ssh into it


  • Infrastructure

    @suoko Did you start using the reference rootfs?

    let it bootloop once, go into recovery, look for cat /proc/last_kmsg - that will give you kernel dmesg



  • @Flohack

    ~ # cat /proc/last_kmsg 
    [    0.000000] Truncating memory at 0xc0000000 to fit in 32-bit physical address space
    [    0.000000] sec_tsp_mode: LCD_ID = 0x408047, val: 0X408047, ret1: 0x8
    [    0.036590] AXI: msm_bus_fabric_init_driver(): msm_bus_fabric_init_driver
    [    0.059722] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059753] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059783] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059783] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059814] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059844] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059844] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.059875] msm_rpm_get_status(): Status id 433 not defined for target
    [    0.209259] sensor_power_on_vdd: done
    [    0.263061] i2c i2c-4: Failed to register i2c client imx135 at 0x10 (-16)
    [    0.263305] i2c i2c-4: Can't create device at 0x10
    [    0.263763] i2c i2c-4: Failed to register i2c client s5k3l1yx at 0x34 (-16)
    [    0.264007] i2c i2c-4: Can't create device at 0x34
    [    0.298034] ion_heap_create: Invalid heap type 3
    [    0.303222] msm_slim_ctrl msm_slim_ctrl.1: Slim-dev:3 report inf element:0x0
    [    0.303436] msm_slim_ctrl msm_slim_ctrl.1: offset:0x0:bit mask:8
    [    0.304138] msm_slim_ctrl msm_slim_ctrl.1: Slim-dev:4 report inf element:0x400
    [    0.304473] msm_slim_ctrl msm_slim_ctrl.1: offset:0x0:bit mask:8
    [    0.385742] Error-Bad Function Input
    [    0.386718] Error-Bad Function Input
    [    0.705566] smd_channel_probe_worker: allocation table not initialized
    [    0.721649] dma_test_init, minor number 37
    [    0.729095] mdm_modem_probe: registered mdm id 0
    [    0.729248] mdm_do_first_power_on:id 0: Powering on modem for the first time
    [    0.990509] cont_splash_clk_ctrl: dsi_esc_clk - clk_set_rate failed
    
    


  • Had to truncate due to false spam-detection

    [    0.999847] [mdnie lite] start!
    [    1.000061] [mdnie lite] end!
    [    1.001800] hdmi_msm hdmi_msm.1: external_common_state_create: sysfs group df038608
    [    1.002227] Inside writeback_driver_init
    [    1.002471] Inside writeback_probe
    [    1.006286] Unknown PM state 0
    [    1.006378] Unknown PM state 3
    [    1.192382] wcd9xxx_slim_probe: failed to get slimbus tabla-slim logical address: -6
    [    1.261932] msm_otg msm_otg: failed to get phy_clk
    [    1.431884] couldn't get usb power supply
    [    1.454223] [jc_spi_init:336] Entered
    [    1.454315] [jc_spi_probe:301] Entered
    [    1.454498] [jc_spi_probe:311] jc_spi successfully probed
    [    1.454589] jc_config_isp_irq~~~~~~~~~~
    [    1.454803] msm_eeprom_probe probe_fail
    [    1.459228] msm_sensor_i2c_probe s5k6b2yx probe succeeded
    [    1.459320] msm_eeprom_probe probe_fail
    [    1.494873] mmc0: No card detect facilities available
    [    1.620819] power_supply sec-fuelgauge: driver failed to report `status' property: 4294967274
    [    1.621063] power_supply sec-fuelgauge: driver failed to report `status' property: 4294967274
    [    1.639068] max77693_get_health_state: Fail to get psy (battery)
    [    1.641784] power_supply sec-charger: driver failed to report `power_now' property: 4294967274
    [    1.643585] max77693_get_health_state: Fail to get psy (battery)
    [    1.646301] power_supply sec-charger: driver failed to report `power_now' property: 4294967274
    
    


  • dbbb7e68-5fe2-4e45-807c-e302dddde79b-image.png g


  • Infrastructure

    @suoko it would be better you join @Halium group on Telegram. We dont want to overload the forum. And copy all such things into a pastebin plz...
    Your log is very short. nothing that could help us. Please try to build Lineage with this manifest to verify if the kernel is at all working.


  • Infrastructure

    Or maybe not. You might want to do telnet debugging with the break=bottom kernel cmdline parameter.


Log in to reply