@advocatux said in No WiFi on Fairphone 2.: @Opolork have you tried to clean the System Settings cache using UT Tweak tool for example? There was this bug https://github.com/ubports/ubuntu-touch/issues/703 but it should be fixed. Also, take a look to https://github.com/ubports/ubuntu-touch/issues/168 Cheers, advocatux. :-) The part, 'Settings > Battery > Toggle WiFi' did the trick. :relaxed: