Cannot Flash bq Aquaris M10 FHD

  • The original problem was that the bq Aquaris M10 FHD could not be detected while connected via U.S.B… and yet it could. It (with developer mode on) could be identified by the laptop (on both macOS and Windows, with universal adb drivers) and by UBports Installer 0.1.13-beta to correctly report the make & model, as well as recommend installation settings, but still asked for the device to be connected via U.S.B. even though it already was.

    Reading v.0.1.9-beta could install it, I tried the earlier versions on the website:
    But that only caused the tablet on fastboot mode to report the estimated download time to be an outrageous "365min.'s" long, so the fully-charged portable device's battery died before the download (much less "the installation") was complete.

    Trying each and every earlier version seems to have failed, since the UBports now cannot detect the tablet at all, while the laptop can on both Mac and Windows can.

    Can someone help me out with this, please? Any assistance on the matter would be very much appreciated. Thanks for your time.

    Best regards,

  • @n192k001 what OS is installed in your tablet, Android or UT? USB port is 2.0 or 3.0? Is adb in your user $PATH on your Mac? Have you try to run the installer with sudo? Is Windows confused with several drivers?

    Tip: you need to start the installer before plugin the device.

    If Mac and Windows don't want to cooperate you can run Ubuntu live (*) usb + the installer (this system doesn't modify anything in your computer).


  • @advocatux sounds like it was android and not oem unlocked thru android settings,reflash via BQ tool and redo (visualize shrugging shoulders) ?

  • @advocatux This is the Ubuntu Edition and has the last Canonical update, O.T.A. 15.

    As to the U.S.B. port, I could not find the version number in the box, manual, or website, whose most descriptive term is "Micro-USB OTG slot" (per the website).

    On the question of adb being in my user $path, yes. I just installed the Homebrew and android Platform Tools reportedly necessary for it.

    Running it (probably v.0.1.13-beta and/or v.0.1.12-beta) on sudo was attempted before trying earlier versions of the installation file.

    Update: With the above mentioned installation, the UBports installation file can now detect it in macOS. What is left now is that ridiculous "366ms" estimated download time on cable Internet with a speed range of 50-100 Mbps.

  • @n192k001 any progress since you posted that update?

  • @advocatux Not at the moment (unless the same 6hr estimated finishing-time were to be counted). I've had to tend to other things lately and will start again this weekend (by getting a U.S.B. drive and/or a better micro-U.S.B. cable).

    Going back to your question, this seems to be U.S.B. 2.0 given the included U.S.B./charging cable's features (the lack of blue in the connector's large end and the shape of the smaller micro-U.S.B. end).

  • @advocatux Thanks for the suggestin of using a live U.S.B.! I worked! (In fact, I'm replying with the newly upgraded tablet.)

    Now, if I could only get the "Desktop Apps" App to work, things would be perfect. It would be great to finally have Firefox, Open/Libre Office, etc running in the M10. But, following the instrucions seems more complicated than expected.

    With UBports' instructions, even 1-word container identifiers (like 'DesktopCv001') are invalid. (May i ask how containers are identified, then, please?)
    So, I can't get past the 1st line of code on Terminal.

    Yet, what's used here are allowed.
    But, the setup fails due to dependency issues. So, i can't get past the 1st line again.

    I've been doing this on the device itself. Tomorrow, I'll try again on a live U.S.B.

  • @n192k001 first of all, congrats.

    Do you have installed in your tablet?

    How are you typing those commands?

  • @n192k001 I have not followed the instructions in Ubports docs, just the ones in the post you list. First make sure your tablet is in developer mode via settings. Then as @advocatux says install the scope. As for the name that should not matter as in
    --id whatever
    --name whatever
    Just make sure its typed in correctly.
    The problem I had if I remeber rightly was in getting adb shell permission on the bq tablet. The permissions box thing ( trying to remember exactly what it looked like after a year isn't working :)) would not show up when using Ubuntu on the laptop. I could only get it to work on Linux mint. It can be abit frustrating but just read through the post again for how to install the apps correctly and check the typing and spacing of the
    libertine-container-manager create --id whatever --name whatever
    It should then start.
    To install a package is if I remember
    libertine-container-manager install-package -i container name -p package/app
    Good luck.

  • This post is deleted!

  • @advocatux Yes, I had it installed and did typed the commands on the M10 itself.

    @Lakota Thanks for the advice (and the question from a while ago)!

    Thanks to you all, I now have the Firefox, Libreoffice, and even the V.L.C. Player & Ubuntu Restricted Extras I'd forgotten running on my Aquaris F.H.D. with the latest O.S release, plus learned how to use a container for the first time. Thanks again!

    Anyone know when the legacy app.'s are updated?

    Likewise, I tried installing the font manager 'Fonts" to install a modified segoeui.fft, but the installation ended with [code]E: Unable to locate package fonts[/code], so Fonts doesn't appear in Deskop Apps. Is this fixable?