Nexus 5 install file push fail

  • I apologize for not finding my problem elsewhere on the forum. It seems pretty basic.

    I got a used nexus 5. I put it in developer mode and enabled usb debugging. oem unlock was unavailable. I read that there's some kind of '7 day' wait for it.

    I plugged it in, running the installer on ubuntu 16.04. The installer found it, asked me if I wanted it unlocked, and I did so on the phone. Then it downloaded some files and an error message popped up.

    Yikes, cannot push files because blah blah blah (I hit retry without getting a screenshot first sadly). After hitting retry, it was just hanging there for a really long time. After a while I closed the program and tried again with a different usb port.

    The installer now does not recognize the phone, and the phone is stuck like this:

    alt text

  • @ddierkes what OS is running on your phone? What OS is running on your computer? What ubports-installer version are you using (package & version number)? Have you checked you have adb and fastboot installed on your computer?

  • The phone had a new android install on it.
    My computer is running Ubuntu 16.04.
    The installer came from a file called ubports-installer_0.1.12-beta_amd64.deb
    /usr/bin/adb and /usr/bin/fastboot both seem to be on my machine.

  • Install finished. Thank you for your time. Sorry.

  • @ddierkes no problem 🙂

    Congratulations for your new UT phone!

  • Hello everyone,

    I have EXACTLY the same situation as ddierkes had encountered.

    After the "ADB push error: " message below:

    0_1528574720455_ADB Push Error.png

    My nexus 5 is stuck like the screenshot in the original post.

    Mobile: Nexus 5 (brand new and just unpacked)
    Mobile OS: pre-installed original Android OS
    Computer OS: Ubuntu 18.04
    UBports Installer: ubports-installer_0.1.12-beta_amd64
    I can see adb (137.5kb) and fastboot(93.1kb) files in /usr/bin/.

    Now it's impossible to turn off my Nexus 5 (Google logo and lock icon always come back).

    I'd be grateful if ddierkes or somebody could let me know how to solve the issue.

    Many thanks!

  • @robert Try using a different usb port. Start the installer then connect your phone and see how that goes.

  • @Lakotaubp

    Dear Lakotaubp,

    Worked like a charm!!
    Thank you so very much for your advice!!

  • @robert Well done and welcome you UBports Ubuntu Touch enjoy.Have a look here for more info

  • Hi,
    I had the same situation like the first black screenshot posted here.
    I am using Nexus 5 with latest stock Android and Windows 7 on PC.

    I could get into bootloader mode with Poweer+Vol-(-)

    When starting UBports installer, while device in bootloader mode, I came one step further.

    UBports Recovery started on device

    UBports installer on PC shows "Waiting for device to enter recovery mode"

    ...this situation is unchanged since about an hour.
    What can I do?

    best regards

  • @clic ok stop the installer, disconnect your phone. Restart the installer then connect your phone. I had to do this with my nexus. If that doesn't fix it, try another usb cable and or port and do the same again.

  • Thanks @Lakotaubp
    I tried 4 USB-Ports and 3 cables. Always the same problem.
    Then I tried another PC with USB3-Ports. The first one only had USB2.

    Now I could reach the step Pushing files to device.
    There I get this adb push error

    0_1531419458814_Screenshot (108).png

    Could this be a bug in the installer? There is a strange combination of '' and '/' in the file path.

    The mentioned file is existing in the correct path (with '')

    Edit: This forum does not accept the backslash sign.
    ...There is a strange combination of Backslash and Slash in the file path.
    The mentioned file is existing in the correct path (with Backslashes)

  • @clic which installer version are you on, I use 0.1.9(103) on windows. There is a new installer out now try that if your not already.
    If not visit. they will be able to help.
    Sorry but I'm out and only on phone so things a bit awkward at present. Will pop back here later to see how you got on.

  • @clic as @Lakotaubp has replied to your post already, I just want to give you an edit tip 🙂

    Backslash is the escape character in markdown. To print a backslash you need to type a backslash and a backslash 😃 so \\ gives you \

    You can put a backlash between backticks (`\`) to show it as code \ too.

    To learn more about backslash

    Okay, enough backslashes for today lol

  • Solved:
    @Lakotaubp yes, the installer was the problem.
    I used 0.1.13 which is linked here:

    This version has the bug. Then I downloaded 0.1.20 from Github:

    This one seems to be working. Now I have Ubuntu Touch 16.04 on the Nexus 5 !

    Thanks for your support

  • @clic excellent welcome to your UBports Ubuntu Touch phone and enjoy it. Have a look here for some more info

Log in to reply