Cannot install ubuntu touch on BQ M10 ubuntu edition



  • I'm having no success attempting to install ubuntu touch onto a new BQ M10 ubuntu edition.
    My PC is running ubuntu 18.04 LTS.
    Latest attempt was made using the download for snap from the ubp website.
    I've tried about eight or so times and the installer does not recognise the device (which is unlocked and in developer mode) so I have tried selecting manually, checking the wipe option, which then results in the prompt to put the device in bootloader mode by holding buttons.
    On one occasion the M10 entered bootloader mode and the flashing started but got no further than waiting for the device to enter recovery mode.
    Since then the M10 will not again bring up the bootloader screen by holding down the power and vol buttons.
    I think the only way forward is to try and get the ubp installer to recognise the device when it is connected to the pc?
    Is there anything I can try to make this happen?



  • @ziggutas Hi, What version of the installer are you using you can get the latest from https://github.com/ubports/ubports-installer/
    You have ADB tools on your pc and have granted access to your tablet?. Connect your m10 to the pc and in the terminal type adb devices you should see your device.
    Try the installer again with if possible a different usb cable (it can make a big difference) and or usb port.
    If you still have no luck try the appimage of the installer, some have found that to work better. Please come back here or https://t.me/WelcomePlus that's the telegram welcome and install group for more help. The telegram group can be quicker depending on whose about at the time.



  • Thanks, I have tried the appimage before and I have swapped cables and usb ports.
    At the moment I have 0.1.20-beta from mariogrip refreshed. Although the pop-up prompting a refresh comes every time the installer is launched.
    Typing adb devices returns 'list of devices attached' and I can't see anything! Should I ?



  • @Lakotaubp I unistalled ubports installer and downloaded the appimage which I ran from my downloads folder.
    Still no go.
    I've also seen an example of what the adb devices command returns when it recognises something so I guess it is not seeing the tablet?
    Tried two cables and usb ports. Going to look for another cable now...



  • @ziggutas Try the link in my post the latest installer is 0.1.21. Yes you should see your device in the adb list. check you have correct adb tools installed. You should also have had a small dialogue box pop up asking you to grant permission for the pc to access the m10. Try that and see what happens



  • @ziggutas that permissions box was hard to find. I never did on Ubuntu I had to use Linux Mint. Please try the telegram group for help on that I just cant remember how to sort it on Ubuntu at the moment. check how to grant adb permissions on Ubuntu on the net. I really think that is your problem. Sorry can't help further just now back off to work. Will be here later if your still stuck



  • sounds like you are not getting adb connecting,you should get a small window appear in the top right corner asking to ALLOW connections to your pc .
    it will be explain in support ,in one of the previous m10 posts



  • @marathon2422 Agree. @ziggutas use the search feature on the forum to find m10 adb permission post



  • @lakotaubp @Marathon2422 , Thanks. Looked at the M10 post and tried that. No change. But I notice on the github page (link in earlier reply) some troubleshooting info for linux:

    If the device not detected, you might be missing udev-rules.

    See if cat /etc/udev/rules.d/51-android.rules exists and contains the rules below. If not, add them to the file and run sudo service udev restart.
    

    I ran the command and it returned: No such file or directory.



  • @ziggutas https://forums.ubports.com/topic/1385/bq-m10-hd-adb-does-not-work
    https://forums.ubports.com/topic/767/can-t-flash-my-bq-m10-fhd-with-ubports/4
    have a read they might help. there are other adb post on the forum have a search back again later



  • Just a thought ,once you get developer mode ,on, and get the allow box clicked on ,you should reboot,before you run ubports installer



  • And don't connect the device before the installer is running and asks you too



  • Pulsar33 said in UBports for BQ E5 : all you need to know:

    What succeeded (with UBports-installer and Mint 18.3 64 bits) : (for BQ E5 Ubuntu Edition)

    • Power on the BQ E5 and set Developper Mode (SystemPreferences/About/DevelopperMode)
    • Open a Mint terminal and type adb devices : this launches the adb daemon. No device found
    • Connect the BQ E5 (always powered on) to the desktop
    • Type adb devices once more : the device is listed
    • A question appears on the BQ E5 with a key : you have to grant the connexion
    • At this point, launch UBports installer : quick automatic detection !...
    • The installer displays a "Switch to UBports" option : select it then install
    • The BQ E5 is switched to Bootloader Mode automatically
    • Then follow the indications (the password requested is the one of your desktop, not the one of your BQ)
    • 12 files Downloaded (the first one is long with ADSL), then 13 files pushed to the device (quicker)
    • Then the device reboots and installs the files (about 5 minutes), then reboots once more running UBports
      You're done !

    Why should it be different for BQ M10 Ubuntu Edition if you do exactly the same ?
    Best regards. Pulsar33



  • @Lakotaubp Tried what I could from the two links. Nothing changed. Made sure to run installer before connecting. No detect. @Marathon2422 I hadn't tried rebooting the tablet after selecting developer mode and connecting to installer. Tried that, but nothing changed. @Pulsar33 followed your steps to try and see if device would be listed, but no, it's not.

    adb version:Android Debug Bridge version 1.0.36
    Revision 1:7.0.0+r33-2

    I've added the udev-rules suggested in the troubleshooting section for linux on this git hub page
    https://github.com/ubports/ubports-installer/
    but as I'm starting to get slightly out of my depth here...I'm not certain I have done that correctly. Is it correct just to copy and paste those rules as they are presented on that page?



  • @ziggutas Can you try on another pc laptop just to get permissions up from adb? Or if you have a spare usb stick you could create a bootable Linux mint drive and run that on your pc just to get adb permissions up. daft question just to check oem is unlocked ? but the installer would have picked that up. try resetting your device and seeing if that helps.
    Before that stop adb on you pc adb kill in terminal. reconnect your device type adb devices and watch the screen on the m10 closely does the dialogue box show.

    @advocatux can you shed any knowledge on this



  • @lakotaubp Thanks again for all the help. I'm going to have to put it to one side for a day or two; work is getting in the way!Plenty of things to try in your last post and there is no such thing as a daft question when you're talking to me ;).I'm not sure how to check if oem unlocked; isn't that for android devices? Mine is ubuntu edition m10-15.04 (OTA-9.5), no updates possible...I think.

    Will try laptop first, reset device next, Mint after.



  • @ziggutas Sounds good. The installer should sort out OEM unlock but it can be done from the terminal as well. Good luck let us know how uttered goes



  • @lakotaubp Tried connecting device to laptop but no response from adb devices.
    Presumably I should still have tablet in developer mode before connecting? Should I have installer running also? Anyway, I tried with and without installer; no joy.
    Resetting the device made no difference.
    Running Linux Mint 19Cinnamon on usb stick I tried to adb, nothing, and tried running ubports-installer (appimage) and connecting device; nothing.
    I'm curious to know what would be the set up for trying OEM unlock from terminal?



  • @ziggutas first run his in the terminal to check your adb

    sudo add-apt-repository ppa:phablet-team/tools && sudo apt-get update
    sudo apt-get install android-tools-adb android-tools-fastboot

    Then connect your tablet and type adb devices you should see your m10 and or see a dialog box to grant permission

    You may have done that already, anyway
    sudo fastboot oem unlock
    should do the trick



  • @lakotaubp Ran the commands; already had the latest versions. Tried adb: nothing.
    Sudo fastboot oem unlock got nowhere. Just 'waiting for any device'.

    Plugged my phone in (bq e4.5, ub touch 15) typed adb devices and it was listed straight away with a pop up window on phone screen also. So pc side of things appears ok.

    Tried once again running ubports-installer and choosing device manually but failed at the prompt to press vol and power buttons to go to bootloader. Tablet always ends up rebooting normally to the 'bq powered by ubuntu' screen.

    This makes me think something may have changed in the tablet the very first time I pressed vol,power and installer appeared to be working bu then got stuck at recovery mode and would go no further...?


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.