Moving to UBports now



  • Due to a hardware fault (the touch screen of my BQ E4.5 does not respond to touch in 90% of the surface) I will now definitely move from OWA15 to UBports. I was lucky to have had already configured some other E4.5 to r3 (December 2017) and so I have just moved my contacts to this and can continue to have a mobile for calls, Dekko and as hotspot for my daily usage. When the faulty E4.5 returns from bq.com (they offered to replace the screen), I will update this to the most recent version of UBports.

    I'm missing a lot of apps at the moment, which I have had on the OWA15 device, mostly:
    SensorStatus
    Knowndict
    Is there any way to get them back? A search in the OpenStore does not work either.

    Thanks, Matthias



  • @guru sensorssatus is in the OpenStore https://open-store.io/app/sensorsstatus.chrisclime but I don't know about the other one, this is the first time I hear it.



  • I updated the OpenStore app in the E4.5 and now the search works better. I could install sensorstatus from there.

    KnownDict is here https://launchpad.net/knowndict but I have to look for a click pkg...





  • KnownDict was running as an app on my OWA15 device and have had support for the so called StarDict files, i.e. for dictionary files in that format. I own a Spanish dictionary of around 100.000 words. This is not to translate from, for example, Spanish to English, but to get the correct spelling and explanations of a given word, and examples of the usage. I really miss that. I will write an email to the old list, maybe someone has a backup of the click package...



  • @guru I have good memories of knowndict as well! Seems its enough to

    bzr branch lp:knowndict
    cd knowndict 
    clickable --sdk 16.04
    

    I get through the wizard. But I cant remember anymore how to put a dictionary in there :-P



  • The click tar contains two dictionaries:

    share/qml/knowndict/pre_installed
    share/qml/knowndict/pre_installed/langdao_ce
    share/qml/knowndict/pre_installed/langdao_ce/langdao-ce-gb.ifo
    share/qml/knowndict/pre_installed/langdao_ce/langdao-ce-gb.dict
    share/qml/knowndict/pre_installed/langdao_ce/langdao-ce-gb.idx
    share/qml/knowndict/pre_installed/langdao_ec
    share/qml/knowndict/pre_installed/langdao_ec/langdao-ec-gb.idx
    share/qml/knowndict/pre_installed/langdao_ec/langdao-ec-gb.dict
    share/qml/knowndict/pre_installed/langdao_ec/langdao-ec-gb.ifo
    

    Check, where they endup in the mobile. IIRC, it's enough to make a new dir and place the three files into it.
    Will later check, if I find a slot in time....



  • Terence Sambo from the old ubuntu-phone mailing list, compiled a click for me and I installed it with

    phablet@ubuntu-phablet:~/dict$ pkcon --allow-untrusted install-local knowndict.benyfu_0.1.3-15.04_armhf.click
    Installing files              [=========================]         
    Finished                      [=========================]         
    Installing files              [=========================]         
    Starting                      [=========================]         
    Finished                      [=========================]         
    Installed   	knowndict.benyfu-0.1.3.armhf (installed:click,removable=1,app_name=KnownDict)	summary goes here
    phablet@ubuntu-phablet:~/dict$ sudo click register --user=phablet 'knowndict.benyfu' 0.1.3
    [sudo] password for phablet: 
    phablet@ubuntu-phablet:~/dict$ 
    

    The rest was just importing my dictionary via the file manager app.

    A big thanks to Terence!

    Matthias



  • @guru said in Moving to UBports now:

    A big thanks to Terence!

    You're very welcome! :)



  • The broken E4.5 returned from bq.com today, repaired (they swapped the screen for 120 EUR). It runs some version of UT.

    How can I update this to the most recent version of UBports? I have no M$ laptop, only FreeBSD and some older Ubuntu 15.x

    Thanks



  • @guru The installer should work with ubuntu 15 I think, if you have any issues try an older version of the installer like 0.1.12



  • I've downloaded the file ubports-installer-0.1.21-beta.freebsd and can have a look into it with

    $ xz -dc ubports-installer-0.1.21-beta.freebsd | tar tf -
    +COMPACT_MANIFEST
    +MANIFEST
    /opt/ubports-installer/LICENSE.electron.txt
    /opt/ubports-installer/LICENSES.chromium.html
    /opt/ubports-installer/blink_image_resources_200_percent.pak
    /opt/ubports-installer/content_resources_200_percent.pak
    ...
    

    How is this to be installed and used on FreeBSD?

    I tried to rename the archive to the normal file name for FreeBSD packages, integrated it in my repository and tried to install it, which gives:

    # mv ubports-installer-0.1.21-beta.freebsd /usr/local/PKGDIR.20170304/ubports-installer-0.1.21-beta.txz
    # pkg repo /usr/local/PKGDIR.20170304
    pkg -R /usr/local/etc/pkg/repos/ install ubports-installer
    Updating FreeBSD repository catalogue...
    meta.txz                                 : 100%  264 B     0.3kB/s    00:01    
    packagesite.txz                          : 100%  418 KiB 428.5kB/s    00:01    
    Processing entries:  88%
    pkg: wrong architecture: linux:4:x86:64 instead of FreeBSD:12:amd64
    pkg: repository FreeBSD contains packages with wrong ABI: linux:4:x86:64
    Processing entries: 100%
    Unable to update repository FreeBSD
    Error updating repositories!
    

    Can the dev who created this archive please contact me? Thanks.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.