Why some xenial webapps don't work



  • I've previously built two or three webapps for vivid which worked fine. I used webapp-creator and I also tried clickable. I recently acquired a Nexus 4 and installed xenial. I then tried to build the webapps that I made for vivid.
    Using webapp-creator, two of them worked fine and one didn't. I then tried clickable for the one that didn't work. It still didn't work properly. I could get to the site, but the video content wouln't play. I made several attempts using webapp-creator and also clickable. They all failed.
    After much head scratching, I tried accessing the website in question by simply typing the url into the browser. This method worked fine on vivid, but not on xenial. I also tried browser-next, but this didn't work either.
    So I concluded it might be a browser problem and I tried accessing the offending website from my ubuntu 18.04 laptop using firefox. This time everything worked perfectly.
    I report this in the hope it may save someone else some grief.
    The website in question was the BBC iplayer website at www.bbc.co.uk/iplayer.
    I guess the problem was due to the fact that the BBC iplayer website incorporates controls to ensure that only registered users can access the video media.
    Please note that videos on the BBC iplayer website are only available from within the UK.



  • @dtarrant Though it would be more usfull here than in support.



  • With the arrival of OTA 5, I investigated the behaviour of Morph Browser with regard to its compatibilty with the video content of the BBC iplayer website. I discovered the browser is unable the play iplayer video unless I use settings to enable desktop mode, in which case the videos play perfectly.

    However my webapp-creator generated BBC iplayer webapp still won't play the video material whether or not morph browser is set to desktop mode.

    I made a webapp for the BBC News website which plays video via morph browser perfectly without the use of desktop mode.

    I'm baffled and would really appreciate some help with this.



  • @dtarrant if the videos play fine in desktop mode, you could try to play with the user agent string in webapp-creator and avoid any reference to mobile.



  • @advocatux Thanks for your suggestion. I assume morph browser should be left in normal mode except when running my BBC iplayer app. So my question is how is it possible to control the display mode of morph browser from webapp-creator/BBC iplayer? You refer to user agent, but I don't remember seeing anything about that whilst running webapp-creator. Did I miss something?



  • @dtarrant I remember that option was available when using Ogra at least but I don't know if it's the same for the default system in webapp-creator.

    Have you seen this https://github.com/Jujuyeh/webapp-creator/wiki/libwebappcreator-(English) already?



  • @advocatux I'm not using ogra at present. I didn't need that for my BBC News webapp, so I decided to stick with that approach for BBC iplayer.
    I've had a quick look at the material on user agent strings at the link you provided. It seems complicated and will require careful study.
    In the meantime I discovered that I hadn't upgraded to OTA 5 and was still running a recent rc. So I upgraded to OTA 5 and decided to try webapp-creator again.
    This time it ran and informed me that my click package had been successfully created and was at
    ~/.cache/webapp-creator.......etc, but it wasn't there. I tried again and the result was the same.
    It seems that webapp-creator may have been broken by the upgrade. I wonder if anyone else has had the same problem? I tried re- installing webapp-creator, but the problem remained.



  • @dtarrant
    in the myapp.apparmor you must insert the "video" and "audio" permissions (see the documentation).
    the file myapp.manifest must copied to manifest.json .
    so i tested this on my ubuntu-phone in terminal whith " click build ." ; then i have the myapp.click which can be installed by ut.tweak-tool or by using "pkcon --install ..." . After this you can test your application before uploading to the store



  • Hey, I also have big problems with uMastonauts. The webview crashes every time I start it. Switching to import Morph.Web 0.1 does'nt work. The app is useless until I know how to fix this but I have no idea. :-(

    Is there a working example webapp with the morph browser engine where we can look how to do this?



  • @ksalver Are you talking about using clickable? When I use webapp-creator things are simpler than you imply. When I created my BBC News webapp, I just filled in a few things in a template. I didn't encounter json or apparmor. I then installed using ubuntu tweak tool and everything worked fine including the video as long as I had chosen simple webapp and selected the multimedia option. I only used the terminal on a previous occasion when I tried out clickable. That worked, but seemed like overkill compared to webapp-creator for a simple webapp. It was more like a tool for power users.



  • @krille I've built 3 simple webapps using webapp-creator that work fine, including video, with morph browser. These are not in openstore. I made them for my personal use, but I could telegram you the click packages if that would help.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.