OTA-6 Call for Testing

  • @advocatux Well. After a while, finally found it. It was not obvious... So, cleaned all items of system settings. It did not help.

    More ideas, anyone?

  • @kwah hmm... you can try to install UT again on your device using the installer but without checking the wipe option.

    You can also try a "factory reset". I don't remember the exact words in English, but it's in System Settings > Reset > Remove & Reboot (or something like that).

    If you decide to do this DON'T FORGET to backup of all your data.

  • @htc_tattoo I have this problem now also on the Nexus 5. If I open a lot of apps (more than 4), switching between them, the morph browser crashs and start empty again (open windows are away). The same happens on the BQ E5 always with even 2 apps.

    @advocatux Probably such a swap solution would help 😉

  • @Mic_

    While you are seeing the same behavior, the semantics are different. When Ubuntu Touch runs out of memory, it will kill an app and retain a screenshot of it in the app switcher. The app is not crashing, but it does need to handle this situation better. You may want to file a bug on morph-browser since it does not restore open windows when it is killed due to low memory.

    zram may help a little, but really the problem is that the system and apps are using too much memory, and you may be expecting a bit too much of your device. I've put in a PR to re-enable zram on the E5, but it will not be merged until after the OTA-6 release.

  • Alarm clock really does not work. Today i checked again, 11 minutes after the alarm there was just a notification that i missed it. No vibration, no sound (should do both on very low volume).
    Nexus 5, actial rc image. Please check it, it's a bug.

  • @htc_tattoo

    I believe you. I've been checking it. I've tried to reproduce the problem and I've asked people who have complained about it before to do the same.

    With that, I must say that "Please check it, it's a bug" makes me a little upset. It's mostly due to my own failure to reproduce the problem. I encourage you to file a bug rather than complain about issues on the forum. That gives us a better place to talk about it than a thread like this where lots of people are giving input. Also, you said the issue started occurring a couple of weeks ago? Did you mention it then?

    For relevant log files, let's start with the standard ones at Contribute to UBports - Bug Reporting. Please follow the instructions there to file a bug. Some more relevant information... Is the device plugged in when the alarm is missed? What is your "missed alarm time" set to in Clock settings? Does the notification you missed the alarm appear after that time? Does the alarm always fail to ring, or only sometimes? Do you use your device heavily before the alarm fails to ring? There's a lot of information that is potentially relevant that we just don't have here.

    I understand this issue is upsetting to you. I'm sorry I haven't been able to reproduce it. Please help me by following the normal process to file a bug report so we can get more opinions.

  • Don't be upset, I'm not complaining. I just wanted anybody to confirm if this a problem in N5 devices with OTA-6 or if it is just my phone.
    Thanks for putting the link for bug reports, i opened a new issue. In my opinion something from W46 to W47 changed in the software that causes this.

  • @htc_tattoo sorry cant reproduce either. Two alarms set worked as expected RC version 26 (W28).

  • @htc_tattoo No problem for me with N5 with RC version 26 (W48)

  • Today no alarm again, just the indication light and the green letter showed it some minutes later. My alarm settings were ok, i checked them yesterday. (it showed how many hours and minutes left until it will ring). Today by chance i saw on the indicator of the lock screen (this round wheel) that it showed 0 alarms. I erased my alarms and set a new one with the same settings. Turned screen off and on again, now 1 alarm is shown. Let's see if it works tomorrow.

  • I use alarm clock daily (charging to 80%) with BQ E5 and Nexus 5 (both with 16.04 RC) and I never had problems with it. But sometimes in the past the symbol was shown even if the alarm was not set.

  • @htc_tattoo my Alarms working fine too. have you checked the alarm volume setting in the settings of the clock? just to be sure...

  • Today it worked again, erasing all existing alarms helped.
    As i yesterday erased my alarms and made a new one (with the same alarm settings, did not change anything in the alarm clock settings like volume) it seems that existing alarms were ignored after an ota update. (They were not shown on the lock screen indicator ether).
    So there might be the risk that ota-6 will mute some alarms.
    Let's see if it works until friday...

  • I reverted back to my OPO today as there has been a regression in the call sound on the Pro 5. Both are now on xenial RC 2018-W48.
    While setting up OPO again, I noticed that GPS location is not working. I get "GPE denied" in e.g. uNav. Is this a known issue or should I report it?

    I can add that I get "Access error" in SensorsStatus.

  • @tomoqv Can you try it on the dev channel first ? I have no location issues with my OPO dev (641). Everything is on as far as location settings go and access allowed to uNav? I know this obvious and I'm not trying to be insulting, haven't seen this specific to OTA6.

  • @Lakotaubp Thanks, that did it! GPS kicked in right a way.

  • @advocatux Thanks for the tip. Reinstalled 16.04 / stable. Got switcher back... Will try rc 😉

  • @tomoqv Glad you got it sorted. Just out of interest was it the switching to dev that fixed it? If so and only when you have time and or feel like it what happens if you go back to RC.

  • @lakotaubp Yes, switching to devel fixed it. I may have time to go back to RC during the weekend. If so, I will report back.

  • @tomoqv Thank you

Log in to reply