Nexus 5 flash fails; Universal ADB Driver installed - 32-bit Win 7 Pro SP1

  • @rvan good luck patience is required yes. Don't forget the usb cable thing though new ones are not always the best.

  • I was able to download and install v 1.4.3 of the ADB tool you referred me to. Installation of this utility appears to have completed successfully. I am concerned about the message that I was to continue with installation of the driver??? Additionally, this utility does not appear in the "Programs and Features" list in the Control Panel. Is there any way I can confirm this utility installed correctly? In fact, I am certain this installation did not proceed successfully because, when I connect the N5 to the PC it is not recognized. The Universal ADb Driver did perform this task correctly. Other than this, no change in my results. I could not get Telegram to cooperate either...

    I did try a second USB cable for the sake of begin thorough but, this had no impact on my experience. I also closed and launched the UBPorts installer a few times. No progress.

    I was not able to locate sources for the older versions of the UBports installer. I checked GitHub.

  • @rvan Try running sudo OEM unlock just incase from terminal. Adb will be started by the installer. You should be able to check adb us working by connecting your phone and start Adb ( sudo adb start) from the terminal then type adb devices and it should detect your device then do the OEM unlock. Then try again.

  • @Lakotaubp - I am using 64-bit Windows 7 Pro sudo. However, I installed Ubuntu 18.04 LTS on this laptop so, it is a dual boot machine, last evening in preparation for more unanticipated issues with this. I guess it's on to Linux!

  • @rvan use the command window and type adb devices. Soy should see a list with your device on it if not you need to install the right driver (might be the one you didn't ). This might help found this very quick so not vouching or endorsing etc. etc.

  • @Lakotaubp - No. You are going too far. You must understand the constraints I am working with. I may not be explaining these well.

    The adb utility you referred me to is not installing or, executing properly. I have been trying to use v1.4.3 because, it is stated to be for Android 6+ and this is the version of Android currently on my N5. After answering "Y" to the first to questions after running the executable in Windows (Note this version of the utility only runs, it makes no attempt to install in Program Files.) I see a message stating 0 files copied. This is not correct. I attempted to install adb-setup-1.3 and this worked as desired. (4) files were copied and the installation proceeded as you see in many blogs regarding this topic. Okay. Good to go on the "15 s adb installer" yet, this should be the wrong version as Android 6+ is supposed to use v1.4.3.

    Universal ADB Driver - I navigate to this via the Start menu choice for All Programs. ClockworkMod appears here and a shortcut titled "Start ADB Server" is listed under this. I have both used this shortcut to start the server and chosen not to use it. This is because UBports installer is supposed to start this.

    With the N5 connected to a USB port I see "Android Device" in Device Manager. This says Google Nexus ADB Device beneath it.

    On to UBports installer - I launch it, connect the N5 to the USB port when instructed to do so, N5 enters USB Debugging Mode, I choose "Select device manually" because, I have been unable to locate any setting resembling OEM Unlock in the Developer Options in my N5. Next, I select Nexus 5 from the pull down list and I am ready to install. I press "Install" and then place the N5 in Bootloader mode. Bootloader screen is displayed with this information. I think lock may still be an issue despite my recent progress.


    Still, installation does not proceed. Are you suggesting I boot into Ubuntu, connect my phone to USB then execute the sudo OEM unlock then, resume trying to flash in Windows?

    Edit - I just found this reference discussing unlocking the N5 bootloader.

    I do not know if this is correct or definitive.

    I installed SDK Tools earlier today but, I find typing "adb devices" echo's back the message, 'adb' is not recognized as an internal or external command, operable program or batch file. I have no idea how to resolve this issue but, I can tell you I have launched a command prompt window from both my "sdk-tools-windows-4333796" and "sdk-tools-windows-4333796/tools" directories and I obtain the same result.

    I need to determine what is going on with SDK Tools and the v1.4.3 of the 15s adb installer.

  • @rvan I understand where you are and you need to unlock your device. With windows use their Command Prompt tool (terminal in linux) and with the device connected type start adb then adb devices. That will list your device. Then type fastboot devices you should see your device then fastboot OEM unlock, which should unlock your device. Lastly fastboot reboot. After that if you run fastboot unlock-info it should return true.
    Then just run the installer.
    One way to open the Command Prompt is to go to the adb folder(it will be in downloads) open it right click somewhere blank and choose the option to open here. Think I just used the search box. Good luck

  • Everything I have found indicates unlocking is best done before any other actions are taken with the N5 and requires the SDK and Platform Tools. I have these installed but, discovered they are not consistent versions. Presumably, I am okay with the "unlock the N5 right away" requirement but, I cannot confirm. I suspect this is one of the better threads regarding this subject matter:

  • @rvan You only need bother with the Information section, number 1 Unlocking the boot loader. You've done the rest. Same as my post above really.
    Then you can try installer again.

  • If I can jump in here. I too am having problems with the installer on an N5. After much buggering about, I managed to get it to do the fastboot part, but when it reboots into UBports revovery, the installer fails to detect it. I have run "adb devices" at this point and it is quickly detected and that it is in recovery mode. I wonder if the installer is putting the "./" in the adb commands?
    I have used three different PCs and installed Ubuntu on one, also several different cables, all to no avail. I fear the installer is the problem.

  • @judderman2 what ubports-installer version are you running, and for what OS?

    Anyway, try to unplug and plug again the phone when you're stuck in that recovery step. Sometimes adb and fastboot fight too much for the same space 🙂

  • Thanks for your reply. Mostly Win10 64, but also Win7 64 and Ubuntu something or other. Yes, have tried unplugging and replugging, still no joy, shame as I'm really looking forward to trying it, so fed up with Googley andwoid. Loved WebOS, it got killed, BlackBerry 10 was decent, it got killed, SailfishOS shows promise, but need to have android apps support, so not ideal; please, someone, spare us all from android

  • Installer version 0.1.21-beta

  • @judderman2 one pretty common issue with windows is that the necessary tools are not in the user's $PATH. Check that or run the installer with admin powers

  • Always run installer as admin. Fastboot and ADB installed globally, but have also tried putting the path in.

  • @judderman2 you can try an older installer version then. This version for example has a great success rate on windows

  • ok, thanks, i'll give it a go and get back to you

  • @judderman2 good luck!

  • Nope, same thing, goes through fastboot stage quite quickly (after manual selection, never auto detects), reboots into UBports recovery, but installer doesn't see it. Are files available to flash with fastboot, or is it o different to android that that won't work?

  • @judderman2 is there anything relevant in the installer log?

Log in to reply