Help testing new legacy image

  • I'm trying to install the new images on a Bq E5. I'm able to get into fastboot mode in my phone, I connect the phone with an USB cable to my Ubuntu system (I'm running currently Ubuntu 17.04), but it seems that my Ubuntu system does not see my Ubuntu Phone. Nothing appears with "lsusb", and when I try the "ubuntu-device-flash" command, it says it is waiting for the device to be put into fastboot (which it is) and does nothing.

    Can I flash the image directly from the phone? I can upload (with ssh) the "img" file to my phone, so if I could I would do it directly there.

  • @wgarcia

    If fastboot devices doesn't detect your phone while it's booted to the bootloader, try a different USB port and USB cable. Ensure you're plugging in to a USB 2.0 port on your computer.

  • @UniSuperBox Thanks, it turned out I had changed to mtp only with the tweak toool, when I changed to USB I could mount the device and now I'm flashing the uBport image, crossing my fingers....

  • Yes!, success!, I'm in the uBports ship with my BQ E5!

  • @wgarcia Congratulations!

  • Has anyone tested the Aquaris E4.5? My Aquaris I use as a main phone, so I have some fear of flashing the device

  • @wgarcia What is the restoration procedure?
    should you install openssh-server on the phone?

  • What I did is the following. You do not need to install openssh-server, you just need to enable the ssh client in the phone. Get a shell with "adb" and execute this command:

    android-gadget-service enable ssh

    I also use an application called "net-info" to figure out the IP of my phone in the network where it is connected through wifi, say it is

    So before wiping out my data I make a copy in my computer of /home/phablet, say in a directory called bq-phone in your home:

    rsync -avz - - delete -e ssh phablet@ /home/myuser/bq-phone

    This will create a directory called "phablet" in "bq-phone" with a copy of what you have in your phone. Of course you could do this I believe in a SD-card directly in your phone, in this case without "ssh".

    Now, after reflashing the phone, I followed these steps:

    1. I created a passcode and enabled developer mode
    2. I accessed again to a shell in my phone and enables "ssh" again
    3. I copied the public gpg key from my computer to /home/phablet/.ssh/authorized_keys. For this one I had to "adb push" to the phone the file ( generated in the .ssh directory of my computer), and then append it to the authorized_keys file:
      cat >> .ssh/authorized_keys (this in the phone shell)
      Then I installed first net-info to figure out the IP of the phone again, so that I can use ssh.
    4. I reinstalled all the applications that I had.
    5. Then I used rsync to restore all the data in the phone:
      rsync -avz - - delete -e ssh /home/myuser/bq-phone/phablet phablet@

    I restarted the phone and voilà!, everything looks exactly the same, but I'm running now the uBports image.

  • Sorry, in my explanation above, the gpg-key upload and appending to authorized_keys in the phone has also to be done when you first enable ssh to backup your data.

    I just flashed my BQ E4.5 about 5 minutes ago and it works fine.
    But be aware, all your data and contacts will be deleted, it's like a brand new phone from the factory.

    I just downloaded the image, where the link to that image is on this site:

    I set the phone to developer mode and connect it via USB to my computer.

    Then I enter in the Terminal:
    adb reboot-bootloader
    This takes some time, until the phone was in fastboot mode.
    On the phone was ablack screen, where at the bottom is a very tinny like written "fastboot"
    cd Downloads # where I stored the downloaded image
    sudo ubuntu-device-flash --server= touch --channel=ubports-touch/legacy --bootstrap --recovery-image=./recovery-krillin.img

    After 3 minutes I can see in the terminal:
    2017/05/15 16:53:16 Rebooting into recovery to flash

    Then the phone reboots, which took some other minutes.
    After it was initialized, you can see the phone booting and the ubports logo.
    Phone is up and running.. 🙂

  • @WLBI Thank You!

  • I tested a little bit the mx4.

    • WiFi: OK
    • Camera: OK
    • Flashlight: OK
    • BT connection to Ubuntu Desktop: OK
    • lockscreen notifications: OK
    • phone crashes when App is allowed to use a device for the first time:
      • utorch: Phone crash when allowing access to camera service for the first time (worked after boot)
      • unav: phone crash when allowing access to navigation data for the first time (worked after boot)

    Not tested: Phonecalls/SMS as the phone does not recognize SIM anymore (hardware defect)

  • @sk Didn't crash for me, but I had this issue when I was using CM13 and Ubuntu dualboot on my phone.

  • @zubozrout said in Help testing new legacy image:

    @sk Didn't crash for me, but I had this issue when I was using CM13 and Ubuntu dualboot on my phone.

    How did you managed dualboot? I would love to dualboot my fairphone 2 with FP OSOS and UT. Than i could help testing whithout being lost in business access.
    I looked into EFIdroid a little bit which seems promising at least for someone with Mord development skills as I have.

  • Joining in (fairly) late ...
    I own a M10 FHD, I'm willing to switch to UBports and help with bug reporting and such. However I feel like I need a more detailed flashing guide ( something dumb proof ...) or at least some link with information about the procedure and requirements.
    I truly appreciate your effort, keep the ball rolling!

  • I migrated bq e4.5
    to ubports channels,but the location does not work,missing the scopes own bq.Any solution?
    I have reflashed two times and still the same.

  • I would love to test UBports on M10 FHD, but as I see it: "Status: Update fails, tested", I'm not that eager to test it. I presume that at the moment there are some issues to install it on the tablet. Am I right? If that is the case, then I will wait for the image that will work/install and test it then.

  • @mariogrip since the M10 and Meizu devices are currently not in core, legacy or development in the device list how should you see them.
    And back to another question where can you read some release note ex which feature / bugs that been fixed?


  • Besides being a happy monthly patron and funding device supporter of the FP2 I would like very much help testing the legacy image.
    Due to business requirements I am not able to switch fully to UT for the time being and flashing/backing up/restoring vice versa is too inconvenient for me. If a multi boot option would be available I would be able to switch as often as possible to UT.

    Furthermore I think, that providing multi boot options would gain more users anyway. In 2007, when switching to ubuntu on my desktop it helped a lot to have my Windows OS as backup in the first weeks.
    I know that it is to early to talk about apps because you guys have to generate the stable core framework first, but I think in terms of stability it is good to have as much devices running UT as possible as soon as possible.

    I am not a developer, but I am a very experienced user. So I would be able to help a little if one developer who at least is able to give a little love to e.g. this approach will accompany .

Log in to reply