[SOLVED] Impossible USB tethering (standard, not reverse) connection



  • Hello, this story begins here, but I will go to summarize it shortly.
    Setting:
    device BQ Aquaris E4.5
    OS UBports Ubuntu 16.04 (OTA-7)

    After the upgrade from the last Canonical Ubuntu Touch release to UBports Ubuntu 16.04 (OTA-7) I'm not able anymore to activate USB tethering and use my phone as a USB modem. If I run

    android-gadget-service enable rndis
    

    it correctly returns

    rndis enabled
    

    and my computer (Ubuntu 16.04 LTS) starts trying to connect to the cabled network, but it actually never gets an IP address (despite an enp0s29u1u3 interface appears). From phone terminal there is no visible interface about this connection. Wi-Fi hotspot works fine.
    I don't have another computer to try, but I will try at least with another OS.
    Let me know what else can be useful to debug this problem.



  • @jumpy88 probably this is a stupid question 😁 but have you tried with a different usb cable?



  • No question is stupid when debugging 😉
    I haven't tried (I will) but the one I'm using is the same I used to install UBports UT, and I had no problem.





  • Ok, for completeness I've tried another cable and I'm experiencing the same issue. Moreover, both of them work fine for MTP.



  • @advocatux ok, I think we are done. In the previous OS version I had on my phone

    android-gadget-service enable rndis
    

    was enough. Reading the guide you posted I found out there is a

    sudo tethering enable
    

    to be executed. I tried and now this post is flowing through my BQ E4.5 🙂
    Now I have just two more questions: before to see the command I had already enabled RW permissions on my device. Is there a way to go back to RO without reinstalling the OS or is it impossible as described here? Should I be scared of having a RW OS or is it ok?
    Thank you for the support up to here.



  • @jumpy88 you're welcome. The easier way to switch from ro and rw and vice versa is using UT Tweak tool 🙂



  • @advocatux ok, thank you, I'll have a look in that. For now I think it's enough today 🙂

    Just to summarize:

    • no need any OS modification
    • no need developer mode enabled
    • just run on phone terminal:
    android-gadget-service enable rndis
    sudo tethering enable
    

    ps Would it be difficult to integrate this with the network menu? It's a pretty common feature to require.



  • I understand this correctly? You are trying to use your phone's internet connection as your desktop internet connection via USB cable?
    And you were able to make it work?
    because I filed this bug long time ago after the xenial switch because it stopped working. In vivd, switching in the UT tweak tool was enough.
    Do you mean ```
    sudo tethering enable



  • Hello @kugiigi, yes you understand correctly. I guess UT tweak tool just calls

    android-gadget-service enable rndis
    

    because I have tried it and I see the same behaviour. After that you have to call

    sudo tethering enable
    

    and it should work. Remember to do both, not just the second one, and it is necessary each time you switch to MTP.



  • @jumpy88 oh I see, that's good news then.
    I will try it on my phones and see.
    If we can confirm this, then we can add this information in the bug and maybe close it.
    And add a bug in UTTT 🙂



  • @kugiigi already added in the bug report 6 minutes before your last post 😀


Log in to reply