Desktop apps

  • @Lakota said in Desktop apps:

    @doniks Thanks for the help
    Yes lock screen off.
    Yes cable allows access to folders
    Yes tried different ports and cable

    ok, that's all good.

    Yes other phone used. Nexus 5 to create libertine container and install apps (succeeded).

    ok. I assume you mean you did create the libertine container via adb,
    right? In that case you know the usb cable and port are ok.

    Yet too try recovery

    ok. try the adb_usb.ini tip below first

    Does adb device say anything? What happens in the output of dmesg when you plug in the device? Does the output of lsusb differ between the device plugged in / not plugged in?

    adb nothing, or on device screen.
    The next two I need to look up how to do.

    Ok, I wasn't clear enough. Sometimes there is a problem with adb:

    Follow steps 1, 4, 6, 7 here:

    The M 10 is running the latest ubports r2 stable.


    adb message device unauthorized. Please check the confirmation dialog on your device. No message on device.

    I don't understand what you are saying here. Is that the output of a command?!

    Also don't have another laptop. Mine is running Ubuntu 17 32 bit.

    No need anymore, it seems clear that cable and port are ok.

    Oh and phablet- shell did nothing at all.

    I think phablet-shell relies on adb, so if adb ain't working phablet-shell won't either.


  • @doniks Thanks will read through the link info later. Sorry about the other bit, when using adb the message β€œdevice unauthorized etc...” comes up in the terminal and theres no confirmation dialog on the device.
    Thanks for the help

  • Just for info tried my Bq 5. Same problem when running adb shell. deamon starts running on port 5037. Then error: device unauthorized. Please check the confirmation dialog on your device.
    Legacy device issue? Just going to have a look at info above will see what happens.

  • @Lakota said in Desktop apps:

    error: device unauthorized

    I've had this problem once. I think it can have multiple causes, but in my case it disappeared when i switched my pc to Ubuntu 16.04.

  • Solved the problem on m10. Used Linux Mint. Started adb got the dialog box on the m10 to authorize and away we went. Also after installing on the m10 libreoffice opened unlike on the nexus 5 where it shuts back down again. This is not in convergence mode just on the tablet.

  • Have just used Mint again to create a container on my Bq 5. All went well all seems to work fine. Also used Mint to remove and reinstall the container and apps on the nexus 5. No change there they just crash on opening still.

  • @tager18 Same log results that I got. Did you create a bug report or found away around it at all.

  • Hello. I tried to install firefox following the guide but the app justs open and then closes itself. This is in my N5.

    If I want to completely remove the container and recover the disk space on the phone . I just have to run libertine-container-manager destroy right?

    I tried to only remove firefox by running libertine-container-manager remove-package firefox but it doesnt work. Of course I am doing something wrong.. but well.

    thank you all in advance.

    EDIT: ok, sorry for my stupidity. with libertine-container-manager remove-package -p firefox its how to uninstall and app... I will keep clean this for now.

  • @malditobastardo I think you also need to include the container identifier as well as the package one.
    Libertine-container-manager remove-package -i container name -p Firefox.

  • @Lakota OK all sorted

  • For me, the command libertine-container-manager create --id ubuntu --name 'ubuntu' didn't work.
    What worked for me is: libertine-container-manager create --i ubuntu --n myContainerName.

    Just to give an advice, in case somebody get the same error I got typing the first command.

    P.S. I installed Firefox, Inkscape and LibreOffice up to now and everything work like a charm...really impressed.

    Thank you for the procedure.


  • @matteo Good. What device device are you using ?. Mine work on the Bq devices but wont run on my nexus 5

  • @zubozrout Hi. Thanks for this "How to" - it's very useful.

    I have a Libertine container. And I have two apps showing in it. However, when I click on either app, they don't boot. Did I miss a step?

  • @3arn0wl If your using a nexus 5 they wont run but they should all work on the Bq devices. Dont know about the others as I don't have them.
    Not sure about a fix for the nexus as yet or even what the problem is.

  • πŸ™‚ Thanks for that, @Lakota - I am running Touch on a Nexus 5.

  • @Lakota I have BQ Aquaris E5. I installed also Gimp and it seems working good.

  • Yeah I can confirm that libertine is not working -well at least- on the N5.. (not at all for me)

  • I'm now running r12 from the release channel. The Xapps still don't work on the nexus 5. Has anyone tried to delete and re install libertine container to see if that fixes it? If not I'll give it a go in the next few days

  • When you say that it does nothing, does the script literally output nothing and then quit? Or does it attempt to run debootstrap and debootstrap fails?

    You may possibly be able get away with remounting your root as read-write using sudo mount -o remount,rw / and then reinstalling libertine from the overlays using sudo apt-get --reinstall install libertine python3-libertine-chroot python3-libertine libertine-tools liblibertine1 which should reinstall ALL of the libertine packages (mind you I made this list from my 16.04 WSL so this list may differ from the list in 15.04 stable-overlay).

    After reinstalling, try building a container using a command like libertine-container-manager create -i applications -n Applications -t chroot with no other options (for instance, the distribution argument is useless on our systems because if you aren't using an LXC container for libertine, you are restricted to Vivid.

    I'm actually wondering if your libertine installation is for some reason attempting LXC containers (what version of Ubuntu are you running 15.04 or 16.04? That could tell us a lot, 16.04 SHOULD attempt LXC by default since 16.04 should support LXC.)

    As for device unauthorized, open System Settings and go to Developer Mode options, then revoke all authorizations and plug it back into your machine, see if you get a device authorization pop-up on the tablet.

  • @Tonoxis Thanks for the advice. I am currently on 15.04 r14 on the RC channel and have not tried a reinstall since swapping over from stable. As mentioned above(somewhere πŸ˜‰) I used the same process as on my bq m10 and 5 hd and they are both fine still and both are on RC now. So it still appears to be a nexus 5 issue.
    Will give it a go over the weekend. Thanks again.

Log in to reply