Won't boot Ubuntu Touch on Nexus 5



  • @floki just to have it as a general checklist, take a look to https://forums.ubports.com/post/21219



  • @advocatux said in Won't boot Ubuntu Touch on Nexus 5:

    @floki just to have it as a general checklist, take a look to https://forums.ubports.com/post/21219

    Very help, thank you! I will need to flash the factory rom and start over since I can't get back into android since the last time i tried flashing ubuntu. any recommendations on specific usb cables that have worked for you?



  • any recommendations on specific usb cables that have worked for you?

    @floki there isn't any rule of thumb other than check that the USB cable you want to use is a data cable and not a charge-only one.

    In my case, once I found a couple of trusted USB cables, I keep them away from all the other ones 🙂



  • Have a similar problem. Only the installation seems to go allright, but at the end it goes to the recovery screen and just stays there. I finally hit the Reboot system now and it ended up just coming back on and going to the Google logo then off then the Google logo again. This repeated multiple times before I used the power button to turn it off



  • @eduardo You might have two things here. The install itself stuck at the recovery and a power button issue. For the first try rerunning the installer with a different usb cable and follow @advocatux advice further up in this thread. For the second give the power button a sharp tap on the edge of a table or such and see if it comes on or "flicking" a finger nail on and off the power button until it moves from the Google screen.



  • Hello,

    I've just experienced the same problem yesterday when trying to install for the first time Ubports.

    On my Nexus5 the same thing: phone on the Ubports Recovery and the Installer doing nothing (wainting for the phone to get to recovery). I tried in different platforms, OS and cables and it was always the same.

    It seems that the Ubports recovery doesn't behave as it should (not telling to the installer that it is available).

    My solution:
    1 - Launch the Ubports installer, and follow all steps until it gets stuck on the "waiting for recovery"
    2 - Let the installer hanging there, but on the phone return to bootloader (you can choose the option on the phone menu, or use the key combination)
    3 - install the latest TWRP via fastboot. Command like this: fastboot flash recovery twrp-X.X.X-Y-hammerhead.img
    replacing X and Y for the actual version available at https://twrp.me/lg/lgnexus5.html
    4 - Once twrp is installed, choose the menu option to reboot to recovery (look for it with the volume buttons and then power to select)
    5 - as soon as TWRP is up, the installer will "unstuck" itself (seems twrp sends the expected commands)
    6 - Let the installer go on, wait until it's finished (when it says it's safe to disconnect your phone), close the installer
    7 - Open up a new installer, and begin the process again (just don't wipe data), basically we want the installer to put Ubports on the place of TWRP and the rest the phone should be able to solve by itself (with all files push in to it on the first run with TWRP)
    8 - Once the Ubports recovery is installed, the installer will again say that thing about waiting for recovery, but if you look at the phone it should say something like "installing updates".
    9 - Wait for the installation to complete, and wait a little bit more once the Google splash screen comes up
    10 - Ubports should be up and running



  • @Cláudio-Martins Maybe you can skip straight to installing UT recovery.
    Download it from Ubports site, flash it with:
    fastboot flash recovery recovery-hammerhead.img
    and then launch the installer ( phone rebooted to recovery)



  • @Stefano , thank you.
    That way we won't need a second run at the Ubports installation.



  • thanks for the procedure, but it didn't work. it continues to perform the installation and then sits on the recovery screen until I either choose reboot or power down. It then seem to try to boot again and again the google logo appears for about 8 seconds and continues to continue repeating until I force it off by holding the power button.



  • @eduardo So what finally happened was I went and did a complete restore using an Android image. Even then, and this may have been the problem all along, There was a problem mounting the Data partition and I had to repair that. After Android was installed I ran UBports again and now it is fine. Thank you for your help.


Log in to reply