Can't play video on FP2 [solved]



  • @kugiigi said in Can't play video on FP2:

    Have you tried rebooting?

    Yes, I have tried rebooting. Like I said, I've had this problem for several months. There were some reboots (and updates on rc channel) since then. I tried one reboot right now, still can't play videos.

    Has anybody with FP2 on rc channel problems with videos? Can this be phone dependent? I mean it's just software. Or is there some hw decoding involved?



  • I have tried to change channel to stable. Installed Version 8. Now I'm on OTA-10 and the problem persists.

    Any ideas anybody?



  • Same problem on LGE Nexus 5 (Ubuntu 16.04 (OTA-10)).



  • The problem is well known on the Nexus 5 (it's one of the reasons that made me procure an OPO). I wasn't aware the same issue existed on the FP2. It's not listed on the open issues.

    https://github.com/ubports/ubuntu-touch/issues?q=is%3Aissue+is%3Aopen+label%3A"device%3A+FP2"+label%3Abug



  • Hellou. Today I have tried to reinstall ubports, to see if something changed for video playback. I have installed android back using fairphone 2 android manual install technique. After android was working, I used ubports installer to install ubports touch 16.04/rc (version 63). Everything went smooth and I have latest OS from rc channel. But I still can't play videos on FP2 using gallery or media player.

    Q1: Are there any Fairphone 2 owners, who are using Ubuntu touch OS and can't play videos, as I do? Or you have a FP2 and can shoot and play videos without any problem?

    Q2: I didn't choose the wipe user data during install. Can the user data affect video playback and cause some problems?



  • @jezek hey there ! I own a fp2 and it definitely played videos of any kind when it ran ubports (16.04 ota11 stable. It must be a hardware problem or, indeed, an installation issue. Try using wipe option. It could also be a new bug. Presently I can't tell since because I can't use the flashlight of the new camera module (known issue), it runs android (until I find myself an old 6 MP module ^^). I'll let you know



  • @jezek I run rc on my FP2 and never had an issue with video recording and playback. Did you always have that issue?



  • @TobsEnd No, this issue was not always on my FP2. After I bought the phone in summer 2018 an immediately installed Ubports touch and video recording and playing was not a problem for about a year. Then suddenly I noticed, that video playback in gallery and media player is not working, even for videos I played a week ago. I thought, that it is some update issue, so I waited some time and then I started this thread.

    Q: How do I test if this is a hardware issue? The only way, that comes to my mind is to install android and test video playback, but how do I know it's usind HW decoding instead of SW, if the video plays?



  • @jezek :

    please try the following command in the terminal (on the phone):

    rm -rf .cache/mediascanner-2.0/ .cache/unity-thumbnailer/ .cache/gstreamer*/*
    

    Then reboot.

    This always fixed it for me, whenever this issue appeared again.



  • @Luksus Wow, that worked. You are a savior. Thank you.


Log in to reply