[Solved] Oneplus one failed install of ubports, how to recover?



  • Tried to install following instructions for OnePlus one. For this question, it's enough to just say that it didn't work. My state is: when I turn on the phone, I just get the OnePlus one ubports splashscreen ( which is sort of orange and black and white and it says "powered by Ubuntu" with the OnePlus logo).

    Powering on and holding down the volume down key until the phone vibrates, then letting go, I can get to a menu that says "UBports Recovery" with different menu choices presented to me.

    My goal is to return to Android on my OnePlus one and see if my failed installation of UBPorts is due to not enabling something in Android (I did enable developer and debug mode and abd but it seems some people are saying that's not all there is to do). Anyway if my goal is to get my OnePlus one to boot to Android, what option do I pick on the UBPorts recovery menu?

    For anyone not familiar with the UBports recovery screen I am looking at, I have the following choices:
    Reboot system now
    Ubuntu actions
    Android actions
    Reboot to bootloader
    Power down
    View recovery logs

    As a second question, related to the first, did UBPorts install on my phone if I am seeing UBports Recovery screen? Can I complete the UBports installation from here by choosing something under the UBport Recovery menu "Ubuntu actions"?



  • @penguining
    What PC OS are you on? Windows, GNU/Linux?



  • @Keneda
    Hi Keneda. I am on Debian kernel 4.9.0.12 .

    Thank you for responding!

    After following along another thread on the forum with another Oneplus one owner, I was able to get it up and running.

    I am so appreciative of this effort; I actually refused to use an Android phone and have had an old flip phone all this time owing to privacy concerns and not wanting to contribute to an abusive ecosystem.

    For sure I will be sending UBports money when this whole covid thing ends and I am returned to work.

    For now let me see if I can find a way to contribute some documentation around getting a Oneplus one going since that's all I've actually done.

    It appears to me that I had to be in the on button +down volume button state (the recovery screen) in order to get .appimage and Debian to recognize my phone being connected to my computer. At least, that seemed to be one thing which made a difference to me.

    Also, during the transfer of UBports / ubuntu to my phone, the app repeatedly lost connection. I am not sure if it was a time out thing with the app or it doesn't know that the transfer of files from the computer to the phone was going all right, but I had to reconnect 3 or 4 times as the transfer was taking place. I could see it was happening from the progress bar and I didn't take that long, a few minutes, but still it would disconnect itself.

    Thought I would pass that along in case it's relevant to UBports or anyone else.

    Thanks again !!!



  • @penguining Congratulations on working it out in the end and enjoy Ubuntu Touch. Can you try adding solved to the end of the title to help others. Use the three vertical dots to the right. Any issues let me know. Thanks



  • @Lakotaubp
    He's new user, he's not already allowed to do that i think.



  • @Keneda
    You're right they can't.
    I just did it for them.



  • This post is deleted!


  • @Keneda Yes I did know. Just testing things a bit.



  • @penguining Hi,
    I'm glad you got it working.
    I just wanted to add that I had a similar experience, but without a happy ending. I've had different experiences depending on the installation source; from best to worst it was: AppImage, deb package and snap package.
    As with you, the AppImage recognised everything and installed successfully; at least that's what the message says. The deb was similar but couldn't recognise the device initially. The snap did not work at all: didn't recognise, kept complaining of lost connection to the device and no message of successful installation.
    Also, volume up + power never worked for me, only volume down + power.
    So at the moment I'm stuck with the UBports recovery screen.

    Cheers!


Log in to reply