how do I install openssh-server?



  • @Eric Dalton mentioned this yesterday in another group

    The permissions on ~/.ssh/ must be 0700 and the permissions on ~/.ssh/authorized_keys must be 0600



  • @AppLee ok, im trying to set this up using the terminal interface on the phone,
    and yes, I do want to learn to use adb, but i havent learned how to use it yet.

    on the terminal of the phone typing sudo android-gadget-service enable ssh
    yields command not found



  • @Eric
    No adb tools on the PinePhone.
    And you have to use ssh keys to access the phone.

    You'll have to create the authorized_keys file in .ssh folder on the pinephone and export your public key there...



  • adb: error: failed to get feature set: no devices/emulators found
    $adb devices
    (blank)
    not sure what to do about it.
    on ubuntu touch, on the pinephone, in the system settings> about there is no listing of developer mode. so I dont know how to enable it.

    is there a command line way to enable developer mode?



  • here is my about screen, no developer mode, cant scroll down any further:



  • @Eric You probably don't want to post your IMEI, WiFI MAC, etc… on-line, btw.

    As for adb it doesn't exist on the pine phone, because it's not an android based device.

    As for openssh-server it is already installeld, however it is not connected to developer mode. It does need to be started manually currently though, by running sudo start ssh on the device.



  • IDK, I have very finite time to work on these things. I followed the tutorial. installed the keys, and now Im getting no route to host. I did learn to use jumpstart which was nice. I've no idea if i can or cannot use adb with the pinephone, and Im quiet frustrated. the firewall ufw is inactive. I can ping the device, at 5000ms & 0% packet loss.



  • Well, I took the phone in the house, and started downloading debian, saying to my self i cant believe i couldn't get this to go, but aw well I'll give it one more go before wiping it out. And it works. FFS. problem solved I guess.



  • @Eric said in how do I install openssh-server?:

    I've no idea if i can or cannot use adb with the pinephone, and Im quiet frustrated.

    As already said, you can't use ADB with pinephone.
    ADB is for Android Debug Bridge and is only available on android devices or UBport ported on android based devices.

    Pinephone is pure GNU/Linux, not any android component on it, so no ADB on it, period.



  • @Keneda Thank you for the clear answer.



  • @Eric this worked for my Nexus 7 LTE tablet, thanks!


Log in to reply