Meizu Pro 5 stuck flashing

  • Hey there!

    I bought a Meizu Pro 5 (global) with regular Flyme. I searched through similar problems here, but couldn't resolve my problem. I went through this tutorial to install UT (using an Ubuntu PC with 18.04):

    It went perfect until step 5. Here it keeps stuck:

    Flashing version 525 from ubports-touch/16.04/devel channel and server to device turbo

    I tried the stable version first, then devel. Same result.
    I tried the UBPorts Installer and it also gets stuck flashing. But here, when I manually go into the Recovery-Mode (right during the "stuck situation") it continues until the end. I even get the message that the PC is done and that the rest will be performed by the phone itself.
    And here the phone gets stuck showing the Ubuntu logo. Rebooting leads to a bootloop.

    I reinstalled the recovery tool several times and started over, but no success.

    Any ideas, how to fix that?

  • I did it by following another (german) tutorial:

    I have another question now:
    This is the first time for me, that the OS is not an OTA. It says Ubuntu 16.04 (2020-W19).
    Can I switch to an OTA?
    Is this because the tutorial said

    sudo ubuntu-device-flash --verbose --server= touch --device=turbo --channel=ubports-touch/16.04/rc

    Could I've chosen .../stable instead of .../rc?
    In that case I would redo all this...

  • @jojuma
    Normally you can switch to stable on the phone itself, just need to change channel in the phone update settings.

  • Yes! Worked! Thank you so much.

    It was quite an oddyssey to remove Flyme and install UT always being afraid of bricking the device. I'm not quite experienced yet.

    I'm so happy now that it worked!

  • @jojuma
    Really happy that you succeeded, UBports can be a journey just by itself while updating an "old" canonical uTouch MX4 device lol, so coming from flyme knowing how closed are Meizu devices...

  • @jojuma Well done. Could you please mark the post as solved using the Topic Tools button. First choose ask as question then mark solved. This will help others.Thanks

Log in to reply