How long should an install take?

  • Hi All,

    I am trying to install on to a Nexus 5. The installer is stuck on the "Flashing firmware..." screen for over half an hour. Is this normal? How long should it take? The install guide gives no indication if I have to wait for a minute, or an hour, or a week!

    The phone has the green android screen showing, with the word 'Start' at the top of the screen.

    I am using Linux Mint 19.3 Cinnamon desktop. The installer is version 0.4.18 - beta.


  • It should last about 10 minutes, no more.
    Did you install ADB and Fastboot on your computer? If not, open a terminal and type:

    sudo apt-get update
    sudo apt-get install adb
    sudo apt-get install fastboot

    Did you activate developer mode as well as enable Android debug bridge?

  • I did enable USB Debug and Developer Mode on the phone.

    I only installed the UBPorts installer on my computer, nothing else; I assumed that the installer would have everything, and do everything, that was needed. The web site made no mention of needing to do anything else.
    Sorry if I am sounding stupid.

  • @BarryT If you run those commands in a terminal as @stanwood said then restart your pc you should be fine.

  • @BarryT No don't say that ;-). I've got the same experience when I first tried to install UT on my Nexus 5.

    Just install ADB and Fastboot (just as easy as I described above), reboot your N5 in recovery mode, plug it to your computer and run UBports Installer. If your PC is not able to connect to your N5, type in a terminal: sudo fastboot oem unlock. Than start the installation.

  • Hi Guys,

    Thanks for all the help. I have done all that you suggest but, unfortunately, I'm still no further forward: the installer still stops at the 'Flashing firmware...' screen. I have tried two different computers and two different USB cables. I am clearly missing something that you guys consider obvious, so could we go back to first principles; could some one please answer the following in detail:-

    • How do I set up the computer for the installer?
    • How do I set up the phone ready for installation?
    • What are the steps for using the installer software, and in what order? (The video on the web site is out of date).
    • What should I see on the computer and phone screens?

    It is a shame that the UBPorts team have removed the link to manual install steps, as using the terminal may have given some clues as to what is going wrong. The simple installer gives no feedback.

    Thanks again,
    Barry T

  • @BarryT It shouldn't take long to flash, 5-15 mins overall maybe. I've no Nexus 5 experience but there are plenty of others here who I'm sure will help you. Try starting the installer from terminal to get a bit of feedback. Command: ubports-installer

  • Hi @BarryT
    I have flashed a couple of Nexus 5, but only on Ubuntu distros, I have no experience with Linux Mint though. But lets give it a try.

    Install adb, fastboot and Ubports installer.
    Reboot your computer. Make sure that only one version of adb and fastboot is installed, there could be some very strange behavior during installation if you have two or more versions installed.

    Activate Developer Mode.
    Allow Usb debug

    Edit Connect your phone to the computer.

    adb reboot bootloader


    Turn off your phone.
    Press both Volume Down and Power buttons simultaneous until the green android figure appears.


    fastboot oem unlock
    fastboot reboot bootloader

    Check if the computer detects the phone:


    fastboot devices

    It should output something like this:

    0923db4e021ffb19 fastboot

    Start the ubports installer and follow the steps.

    If this doesn’t install UT on the device run a live image of Ubuntu and install UT through it instead.

  • Hi @Rondarius

    The terminal command

    fastboot devices


    no permissions (user in plugdev group; are your udev rules wrong?); see [] fastboot

    It looks like the installation of the installer software did not set up the udev rules correctly; it said it would do this automatically during the installation of the software. How do I set up udev rules manually?

    Barry T

  • @BarryT Remove and reinstall adb and fastboot and reinstall should help

  • @BarryT In the past this info always sorted udev rules problems for me. Clear and easy to understand!

  • @BarryT Maybe a permission issue (?) Have you tried « sudo fastboot devices»?

  • Success! I have a working phone!

    The problem was caused by the file
    being missing; it was not created during the installation of the UBPorts Installer software. I followed this link to manually create the missing file, and then manually add the udev rules. After that everything worked as expected.

    I would expect the UBPorts Installer to check and throw an error if the udev rules are missing. I will register a bug against the installer.

    Thanks to everyone for all your help.
    Barry T

  • @BarryT Congratulations!! Well done !!

  • @BarryT Great! 🙂 Indeed, I suppose that UT Installer should be able to detect any missing rules as it's designed to be used by ordinary users & newbies.

Log in to reply