"The" Bluetooth Thread



  • The other issue I have is that I have yet to get audio work when connected the "My V70" Volvo car kit. It connects fine, but it is impossible to hang up a call from the car kit.



  • @Pet_HH
    Update on actual status: Connections are working to Headset and others, i had to deactivate all the other BT surrounding and connect one item after the next.



  • @guru said in "The" Bluetooth Thread:

    @Leppa said in "The" Bluetooth Thread:

    @alternatore said in "The" Bluetooth Thread:

    Dunno why my previous message was deleted

    Aren't you banned?

    How many times this guy altern* will post the same stuff?

    Matthias

    As long as it takes. Admin(s) of this forum is quite ridiculous.

    BT with Pioneer car stereo sometimes requires BT restart in tablet when using it with M10 FHD. It connects, but audio does not go through. Also connection time is pretty long ~10s.



  • I have a 2012 Ford Focus (SYNC) and a OnePlus One. The BT connection is OK once connected, however quite frequently when I have turned the ignition on, it may appear that they have automatically paired but when I play from Podbird or from the Music app, nothing happens.

    I then have to (from the car console) disconnect the phone, begin to play something on the phone and then reconnect it. Once I've done this there's no further issue.

    Unfortunately so far, calls don't seem to be working with either Mic or Speakers.



  • @MarkDJ said in "The" Bluetooth Thread:

    I have a 2012 Ford Focus (SYNC) and a OnePlus One. The BT connection is OK once connected, however quite frequently when I have turned the ignition on, it may appear that they have automatically paired but when I play from Podbird or from the Music app, nothing happens.

    I then have to (from the car console) disconnect the phone, begin to play something on the phone and then reconnect it. Once I've done this there's no further issue.

    Unfortunately so far, calls don't seem to be working with either Mic or Speakers.

    A couple of hours after posting the above, the BT connection to the car had a complete meltdown and refused to connect even after several restarts of the phone.

    However the next day, it connected OK again and I was able to listen to audio from the phone. Suddenly a call comes in and lo and behold I was able to answer it from the steering wheel control! I had the call come through to the car speakers and the microphone was working too!

    This is the first time I've had a successful hands-free phone call using the OnePlus One. I'm now guessing that there are intermittent issues with the BT connection between these devices.



  • At the moment I am testing a Jabra Drive. So this is a very standard car kit. No telephonebook or other fancy stuff. Only phonecalls. For now it looks good. It connects very fast. And the sound works!

    But the first time I connected the device everything went very smooth. After someone called me the trouble began. Could not connect anymore. Pushing the button (for answering a call) I could only see the device connecting and then it was disconnected again.
    So I tested a lot of things with the phone and the Jabra Drive. Nothing worked. Finaly I pushed the button again, for a very long time. Since then, everyting is fine again!

    I installed a log viewer. Now that the device works fine, I'm still keep getting errors for bluetooth: http://paste.ubuntu.com/25508920/

    So, it is not rock sollid stable. But it works a lot better then my Parrot CK3100 which never gave any sound.
    I wil keep you posted testing the device.

    UDPATE
    Sad, but after one day the sound didn't work. Rebooting the Jabra solves the problem. So, not very reliable connections

    alt text



  • Hi. It's been a long time since this topic was created, so I would like to know if any progress has been made on bluetooth connectivity with cars and hands free systems.


  • Infrastructure

    @Vehi_MV Currently we decided to wait for 16.04 as it will bring a new upstream version of Bluez stack, and then we will re-visit this long list of issues ;)

    BR



  • OnePlus One
    Motorola Whisper HZ850
    Bluetooth connected

    Received a phone call, did not hear ringing through earpiece, heard ringing from phone, loud. Pressing button did not answer like it did on the iPhone. After answering using the OnePlus One, Audio worked through the earpiece. Both in and out.

    Basically audio works but not controls.

    This was testing just a few days ago.

    Edit, just saw last message, sorry lol


  • Infrastructure

    Hello Guys,

    after some long time small update for this thread: As it seems, Bluez and all its problems in 15.04 might persist on 16.04, since it seems it has been backported from xenial to vivid. So we are in very small hope that things will improve. Sorry to not give a better answer at the moment. But we can finally only tell if its like this when 16.04 is out.

    In the meanwhile I hacked around a small problem that might affect you also: https://forums.ubports.com/topic/1030/howto-change-the-name-of-your-device-for-bluetooth-pairing - Just to let you know we did not forget about Bluetooth :)

    BR Florian



  • That's quite a sad news. I thought bluetooth will significantly improve in 16.04 considering that it is the latest LTS release.
    Anyway, any chance we get the media controls working soon?
    I bought a bluetooth headset a year ago and I've never used its media controls as I use it exclusively with my Ubuntu Phone :D


  • Infrastructure

    @kugiigi Hmm the latest LTS releases is 18.04 ;)



  • Hi,
    i've a meizu pro 5, bluetooth is working fine with my music app but no with phone app, I hear a lot of noise and I notice that bluetooth speaker controller doesn't come up when I try to adjust volume with the physical buttons during a call. Is it possible that phone app doesn't use the right audio device during bluetooth connection?
    thanks



  • Hello Guys,

    I did some tests about bluetooth and I would to share some results for help in solving this annoying bug.
    I have a Meizu pro 5 with 15.04r3and as I said before with Bluetooth Music Player is working fine but calls sound is disturbed.
    I realized that:

    1. Music Player comunincates with bluetooth headphone trough a2dp_sink (ACL) protocol;
    2. SCO (HSP/HFP) protocol is not working.

    I did some modification to the file:

    /etc/pulse/touch.pa

    I commented out the load of the two module-null-sink and I modified the module-bluez5-discover
    in the following way:

    load-module module-bluez5-discover headset=both

    With this modification I tryied to reproduce some wav tracks with the tools paplay in this way:

    pactl set-card-profile <bluetooth card number> a2sp_sink
    paplay -v -d bluez_sink<my bluetooth card macaddres> tracks.wav

    Sound it's ok, and with hciconfig I saw ACL TX packtes growing, in this way:

    pactl set-card-profile <bluetooth card number> headsset_head_unit
    paplay -v -d bluez_sink<my bluetooth card macaddres> tracks.wav

    paplay hangs and with hciconfig not packtes are sent. So I apply this patch to broadcom bluetooth chip:

    https://freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Bluetooth/

    hcitool cmd 0x3F 0x01C 0x01 0x02 0x00 0x01 0x01

    And I try again to reproduce the track with this command:
    pactl set-card-profile <bluetooth card number> headsset_head_unit
    paplay -v -d bluez_sink<my bluetooth card macaddres> tracks.wav

    Finally it works and with hciconfig I saw TX SCO packets growing.
    Then I try to start a Call with telephony-service but not sound!
    Can you say me which is the default sink for telephony-service??

    Conclusion: I think that the sound it's disturbed because OFONO packets are sent to "bluetooth haedset" with ACL protocol and not SCO protocol as it should.

    I hope that this can help you. I continue to debug the problem and I hope to find a solution.

    Best Regards



  • @miousername If you can fix that issue, you'll be a genius. Fingers crossed.



  • @miousername I'm really, really folowing you on this!


  • Infrastructure

    @miousername Good Job! If you are that far, it would be good if you start also commenting on an issue in our GH tracker. Probably there are a few Bluetooth related issues already opened. Finally, we must identify where to patch and then spin up a package build job to override the defaults in Ubuntu root fs. For this to be successful, it would be nice to know the source package that eventually could fix this.



  • I'm trying to pair a meizu pro 5 with the audio system in my vauxhall/opel antara
    The phone recognises the system but doesnt bring up a screen to input the pin code generated, it then fails to connect with the audio unit display saying 'connection failed'



  • I have been using Ubuntu touch now for a little more than a week as my main phone.
    One issue I have been bothered by is the call quality on my end for Bluetooth connections. on my nexus 5 I am able to pair with several devices, such as our 2018 ford explorer, a set of cheap bluetooth headphones, a jabra ear piece and a high end bluetooth headphones set. In every case In, music and podcast sound great. Audio quality is great, volume fine, no strange compression sound that one can hear over Bluetooth running under some protocols. However in every case call quality is so poor its not worth using. The audio is digitized sounding almost as if the caller is using a transformers voice changer toy for Megatron.
    Is this just my nexus 5? is it Ubuntu touch? any ideas???



  • OK...
    So Bluetooth working correctly will make or break it for me to use touch as my OS.
    Two days ago I was pulled over and was given a $206.00 fine for talking on my phone. this is 4x more than the cost of my nexus 5!!!
    I can use earbuds, they work great... But strange thing is I can't plug into my aux in my car, I get a similar result as I do with Bluetooth. I'm starting to think this is a specific problem with the phone I have, not Ubuntu, or a problem with nexus 5 only... Does anyone else have issues with call quality while on Bluetooth in nexus 5??


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.