Differences in qtwebengine rendering?



  • @AppLee said in Differences in qtwebengine rendering?:

    From your screenshot, the qtwebengine component is not anchored properly and a higher anchor for the bottom edge might have this appearance.

    Yes that is what it looks like. But my question is what might cause this to happen only on the larger OnePlus3 screen and not the Nexus5?



  • @CiberSheep said in Differences in qtwebengine rendering?:

    @poVoq Thanks.
    Probably is related to the scaling. Check if instead of the zoomFactor property in the webview, using https://github.com/costales/unav/blob/master/app.desktop#L7 --scaling makes this better or worse

    That makes the strange bottom edge a bit smaller, but once the keyboard comes up it increases to nearly 1/3 the screen on top of the keyboard. So definitely much worse.

    Also on the Nexus 5 it has the strange effect that (while everything looks still nicely as before these changes) the keyboard inputs in the qtwebengine are not shown anymore and only appear in the forms after the keyboard is minimized. (edit: same effect also on OnePlus3)



  • What is also odd is that on the very first launch of the app on the Oneplus3 it doesn't get offset below the top bar. only after closing the app and relaunching it this starts to happen permanently.



  • I can replicate this behaviour if I use Utweak to change the usage mode from Staged to Windowed, though the window can be stretched to full screen if I choose. Could you have done the same?



  • No, didn't even know how to do that until now. It is staged mode.

    I tried increasing the overall scale in uttweektool now from 21 to 24 to see if that would make a difference, but the problem stays the same.



  • I'm not sure if I understand the issue correctly 😅
    But first thing that came to mind is that the layout of the bottom edge I think is when there's a mouse detected?



  • Ah, good point. I noticed that sometimes on the OnePlus3 I shortly see a mouse pointer on the circle screen, so that might be a specific bug of the Staged mode in that model?



  • @poVoq I've seen that issue in some ports so it's possible. How's the bottom edge in the messaging apps, clock, calendar, etc?



  • @kugiigi said in Differences in qtwebengine rendering?:

    @poVoq I've seen that issue in some ports so it's possible. How's the bottom edge in the messaging apps, clock, calendar, etc?

    Same in the sense that I get the bar with those core apps for clicking with the mouse pointer despite being in Staged mode, but they do not have the additional white border on top of it.

    I tried switching around Stage mode with UT-Tweek-Tool, but no difference.



  • @poVoq Looks like indeed a issue specific to that port. Bottom edge should just moistly be a tiny icon and not a full width bar. That's only when there's a mouse connected.


Log in to reply