telegram



  • i have 16.04 dev installed on my nex5. i tried to install telegram for ubuntu but it times out after entering the code? several efforts with no joy. ideas?



  • @dr1445 I moved your issue from App Development to Support . Please try to find the right category when posting a question, thank you.

    First you need to install the latest xenial version of Telegram app. You can download it from here https://open-store.io/app/com.ubuntu.telegram or, it's easier, use the OpenStore app on your phone to search and install it.

    Now, do you receive the code without any issue? It's working this time? Good, problem solved.
    Is it not working? then it's probably a problem with Telegram servers. You can take a look to .cache/upstart/application-click-com.ubuntu.telegram_telegram_2.5.4.0.log to see what's going on.



  • the app store is where i installed it from. i downloaded the link from your reply on my pc, dragged and dropped it to the phone download file. from there i installed it with the same result. sorry to be dense but where is that cache file located?



  • @dr1445 dont' worry, that's in the /home directory of your phone, so the full path is /home/phablet/.cache/upstart/application-click-com.ubuntu.telegram_telegram_2.5.4.0.log

    You can install Logviewer too, maybe using that app is easier for you to see the content of that log.



  • lots of data there but the short of it is "apparmor policy prevents this sender from sending this message" now the search for apparmor begins?



  • I have had this issue recently, where I have installed a fresh copy of Telegram and after entering my number and pressing submit, nothing happens. For me this happened a few times and then it just worked. I do not know if it was the reboot of the device or the fact that things were just aligned. Try the reboot (if you have not already) and just keep on trying, it will take it and give you the code. Like suggested it may be the servers having an issue. Good luck though.



  • i will keep trying for few days and see what develops, self healing would be super.



  • @dr1445 I'll just throw it in here again; Telegram didn't like me very much, and even with all the support the very able people here gave, I eventually gave up trying to get in... I went to Matrix, which I've found to be excellent - it's completely open source, very easy to set up and use, and there are some good clients on UT too: fluffy chat and uMatriks

    (There's a burgeoning UBports community there - https://riot.im/app/#/room/#ubports:matrix.org)



  • @dr1445 that line is irrelevant for your current issue, you need to search for lines about how telegram app is trying to connect to Telegram servers.

    If you want, you can paste that Telegram log on https://paste.ubuntu.com/ so we can take a look at it (scan it first to see if it has any personal info).



  • I just installed the telegram app and "registering" (number plus code via sms) worked without any hassles. I can read my groups everything seems functional from a short glimpse



  • @dr1445 The only other thing I can think of if you wanted to try it would be to reinstall 16.04 dev with wipe option and see what happens, unless that's what you have done. Bit of a pain I know, but you would have a clean nexus5 then, just make sure you back up stuff first.



  • @lakotaubp or use Factory Reset ;)



  • @advocatux Thats to easy !





  • already tried factory reset.





  • @dr1445 you're getting a PHONE_NUMBER_UNOCCUPIED error, that means the code you're using is valid but no user with the given number is registered.

    Have you used that phone number before on Telegram? Are you using a "normal" mobile phone number?

    Things to try. Check out you're using the right country code and the phone number is introduced properly.

    If that doesn't work, delete Telegram's cache, config, and data, uninstall Telegram app, and install it again.

    Good luck

    Edit to add: check out that you have a good internet/data connection too
    Edit again to add this too :) If you have never registered that phone number before, you can try to register it first on a non-UT phone or use Telegram Desktop on your computer and register that number before activating Telegram app on your UT phone.



  • @advocatux
    I had a struggle with my meizu ID like that
    +1 for USA,and it needed the 1 before the rest of the number.

    Meizu automatically put the extra number in,and I did not.



  • i have not used the phone # on telegram nor have i entered a 1 before the #. i can pull the sim card and use it on an android phone to install telegram if adding the 1 does not work.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.