Ubuntu Touch Programming Course

  • @nithin said in Ubuntu Touch Programming Course:

    After this there was no zfs option available at all.
    so had to use this

    sudo apt install -t xenial-backports lxd lxd-client

    Thanks! Using lxd from xenial-backports helped to overcome that Creating the bridge failed with: not implemented issue.

    It would be nice to have this hint in Course.

  • @mimecar : following you.
    Thanks for your work !

  • @tischlerwilly @mimecar : Error No Storage Pool Found
    As said by tischlerwilly, I have the same error when installing the developper kits :

    No storage pool found
    I'm also using MINT 18(.3) 64bits. Did you find the solution, please ?
    Best regards

    Oooops ! See below ...

  • @mimecar @HendriXXX @TischlerWilly :

    Sorry, I've discovered that when I search for something with CTRL-F in a long thread with Firefox, the process doesn't see all the content. So at the beginning of the thread, searching for "pool", I found only the posts of TischlerWilly and mimecar but no complete answer.
    This is why I thought there was no answer ...
    If I go at the end of the thread, I find the answers of HendriXXX and mimecar, so I'll give a try to the solution and report here how it goes.
    Have a nice day

  • @mimecar said in Ubuntu Touch Programming Course:

    • sudo add-apt-repository ppa:ubuntu-lxc/lxd-stable

    This command returned an error. I tried this instead :

    • sudo add-apt-repository ppa:ubuntu-lxc/stable

    I hope it was the good choice. Next I followed the proposal of HendriXXX :

    • sudo chown lxd:lxd /var/lib/lxd/unix.socket

    All the process worked and my kits are created now.
    However, I didn't see the error "container is faulty"
    Proceeding to the next steps ...
    Best regards

  • This may seem off-topic, but way a custom PPA when LXC and LXD are available in the repositories?

  • @mimecar : Hello
    I've been able to generate Hello Word and Calculator applications.
    All is perfectly clear and well explained. Thank you !

    However, I'm facing three errors as described below. Maybe are they due to the same reason.

    As far as ipvoid knows, the faulty IP is :
    IP Address:
    Hostname: keeton.canonical.com
    Organization: Canonical Group Limited
    ASN: AS41231 Canonical Group Limited
    Continent: Europe (EU)
    Country: United Kingdom (GB)
    Latitude\Longitude: 51.5142 / -0.0931
    Region: England
    City: London

    It seems that this must be solved to continue learning how to create my own applications. Have you a solution please ?
    Have a nice day.

  • @pulsar33 Vivid reached End of Life in February 4, 2016. You need to replace all the archive.ubuntu.com with old-releases.ubuntu.com in your sources.list

  • @advocatux @mimecar : Hello
    Thank you for the reply, however I'm not sure to know what to do now. As far as I understand, the problem is to update the kits, not my system which is perfectly up to date (I use MINT18.3). I've searched the whole GUI of Qt Creator but not found how to specify the sources.

    Where are defined the sources for the kits ?

    Moreover, why am I the first to have the problem following the Programming Course if the end of life of Vivid was in February 2016 ?

    Good evening

  • @pulsar33 said in Ubuntu Touch Programming Course:

    As far as I understand, the problem is to update the kits, not my system which is perfectly up to date

    It seem so. I guess we need to update /etc/apt/sources.list inside lxd contaner used for building?

  • I did this:

    • Enter container with lxc exec device-armhf -- /bin/bash
    • Replace archive into old-releases in sources.list with sed -i "s|archive|old-releases|" /etc/apt/sources.list

    But after that, running apt update inside container, I get errors about ports.ubuntu.com/ubuntu-ports/dists/vivid/... (404 Not Found), while old-releases works fine for other repositories.

    There are in fact no vivid in this repo:

    So what cane ports host be changed into? Is there archive as that old-releases somewhere?

  • @talkless In my containers I replaced all urls by http://old-releases.ubuntu.com/ubuntu
    also the ports ones
    vivid vivid-security vivid-backports vivid-updates (main / multiverse / restricted / universe) are all included there

  • @chris said in Ubuntu Touch Programming Course:

    @talkless In my containers I replaced all urls by http://old-releases.ubuntu.com/ubuntu
    also the ports ones
    vivid vivid-security vivid-backports vivid-updates (main / multiverse / restricted / universe) are all included there

    But there's no ubuntu-ports repository (directory) inside http://old-releases.ubuntu.com/

  • @talkless @chris @mimecar : Well shot Guys !
    Thank you for the tip. I didn't try for the armhf-device kit but I succeed for the desktop kit. In fact, the configuration is different for the two kits and the desktop kit only involves "archive". So the tip of @Talkless was clean and the (long) update took place without error.

    101 upgraded, 2 newly installed, 0 to remove and 0 not upgraded. Need to get 95.3 MB of archives. After this operation, 36.1 MB of additional disk space will be used.
    Get:103 http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/ vivid/main unity8-private amd64 8.15+15.04.20161129-0ubuntu1 [584 kB]
    Processing triggers for libc-bin (2.21-0ubuntu4.0.1) ...
    ---Task exited with no errors---

    Most updates are from ci-train-ppa-service ...
    The HelloWorld example compiles and runs without problem.

    Upon the next launch of Qt Creator, only the armhf-device update is proposed.
    Finding ports.ubuntu.com correct source may solve the last problem.

    Good evening

  • Hello,
    I'm not sure I've done the right things and I hope a "guru" will warn me if necessary but I found how to update the device-armhf kit :

    lxc exec device-armhf -- /bin/bash
    root@device-armhf:/# cd /etc/apt
    root@device-armhf:/etc/apt# sed -i "s|archive|old-releases|" sources.list
    root@device-armhf:/etc/apt# sed -i "s|ports.ubuntu.com/ubuntu-ports|old-releases.ubuntu.com/ubuntu|" sources.list

    Then, the (long) update ends with no error.

    This seems fine but I must now understand why all my choices are for 14-10 framework despite the fact that my kits are made with 15-04 framework ...
    limited choices

    Solution is welcome !
    Best regards

  • I think this is a major indication that the SDK needs to be maintained so we can make Ubuntu Touch a success. I think a lot of you can agree with that.

  • @metalbiker this is a volunteer based project, and it's free software, so if any developer(s) wants to maintain it, the door is open.

  • This post is deleted!

  • Hello! I am having a problem with creation of Kits (pages 15-19 of the PDF).

    I try to create new Kit/Build target (as described on pages 15-19) and I choose option "Build and run your application locally on the Desktop", and click "Next", and choose the "Ubuntu-sdk-15.04-dev" and click "Next", and choose target name "default", and click "Finish"

    then a window appears showing that the kit is being downloaded

    0_1531090363679_Zrzut ekranu z 2018-07-09 00-50-08_same-okno.png

    and finally an error message appears:

    • Creating image with: framework: ubuntu-sdk-15.04 arch: amd64
      error: Failed to load raw.lxc
      ---Task exited with errors, please check the output---

    0_1531087501292_Zrzut ekranu z 2018-07-08 23-45-58_800px.png

    The same error happens when I try to do the kit under "Build your application to run on a Ubuntu device or emulator" and choose "Ubuntu-sdk-15.04-dev".

    [I do not use Wizard because I had errors during the first try and the "Do not show this Wizard the next time" was ticked so I have no access to the Wizard anymore. But I have found equivalent wizard in QTcreator - Tools - Ubuntu so I use this one]

    I am doing it on a new, freshly installed Ubuntu 16.04.4. Before this errors I had errors similar to people who wrote in this thread and I used their/your hints to overcame those errors (like changing .

  • @mimecar said in Ubuntu Touch Programming Course:

    Good afternoon.
    You can now download the resources I used in the UbuconParis 2017 workshop. The virtual machine has the following features:

    Ubuntu 16.04 with the Mate desktop.
    SDK already configured with IDE icon on the desktop.
    The workshop exercises are saved in the User Folder.

    Hi! Thanks for doing it! After several hours I still have problems with installing Ubuntu SDK IDE so it looks like a perfect solution for me.

    I have downloaded the 13 GB files. What do I do now?