Need your opinion about ubport

  • Hello, everyone. I'd like to hear your opinion about Ubport. I have a Nexus 7 (2013 Wifi) with LineageOS.

    The support of LineageOS being finished for this device, I inquire about Ubport but I must say that I have seen only very few (old) reviews. I also have used Ubport a few time ago on a Meizu Pro 5, but my global feeling was that it was like an RC release (not finished).

    There are several important points that would determine my passage on Ubport:

    1. Have a secure OS: today LineageOS is no longer maintained for this model, so security vulnerabilities are exploitable. What about Ubport? Are the apps also updated regularly (can we trust them) ?

    2. I'd like to play m3u files (video playlists) to watch my TV channels in my room for example.

    3. I'd like also to browse the web and read RSS feeds: here no problem, the work is remarkable, even if I regret the lack of extensions in the web browser.

    I am mainly wondering how is Ubport now, mainly for point #1 and #2. So what is your opinion (not necessary on Nexus 7 but also on any other device) ? Thank you very much for your feedback !

  • I use UT on a OnePlus 1 and am very pleased with it. the bluetooth is not tip-top for calls in my car, but other than that, it works perfectly.
    I had in on a Nexus 5 before and can really feel the hardware upgrade. The voluntary and collective approach to the OS, with forums like this one etc. is also really friendly and appealing to me.

    not much on the tech, I'm afraid, just my personal experience.

  • @Lindisfarne Thank you very much

  • I was using it on a N5 for a month or two as my daily driver.
    I am not a heavy user, but used it for calls, texts, internet (emails and browsing)
    Screenshots, podcasts.
    I was really enjoying it.
    Never had any problems at all with it at all.
    Some of the apps are still work in progress, but I had enough apps that work perfectly fine for what I need.
    I spend all day in a van though and the BT not working properly is what stops me from using it.
    I have picked up a OnePlus 1 as well. Using LineageOS on that until the BT works out.

  • @prog-amateur for m3u just install vlc in a libertine container and ur good to go. for security issues, there's an open topic about that which covers how apps are surveyed

  • @prog-amateur

    ... and there a number of RSS apps in the Open-store. I don't use any, so I'm not in a position to recommend one.

  • Thank you all, I really appreciate your kind feedback. At the time I was using my Meizu Pro 5, Libertine was like a dream, now it seems that it works well, so I hope to install ubport on my Nexus 7.
    Do we have any review pictures/video of Libertine Desktop apps ?

  • Bear in mind that the experience on a Nexus 7 is likely to be inferior to that on a Meizu Pro 5.

  • So I have installed Ubuntu touch (version stable 16.04, OTA 10). It is smooth, but I have a big bug : Wifi is not possible. I have tried to enter my password many times, and I have checked the keyboard layout (which is OK), but each time I enter the password, I have a new popup to re-enter the password. Is this a known bug ?

  • @prog-amateur It happens also to me sometimes on my Meizu Pro5. What phone version do you own by the way? The chinese version? To be sure on the model, if you turn around your phone, on the back side you should find written the model (mine is TD-LTE). Which channel are you on? Stable? Try also to move to a different channel - Stable, Release Candidate, Developer - to see if something changes (go to Settings->Updates->updates settings->Channels).

  • Thank you @matteo , this is a Nexus 7 tablet (not phone), I am on :

    - Ubuntu Touch 16.04 LTS armhf (20190815) 
    - Stable channel
    - OTA-10

    Do you think I can change channel update from Settings or should I re-install everything from scratch ? Thank you

  • @prog-amateur ok it is actually the Nexus 7 you were talking about, I was confused by the side talk related to the Pro5.
    Yes, indeed, you can change channel from Settings, it is very straightforward and fast to do so.

  • @prog-amateur does it also happen with other wifi spots?

  • @doniks
    Hi, I have a similar problem with wifi (I guess).
    In my case, I registered on my wifi network and it works fine.
    But sometimes it's like the connection is broken and I have to force re-connection to my network, e.g. drop-down menu and tap on my wifi network.
    The auto connection seems off.

    Some other time, I'm just loosing wifi (weak signal or something like that) and the connection dialog pops up.
    In that case, the best course of action is to cancel, open the network menu and tap on my wifi network.

    Most of the time forcing to reconnect to my wifi is enough, but from time to time I have to go airplane mode then disable it after few seconds.

    I hope it could help @prog-amateur with a possible workaround.

  • @matteo than you, in the case I have no other possibility, I would try the other channels.

    @AppLee thank you for your trick, sadly, it does not work in my case.

    @doniks I have tried with my wifi-hotspot from smartphone, and it works fine. Therefore, only my home network doesn't work. It is very strange (I am sure there is no ID/Password issue).

    What I would like to add is that my home network is the one I have used to connect during first start setup after installing Ubuntu Touch. Do you think the bug is related to that ?

    Thank you very much !

  • @arubislander, Hello! I am happy to use ubports on my Meizu pro5, now I am on OTA-11, but I am forced update my device only with TWRP. Last Ubports-installer cant updated firmware (after pushing ota in to device I see white screen and "ask support"). How you update your Meizu pro5? Maybe needs wipe device?

  • @vokaliz
    My Meizu Pro5 is currently on the Release Candidate channel ( I let I on there since the last call for testing). And I have never had any issue receiving updates through it.

    Do you currently have TWRP recovery installed? In that case you will always have to apply the updates manually.

  • @arubislander, Before release of the OTA-11 firmware, I updated through TRWP, but I took the firmware from ubports-installer. I have a fully unlocked Meizu pro 5 from the factory (powered by ubuntu). Now I can not extract the updated firmware from the installer, is there a link to the server where OTA (8 files) for Meizu pro 5 (16.04 turbo stable) is uploaded?

  • @vokaliz Does updating via the System Settings not work?

  • @arubislander, All update options (system update and ubports-installer) are interrupted at the firmware installation stage (ubuntu touch logo and line installation indicator), except one-manual installation via TWRP. To update the device I have to download separately the firmware and run the installer in TWRP environment. Is there a link to new releases of updated ubports firmware where I could download it and install manually?

Log in to reply