Oneplus 3/3T



  • I posted a wifi bug here:
    https://github.com/ubports/ubuntu-touch/issues/1296

    Not sure if it's the same on the 3T



  • @joe I was able to compile ut-tweak-tool and the file browser, but not dekko 2 or puremaps, will this not work with all apps?



  • @dieharddan You are correct. Some apps require some extra things, and usually I don't know what those are.

    This post mentions how to compile apps with qmake :
    https://forums.ubports.com/topic/3323/arm64-apps-and-testing/7

    It seems like @mateo_salta knows a bit more on this.



  • dekko2 looks like a mess 😞 I was just trying it, and there were a lot of specific armhf dependencies linked, probally all of those need to be rebuild, then it ran a build script specific to armhf...



  • Hello, how does the camera works ? Do you use edge or stable ?
    Is libertine running ? I'll need it to recompile ubsync.



  • camera freezes, so no pictures. I don't think you can install stable on it yet, not bluetooth or hotspot when I tried it. But wifi/data/calling/sms/audio/video all seem to work great. Screenshot_2019-11-21_21-52-16.png
    I haven't tried libertine.



  • @ernest I've taken three photos so far



  • @Lakotaubp said in Oneplus 3/3T:

    Just managed to add my nextcloud account so will be using OP3 as main phone tomorrow. Bit of a faff had to copy and paste using messaging app text field, still now have calendar

    Sounds like you have most things up and running. Do you get a ringtone with incoming calls? My OPO 3T will not ring. Tried different settings and a custom ringtone, but still silent. It does vibrate though.

    But it only seems to acknowledge calls when screen is on. Does not work at all in standby.Any thoughts?



  • @ziggutas Much the same here no ringtone but does acknowledge calls screen on it off with vibration.



  • @ziggutas that's a known bug, also sound doesn't work when calling on to OP3, (also it won't wake up the screen, sometimes when screen is on , the call UI crashes leaves active call inaccessible ) sound works when calling from OP3 .
    This behaviour was observed on @vince1171 port, now have the same issues on Ubports arm64 version as well...go figure... hopefully this could be resolved, it's a main stopper.
    I don't think anyone reported that yet to Ubports.



  • @Stefano Ah, thanks for the info. I've made quite a few calls to the phone and the results are a bit erratic, to say the least! Also checked whether the Alert Slider position made a difference...I think it did, but as I say, it's all a bit random. At one point it woke from standby actually ringing with the custom ringtone, but it was about ten seconds after I had hung up on the initiating phone😂



  • @ziggutas Same sort of thing here. Two incoming calls both from mobile, one vibrate only for incoming answered that one fine, next one ringtone and on screen display but called killed as answered though not 100% if it was me answering it or them cutting off. More testing needed.



  • @Lakotaubp ok thanks, is there any limitation with app ? Is it smooth, what about resolution ?

    What is the difference between official installatuon and the one specified above ? Different port ?



  • @ernest I went straight from android 9 on OP3 with the installer. All went ok until pushing files which kept stopping in the end as mentioned above installed twrp cleared/fixed cache,data and storage then ran installer again and all went well.



  • Ok, seems that camera issue affects only 3T.



  • @ernest OP3T on edge, confirm camera app has issues. It won't capture an image after pressing 'button' on front, back or video mode.
    On button press, screen goes black and after a few seconds a blue spinner appears in top left corner of screen... and just ekes going
    Camera switches from front to back OK, but slowly ; takes about 5 secs.



  • if your weather app doesnt launch edit the desktop file in
    /usr/share/click/preinstalled/com.ubuntu.weather/current/share/applications

    change exec line to

    Exec=qmlscene ../../app/ubuntu-weather-app.qml



  • It seems "hotspot" does actually work, it's just that the icon doesn't show up in the top menu; I've seen the same issue with the 4g icon not being there as well, even though 4g is working. Once hotspot is enabled, it can't be turned off though without having to reboot the phone.

    Edit: hotspot can be turned off by toggling wifi.



  • Don't know if anyone else can confirm the following on OP3 for incoming calls
    Phone rings- can't answer call
    Phone vibrates- can answer call
    Think calls issue has already been Githubbed?

    As a side point. Missed calls show in notifications as just number, in phone app itself as contact details



  • @Lakotaubp said in Oneplus 3/3T:

    Don't know if anyone else can confirm the following on OP3 for incoming calls
    Phone rings- can't answer call
    Phone vibrates- can answer call
    Think calls issue has already been Githubbed?

    As a side point. Missed calls show in notifications as just number, in phone app itself as contact details

    OP3T responses to incoming calls:

    Phone does not ring.

    Phone usually turns display on, vibrates, shows small window with caller info, decline/accept etc- can accept call.

    Sometimes phone seems not to respond to incoming call; but the dialler app has usually opened without turning on display. Also if the phone is turned on manually whilst incoming still trying, phone responds as usual, without sound.

    Notification of missed calls do not turn display on or make a sound. Turn phone on and notification envelope is green, and like yours, missed call shown as just a number (details in app)

    Incoming to Dekko and Teleports both notify with sound, turn display on, notification bubble.

    No flashing LED's to accompany notifications at this stage.

    Couldn't see anything on github for this but I'm not sure where everything is on there anyway!😕


Log in to reply