BQ E4.5: only white screen with bq logo after flashing



  • I finally decided to move the BQ E4.5 of my wife to UBports using the ubports-installer 0.4.5-beta on Ubuntu 18.04. It seems that all went fine and at the end the device rebooted twice, the second time only to the white screen with the bq logo.

    What should I do now? Please help!

    Update: I did it a 2nd time and watched more carefully:

    • the installer says: Ubuntu Touch successfully installed
    • the device reboots to the Ubuntu screen with the progress bar which is in the middle already
    • after 2-3 secs the device boots again but only to the white screen, stays there for ever


  • @guru If you have backed up datas, you could try to flash again using wipe option. You may also try manual install instructions from https://devices.ubuntu-touch.io/device/krillin# which give option to format cache partition...



  • On the 2nd (and now 3rd) time I let it wipe out all user data (I have a backup). The 3rd time also failed.

    I read the manual instructions and downloading the files. I have the device now in the menu Select Boot Mode, what should I select? The manual instruction asks me also to set developer mode which I can not do now anymore. It was set before the fist update run. And now?

    If I select with the volume buttons the option Fastboot Mode it replys with => FASTBOOT mode ... but nothing else. And adb does not detect any device.



  • @guru I haven't yet tried ,0.4.5 but did flash a bq5 using 0.4.1 without issue. You could try that or reboot to recovery and clear cache



  • @Lakotaubp If I reboot to Recovery the magenta screen with ubuntu in the center comes up, nothing else, and adb says:

    # adb devices
    List of devices attached
    JU023823	recovery
    

    My wife is just asking: what happened with my telephone ... 🙂



  • @guru In fastboot mode, it's normal that 'adb devices' give an empty list.



  • 0.4.1 gives the same problem: it flashes, reboots twice and stuck in white screen after second boot.



  • @guru Hmm something has not been flashed if recovery is not there. So we need to get a happy wife as quick as possible. Your flashing stable I guess and with wipe can you try the older installer version and I know we always say this try a different cable just incase. Or maybe the appimage



  • @guru Sorry just senn youve done that



  • I booted the device into => FASTBOOT mode ... and when I say in Ubuntu:

    # fastboot format cache
    Couldn't parse erase-block-size '0x'.
    Couldn't parse logical-block-size '0x'.
    /usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
    mke2fs failed: 1
    error: Cannot generate image for cache
    


  • @guru remove reinstall adb/fastboot?



  • @Lakotaubp I reinstalle adb and fasboot; result:

    # fastboot format cache
    Couldn't parse erase-block-size '0x'.
    Couldn't parse logical-block-size '0x'.
    mke2fs 1.44.1 (24-Mar-2018)
    /tmp/TemporaryFile-tCX6Fk: Unimplemented ext2 library function while setting up superblock
    /usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
    mke2fs failed: 1
    error: Cannot generate image for cache
    


  • @guru https://github.com/ubports/ubports-installer/issues/593 try this scroll down to find the correct bit



  • @guru If you are still struggling try posting here as well https://t.me/WelcomePlus see if that gets a quicker resolution. It seems it's a cache issue and I'm pushed on time this morning. Will be back later though. Not sure what is going on here 0.3.2 also worked on my 5



  • I tried 0.4.1 again, this time with the dev channel and not stable. While running the installer I watched it's log file:

    ...
    {"level":"debug","message":"adb:reboot done"}
    {"level":"debug","message":"running step: {\"type\":\"fastboot:flash\",\"condition\":{\"var\":\"bootstrap\",\"value\":true},\"flash\":[{\"partition\":\"recovery\",\"file\":\"recovery-krillin.img\",\"group\":\"recovery\"}]}"}
    {"level":"debug","message":"[{\"file\":\"/home/guru/.cache/ubports/krillin/recovery/recovery-krillin.img\",\"partition\":\"recovery\"}]"}
    {"level":"debug","message":"fastboot:flash done"}
    {"level":"debug","message":"running step: {\"type\":\"fastboot:boot\",\"condition\":{\"var\":\"bootstrap\",\"value\":true},\"file\":\"recovery-krillin.img\",\"fallback_user_action\":\"recovery\",\"group\":\"recovery\"}"}
    {"level":"debug","message":"fastboot:boot done"}
    {"level":"debug","message":"skipping step: {\"type\":\"adb:reboot\",\"condition\":{\"var\":\"bootstrap\",\"value\":false},\"to_state\":\"recovery\",\"fallback_user_action\":\"recovery\"}"}
    {"level":"debug","message":"running step: {\"type\":\"adb:format\",\"partition\":\"cache\"}"}
    {"level":"debug","message":"adb:format done"}
    {"level":"debug","message":"running step: {\"type\":\"systemimage\"}"}
    {"level":"debug","message":"Downloading system-image file 2 of 12"}
    {"level":"debug","message":"Downloading system-image file 3 of 12"}
    {"level":"debug","message":"Downloading system-image file 4 of 12"}
    {"level":"debug","message":"Downloading system-image file 5 of 12"}
    {"level":"debug","message":"Downloading system-image file 6 of 12"}
    {"level":"debug","message":"Downloading system-image file 7 of 12"}
    {"level":"debug","message":"Downloading system-image file 8 of 12"}
    {"level":"debug","message":"Downloading system-image file 9 of 12"}
    {"level":"debug","message":"Downloading system-image file 10 of 12"}
    {"level":"debug","message":"Downloading system-image file 11 of 12"}
    {"level":"debug","message":"Downloading system-image file 12 of 12"}
    {"level":"debug","message":"adb wiped cache"}
    {"level":"debug","message":"adb mounted recovery"}
    {"level":"debug","message":"adb created /cache/recovery directory"}
    {"level":"error","message":"Error: systemimage: Push failed: Failed push: Failed to push file 0: failed to stat: SyntaxError: Invalid or unexpected token"}
    


  • After the last error with the dev channel I removed all .cache/ubports directory (so the installer must re download all files of the image, and was successfully with the 0.4.1 installer.

    Thanks for the provided hints. I will update another E4.5 starting again with the 0.4.5 and will report here.



  • @guru Glad you are getting somewhere still not sure what the change may have been though.


Log in to reply