Oneplus one 3 error on reboot

  • Hi

    I have been trying to install UB tocuh on oneplus 3 phone, with windows 10 model says this:
    ONEPLUS A3003_16_181206

    Starting the program it finds the device fine and downloading and all that.
    Then when the phone is rebooting comes to FASTBOOT menu and starts shows a splash screen very quickly with a android figure with stomac open and a red warning triangle (had to film to find the sequence with the figure)

    Then this menu comes
    Android Recovery
    Use Volume up/down and power

    Reboot system Now
    Ubuntu Actions
    Adroid actions

    PC program says sending files and after a while it says connection to device

    I have tried different options at the recovery options with out any results, always ending up with the same.
    I guess the reason is to be found in the "android error" and why this?

    Any help apreciated.

    Thank you.


    Note: I am also running linux but have never succeded to connect to the device (Linux Mint 18)

  • @AsgerBj Have a read here there are a couple of things to try. I needed to use twrp in the end to clear stuff you may not.
    Edit: And this for after

  • I had recently the opportunity to play with a 3 and 3t with ubuntu and lineage, same pain.... With the partition to fix and repair :
    Please read this:

  • Thanks for the replies, I am not really able to succeed with any of the guides.
    The device is though unlocked and when trying to follow the twrp I get stuck in the process also.
    I believe the error message from the image in my first post is the key to my problems.
    I will try to find a way to completely reset the phone and start from scratch.... If too troubled I will try to find a supported device , ubtouch seems very nice in many apsects.

  • First try this from @UniSuperBox

    Could all of you with flashing problems please do the following...

    You will need a computer with the fastboot package installed.

    Boot to bootloader
    Run the command fastboot format:ext4 cache && fastboot format:ext4 data
    Attempt installation again

    It appears the problem is ADB trying to read a file from the data partition, failing, and simply blocking all connections.
    It will wipe your device

    If that fails it this

    pglushkov 15 days ago

    Hi all!

    Following advice from @banderson5586:

    flashed TWRP to recovery partition using fastboot
    'fastboot flash recovery <twrp.img>

    where twrp.img was downloaded from
    rebooted phone if 'recovery' mode and then using UI of TWRP I did the following

    fixed 'cache' partition
    fixed 'data' partition
    formatted and fixed 'system' partition

    Down load twrp. Then put your device into fastboot (volume up and power buttons together). Go to your downloads folder and right click on your mouse the choose open terminal here.
    Connect your device and type sudo fastboot devices your device should be listed then type fastboot flash recovery twrp-3.3.1-0-oneplus3.img (or whatever version you have). that should take a few seconds. Then its fastboot reboot.
    Now boot to recovery and use the twrp menu to clear/fix data, cache and system. can't rember exactly where they are as have only done this once. Then rerun the installer.

  • @AsgerBj
    is your android partition encrypted ? if yes you need to wipe it.
    did you try to install trwp ?

  • @Lakotaubp
    I tried this part with format ext4, see below, but no changes.
    Still get the "android warning triangle"

    And I believe this error is the root for my troubles


    C:\WINDOWS\system32>fastboot devices
    7d6b67e9 fastboot

    C:\WINDOWS\system32>fastboot format:ext4 cache && fastboot format:ext4 data
    Creating filesystem with parameters:
    Size: 268435456
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8192
    Inode size: 256
    Journal blocks: 1024
    Blocks: 65536
    Block groups: 2
    Reserved block group size: 15
    Created filesystem with 11/16384 inodes and 2089/65536 blocks
    target reported max download size of 435159040 bytes
    erasing 'cache'...
    OKAY [ 0.000s]
    sending 'cache' (6248 KB)...
    OKAY [ 0.250s]
    writing 'cache'...
    OKAY [ 0.063s]
    finished. total time: 0.328s
    Warning: data type is , but ext4 was requested for formating.
    Need size of filesystem
    target reported max download size of 435159040 bytes
    sending 'data' (0 KB)...
    FAILED ()
    finished. total time: 0.000s


  • @ernest
    Not encrypted and yes did install TWRP but installation from that also fails....

  • @AsgerBj I am by no means an expert but that looks like data partion issue. All I know is that from the twrp menu I cleared/fixed data, cache and system and all worked after that and I had the same problem with lost connection. Maybe try twrp again unless anyone else has another idea. Just reflashed mine on installer 0.4.11 and the fix still works.

  • @Lakotaubp This is also my understanding that there is a partition issue, without beeing and expert 🙂

  • i've seen on youtube some guy changing the format to ext2 then back to ext4 to fix partition issue...

  • I tried a fastboot getvar all to show all the partitions

    C:\WINDOWS\system32>fastboot getvar all
    (bootloader) version:0.5
    (bootloader) battery-soc-ok:yes
    (bootloader) battery-voltage:3955000
    (bootloader) variant:MTP eMMC
    (bootloader) secure:yes
    (bootloader) version-baseband:
    (bootloader) version-bootloader:
    (bootloader) display-panel:
    (bootloader) off-mode-charge:0
    (bootloader) charger-screen-enabled:0
    (bootloader) max-download-size: 0x19f00000
    (bootloader) partition-type:cache:ext4
    (bootloader) partition-size:cache: 0x10000000
    (bootloader) partition-type:userdata:ext4
    (bootloader) partition-size:userdata: 0xd68877000
    (bootloader) partition-type:system:ext4
    (bootloader) partition-size:system: 0xbc000000
    (bootloader) serialno:7d6b67e9
    (bootloader) kernel:lk
    (bootloader) product:msm8996
    (bootloader) oem_project_name:15801
    finished. total time: 0.219s

    I then see the partition userdata but not "data" which I believe should be there or?

    after that I did a "fastboot format:ext4 userdata" it format OK, then afterwards trying with UBPorts installer gets at least some reaction with an error message like this below. I believe it is a partition problem.
    Anybody can read something from this?


  • @AsgerBj I had such similar responses to my attempts to install on an op3t. This 'Yikes!' window is identical to the one I got. I gave up for a while at this point as the device was unable to boot into any os. I describe what happened next in the Oneplus 3/3T thread which I'm sure you have studied.

    Can't claim to understand much of this but your experience seems so close to mine that I wonder whether if trying what I did would help?

  • @ziggutas
    I think the issue is on the second line with the data or userdata partition faulty.
    Did you try in the twrp to perform the wipe, then format in ext2,repair, format in ext4 then repair ?

    I got the same faulty mount on my op3, in my case my android was encrypted and some how the format was not doing anything, i had to wipe.

  • I did try formatting to ext2 without succes it is as if the partition does not exist? I am now certain that this is a partition error of some kind though I am able to reinstall the android operating system OK and all is running fine. If I wish to do a system upgrade then installation fails on the reboot part.
    Besides I cannot install the system update from a zip file passed to the phone from a computer, also installation error.
    I will keep searching for how to get in control of the partitions.

  • @AsgerBj Install TWRP, reboot to recovery, wipe the phone, format data ( it ask you if you sure, needs to type ''yes'')
    Reboot to recovery again.
    Change the file type to ext4 on Cache and Data, all of this with TWRP (no fastboot).

    Try to install again with Ubports installer.

  • @AsgerBj Could you take a picture of the error in TWPR ?

  • Well I got on a bumpy road with this stuff, it seems on one of my 'formattings' things went wrong, and my phone got bricked... the phone always turning back to fastboot menu without any possibility to run recover 🙃

    So I ended up on my linux box and found a guide to flash TWRP via the computer.
    Having set the phone on fastboot menu I followed this guide

    From the part "Install Recovery"
    step 1 to 7
    then rebootet into recovery and got this screen.

    Then from TWRP I did a wipe and after a format on the 'data'.
    I did not realy find a place where I could define the format to be etx4..

    I then started the Ubports installer with the phone in fastboot menu and this went OK, even if this "sick android" figure still appeared in a few splash screens...

    Thanks to all for the helping with this 👍 👍 ☺

    Now my phone is running ubuntu touch so the next step is now to figure out how this thing works 🙂

Log in to reply