Android Apps with OTA-13



  • I just upgraded to OTA-13 on my LG Nexus 5. I read that from OTA-12 up the installation of android apps changes. How do I install android Apps?



  • @LRV Hi, if Anbox is already and correctly installed on your N5, you first need to download your apps in .APK file. You will find a lot of them here: https://apkcombo.com

    Once your app is downloaded, open your terminal and type "cd Downloads", than type: "adb install /home/phablet/Downloads/my-app.apk" (replace "my-app.apk" with the exact name of your apk file)
    Than type "exit".

    Got it! Your app will appear on your home screen



  • That is the issue. I do not know how to properly install anbox with the new kernel.
    I've attempted the method you mentioned above but it errors with "bash: adb: command not found" multiple times from which I reckon anbox is not fully preinstalled.

    EDIT: Installing anbox as described in the wiki bricks my OS.



  • @LRV Weird, OTA-13 did not change anything concerning Android kernels, that are already installed in the Nexus 5 Ubuntu Touch image.

    However, since Anbox touches the root of the system image, it must be reinstalled after each OTA update:

    sudo mount -o rw,remount /
    sudo apt update
    sudo apt install anbox-ubuntu-touch android-tools-adb
    anbox-tool install
    exit

    Than re-install your .apk apps as described above. It should work.

    EDIT: Do not load Anbox cd-image as it is already charged in the Nexus 5 by default...



  • @stanwood It looks good, but after
    sudo apt install anbox-ubuntu-touch android-tools-adb

    the terminal indicates "no enough free space in /var/cache/apt/archives/
    I do not how to resolve this issue



  • @tgv34 Ok, so you might resize your memory partition dedicated to Anbox as follow:

    sudo mount -o rw,remount /
    sudo rm -r /var/cache/apt
    sudo tune2fs -m 0 /dev/loop0
    sudo apt update
    sudo apt install anbox-ubuntu-touch android-tools-adb
    sudo mount -o ro,remount /
    exit

    It should work fine after this.



  • @tgv34
    I guess you can also mount /var/cache/apt from the userdata partition.
    This way what is installed is kept after an OTA.
    But I never tried it myself cause I have no need for Anbox.



  • @stanwood Thank you very much, it worked fine on my nexus5
    @AppLee Thank you for your message, I did not tried your suggestion as my issue was already solved.



  • @stanwood Just curious because I didn't install :
    Have you tested Firefox through Anbox? If yes, is it fully operational: downloading, acceleration...



  • @domubpkm No, I installed Anbox on an experimental basis and tried a few Android apps. But didn't use Firefox as Morph is really fine for me. But I guess you can install Firefox not using Anbox but with Libertines. (easier way)



  • @stanwood Your method above worked. Thanks.



  • @LRV Great 👍 Thank you.


Log in to reply