Unable to install UBports on MX4 Ubuntu edition



  • I have successfully installed UBports onto my Nexus 4 but I just can't get it onto my Meizu MX4 Ubuntu edition.

    I have tried the following methods:-
    MDT - does not recognise the MX4
    UBports Installer - does not recognise the MX4
    Using the system-image server - after downloading it just sits there doing nothing.

    I can get into fastboot mode but that does not help.

    I can't get adb to find the device.

    lsusb does not find the device no matter what USB port I connect it to.

    I have another Flyme MX4 which lsusb and adb does recognise.

    I even went to the length of swapping the USB modules in each MX4 device and the Ubuntu edition is still not recognised but the Flyme one is.

    Is there anything else that I can try?



  • @halucigenia

    1.Download the recovery and flash it with fastboot

    1. Reboot to recovery and in terminal type:
      sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --device=arale
      --channel=15.04/stable

    No bootstrap, no recovery options...
    It should work without any problem.



  • I had an issue installing UBPorts on my M10. No matter what I did I could not install it on mine. However, I had installed it on my E5 using MDT with no issues.

    I was then told to download the devmode version of MDT. I did this and removed the previous version I had insalled. This found my device and installed a clean version of UBPorts on my device. Then I was able to install it all OK via the server image on the devices website page.

    If you are still having issues let me know and I can send you the line to install the version I used.



  • @Stefano Thanks, I will try that tonight and let you know if it works.



  • @Stefano That did not work
    sudo fastboot flash recovery recovery-arale.img
    < waiting for device >

    Device then rebooted to original Ubuntu Touch.

    Is there anything that I can do from the terminal on the MX4 or via ssh?



  • @halucigenia Try different usb cable. I use to have MX4 and the connection was unstable, once replaced, it worked every time.Or try to hold it by an angle and push to side.



  • @Stefano Different cables make no difference, the same cables that work with the Flyme device don't work with the UT device.

    In fact the same cables used to work with the UT device previously for example when I last transferred music/photos to and from the UT device, I can't do data transfers with the UT device now from any PCs with any cables, and that is even after replacing the USB module.
    I guess that it could be a hardware fault somewhere else in the device.

    If it were a software fault though what might I look at?



  • @halucigenia So have you installed Flyme to MX4 Ubuntu edition and now can't flash Ubuntu Touch back, right?
    Check if your bootloader is unlocked, if not there is problem.
    Bootloader has to unlocked in order to do Ubuntu Touch installation.
    It seems to be locked bootloader.



  • @Stefano No, I have two devices one Flyme, the other UT.
    It is not a locked bootloader.

    I have swapped the USB modules in each device and still the Flyme one works and the UT one does not.
    It is not the USB modules at fault.

    I have tried different cables and attaching the cables to different ports on different computers.

    There is definitely an issue with the UT device. It is not accepting any connections via USB.



  • @halucigenia that's interesting. Never heard of anything like that. Have you enabled Developer mode on UT device?
    When you connect UT device to a PC can you copy files, does your PC recognise it? Does it recognise when in recovery mode? (adb shell, adb devices? ) Fastboot devices in fastboot list your device or not.?



  • @Stefano Developer mode is enabled on the UT device.
    Nothing seems to detect it at all. PC as a data drive Linux or Windows, adb shell, adb devices, fastboot, nothing. Charging OK though.
    I was hoping that it's just services not starting or something but I am not sure what to look for.



  • Sorry to hear that. It's a mystery what's happening to your MX4. I wish I could help, but a I can't.



  • @Stefano Thanks for trying. :)



  • When I was trying to install on my device I tried different cables and ports and nothing seemed to work. Know how frustrating it can be, but you will get there.



  • Guess you have but have you tried using the SP flash tool. I used it to put flyme on ut mx4 might work for you.



  • @UKPhil Thanks for the encouragement :)



  • @Lakota I will look into the SP flash tool. Thanks for the advice. :)



  • @halucigenia Just curious,coming from flyme,did you go into dev mode,and permit OEM unlock.
    Or from UT,switch to dev mode while unplugged then connect and watch that dev page,you should get a window asking to Allow PC to connect,(maybe !!)



  • @halucigenia have a gowith the process that I mentioned and see how you get on. This was the only thing that worked for me after being ready to throw it all in and go down the andriod route.



  • @UKPhil I can't get the devmode version of MDT to run
    I ran
    sudo apt update
    sudo apt install snapd

    I ran sudo snap install magic-device-tool --devmode

    snap list
    Name Version Rev Developer Notes
    core 16-2.28.1 3017 canonical core
    magic-device-tool 1.0 289 marius-quabeck devmode

    When I run magic-device-tool as my normal user
    I get the message "snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks"

    When I run sudo magic-device-tool
    I get the message "cannot change profile for the next exec call: No such file or directory"

    Looks like snap is incompatible with my kernel
    snap --version
    snap 2.28.1
    snapd 2.28.1
    series 16
    ubuntu 17.04
    kernel 4.11.12-041112-lowlatency

    I think snap needs an "Ubuntu supported" kernel.
    I will try again when I can reboot into another kernel.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.