Pure maps navigation port

  • Nexus 5 edge, I just get a black screen when I start the app 😞

    I don't know if there is any kind of logs that could help

  • @Aurze turns out rebooting the device fixed the issues. You can just ignore me.

  • Hi! good work indeed!! i like the success story of this port, could be an example to follow for other apps!

    only unexpected issue so far for me: I couldn't copypaste the map box key , which is kind of tricky considering the size of the key itself;)

  • Re issues with key pasting: turned out that UT doesn't support copy&paste in regular QQC2 text fields. The issue was solved by switching over to the text field provided by Ubuntu Components. This will be fine in the next release, so you may wait for that as well with the key, I think.

    Why not on Flathub: Number of users is expected to be smaller at Flathub. With Sailfish users, I observed that we were getting close to the limits - hence the request for them as well. As for UBPorts, the key is provided by the packager and he will monitor the situation. Note that it is shared commodity and it would help if the active users do register and use their own key. Note that the blessing for such registration has been given by Mapbox when I contacted them at the end of 2018.

    PS: If I start getting issues with larger user base on Flathub, the same note will be added there as well

  • @rinigus Thanks for taking the time to get this ported over rinigus! I didn't expect it to happen so fast! Thanks to Jonnius and others who assisted as well!

  • @rinigus, have you tried contacting Mapbox directly? The services that we've used for things like weather data in Ubuntu Touch have been extremely generous since we're a community project. There's a link to contact Mapbox's community team here: https://www.mapbox.com/community/impact-2018/

  • @Aurze It seems like this is an issue in the edge channel. Probably related to the location service prompt. As you mentioned, rebooting usually solves the issue.

  • Minor issues, the name of the street in navigation mode only take one row. on my Nexus 5 I see "Boulvard bon..." which is missing most part of the acctual name making it hard to use sometime.

  • Re Mapbox contact: I have contacted sales and have sometimes contacts with development team. Sales was the one that proposed current solution. Didn't get in touch with community team, maybe should.

    Re street name: That's by design. Otherwise it will be covering too much of the screen. There is going to be redesign of navigation screens and interactions, I am planning to do it relatively soon. Plan is to move speed and some other data around, adjust helper screens and such (few issues have been filed on topic and design discussed at TMO among Sailfish users few months ago).

    Whether I should scale street name to fit - that's hard to say. In few places it may lead to excessive amount of chars as well. But I do see your issue :). Let's pick it up when the navigation design will be adjusted.

  • @rinigus You are a good communicator.
    Thank you.

  • Love the approach. It works really well so far. Searching using UK postcodes appears temperamentall at best. It's easy enough to work around but would be good not to have to work around.

  • @BrisPete Pure Maps has been built in a modular way. In particular, its possible to choose search and routing engines as well as other providers. By default, search is provided by Photon. Maybe OpenCage will work better in UK (doesn't support autocomplete though, you would have to write a string and then press Enter). If there is some other geocoder that works better in UK, let me know and we can discuss how to implement it.

    If you have some good examples with incorrect search results using Photon, please file an issue at https://github.com/komoot/photon/issues

    When/if offline maps land at Ubuntu Touch, that geocoder was written by me. It should support postcodes in UK, but that you could test later.

  • @rinigus Thank you. OpenCage appears, on first use, to work perfectly.

    BA11 2JY, BS7 8RW, PL2 1SQ all failed in Photon but worked with OpenCage.

  • @rinigus said in Pure maps navigation port:

    Re issues with key pasting: turned out that UT doesn't support copy&paste in regular QQC2 text fields. The issue was solved by switching over to the text field provided by Ubuntu Components. This will be fine in the next release, so you may wait for that as well with the key, I think.

    I was too impatient and couldn't wait for the next update, so I entered my Mapbox API key manually. 😁

    Since a free account allows 50,000 requests a month, could I reuse the same API key among devices? Could I share it with relatives? This latter question is hypothetical, currently no relative of mine has a device they could install Pure Maps on.

    I created an access token with default settings: all public scopes checked, and no secret scopes nor URL restrictions. Is that OK?

    Also, is there a way to make sure this key is used, other than see it in the preferences?

    @rinigus said in Pure maps navigation port:

    Why not on Flathub: Number of users is expected to be smaller at Flathub.

    Thanks for the clarification.

    BTW I noticed a bug with Navigation using a GPX file: the file open dialog (which looks like a default desktop file dialog) does not see the contents of the /home/phablet/ folder. Tapping on the Cancel button does nothing, and if I press the big Home icon at the top, a new window with huge text opens. The only way to close those two dialog windows is to swipe right from left to open the preview of currently opened apps and swipe them away. I will open an issue on Github tomorrow along with screenshots, if Github allows it.

    FYI we discussed it here: https://forums.ubports.com/topic/3056/gps-apps

    Edit: would it be useful for you to get a UbuntuTouch device to test your app on? I wonder if we (the community) could provide you one. I'd be willing to pitch in. Or maybe you'd rather not, and wish for somebody to assume packaging on UT?

  • Re token: yes, sure, you can share the token and it sounds like you made all correct choices in generation of it. Just 50K was insufficient for Sailfish users and I will expect similar limit to be hit on UT. As for family, close friends - should be no problem.

    If there is anything entered in Preferences then this will be used. You can try to add one extra char and restart Pure Maps. In this case it should fail, I believe.

    Re bug with file open dialog: that wasn't tested and, indeed, it is using regular QQC2 file open dialog. So, please file the issue. As soon as offline maps component will be added, you will get also ability to make meaningful instructions using GPX, i.e. it will decode which street the trace is following and which turn you should take (GPX Smart). Obviously, rerouting doesn't work with GPX traces.

    Re device: I would prefer to avoid having extra devices. That way I can focus on core functionality (currently develop mainly on desktop) and fix the platform-dependant issues on appearance. Its rather large stack of software that I develop already (Pure Maps and OSM Scout Server) and it will be great to avoid getting into device-specific testing as much as possible. Also, looks like clickable desktop can reproduce most of the issues as well.

  • Posting it over here as well.

    I looked into content hub a bit and its looking rather complicated. Task, in my mind, is rather trivial - get file path as a string and load the data from file using given path. When checking out pdf reader source, opening a file seemed also rather involved process. Hence, unless there is some simple trick, I will wait for PR with GPX path acqusition from someone who is familiar with the architecture used by UT.

    Corresponding issue is https://github.com/rinigus/pure-maps/issues/324

  • @rinigus
    Sorry for not creating the issue. 😳

  • I am delighted with this Navigator, I am all day on the road and I need to look for many streets, I used Via Michelin because the map was all over the screen and the buttons annoyed little, also indicated me the state of traffic.
    Pure Maps is at a very high level, it searches the streets well, it does it fast, it has a good design in general, it is intuitive and gives you a lot of information.
    My thanks for this great app.

  • New release is out - 1.25.0

    This release is mainly about fixing smaller annoyances. As usual, though, big thanks to translators for the updates.

    This release brings optional DBus activation, based on xXSparkeyy's work (thank you!). Currently its not used to ensure that the environment is controllable by local environment variables simplifying the debugging on all the supported platforms. For Sailfish users, though, geo handler has been fixed with xXSparkeyy's help. I expect that all these calls by SpritRadar (Sailfish) should work as expected. At least they did work over here.

    Attribution button has been redesigned as it was not clear that the button is interactive. That should make data source acknowledgments clear.

    Search engines are now taking into account your location for location bias. This is currently supported by online providers, for offline operation its in TODO list of OSM Scout Server.

    For QtControls and Kirigami, fallback icons loading has been improved (although not yet for PostmarketOS) and clipboard support was added. For UBPorts, and other non-Silica platforms, navigation icons have been reduced making them more suitable.

    Some other smaller bugs were fixed as well.

    PS: There is a know issue with the release - geocoder function is broken. Fix is coming up

  • Happy to see bug #331 fixed


Log in to reply