Sony Xperia X (suzu/F5121 & F5122)

  • @malditobastardo
    I'd like to try a previous image too but I'm not sure how, maybe @fredldotme can help with it. I just compiled custom repowerd package to exclude the problem is not caused by the commit.

    Maybe the problem is really media-hub and turning the wifi off just starts a network dbus service using wakelock and then the music is playing without interruptions or something like that.

  • @wdehoog Should be fixed, it was the commit 🙂

  • @c4pp4 Hi. You tried to revert the commit 8 days ago and it did not help. I also tried to revert it and it did not help me either. Now todays update seems to work and indeed the commit is gone. But I suspect something else has also changed. I am probably wrong and it is of no use anyway since it now works.

  • @wdehoog

    This commit brings back almost everything in that commit back, except
    modify it so that it actually respect suspend inhibitions when pressing
    power button.

  • Fingerprint scanner isn't mentioned in the post. Android version comes with fingerprint scanner. Does it work under UT as well ?

  • The speakerphone during calls does not work. It is as if everything is silent, even the keyboard sounds do not work.

  • Hello. I have a problem flashing sony xperia x with ubports. I already follow all the steps. My phone is an android 8 oreo version, i unlocked to bootloader with sony flash tool. i already enable oem and usb debugging and i install the Sw binaries with fastboot. but when i start ubports, everything is working until the phone reboots to install the firmware and it boot in ubports recovery mode so is not anymore in the fastboot mode with the blue light on. And when i tried to put it back it gets disconnect. What can i do ? can i flash it from ubports recovery ?

  • @Stef7773 What maybe can help: choose another version of ubports-installer. Otherwise, I followed the posts on xda, there I understood the correct way to flash. I remember some month ago, I had the same problem .

  • @Stef7773
    Rebooting in recovery is normal at some point when installing with ubports installer.
    You forgot to tell on what OS your PC is.

  • @Stef7773 One post is all you need posting twice is confusing and distracting . Please don't do so again as one will be removed, Thanks.

  • Should you run into issues during the flashing: install TWRP and wipe system, data & cache partitions, then proceed to the install guide.

  • @fredldotme
    I had the same problem as @Stef7773 a couple of days ago and yes TWRP did the trick. However would it be possible to add that as point 10. (maybe in brackets) of the preparatory steps listed under ? I guess that could save a couple of people time.

    Apart from that: Great work!

  • I finally received my Xperia X 5122 today and I did the mistake in upgrading it to nougat without saving the DRM keys before.. anyway, I would like to know if not having the DRM keys saved will impact the camera quality in UBports. AFAIK it shouldn't affect at all but who knows, maybe in the future! I've been reading that on SFOS forums and I think until today SFOS doesn't make any use of those DRM features so I think nothing will happen for me. But worth asking anyways 🙂

Log in to reply