Can't update Aquaris M10 FHD Frieza



  • Hi,

    I've been trying for a few days to flash my M10 FHD Frieza. It was originally the ubuntu version.
    It worked until I tried to update it... 😉

    I used ubports-installer, everything seemed to go fine... but it got stuck at "Installing ubuntu update." for hours and then... nothing. Now I can't reboot it (I can access fastboot and all tho).

    Tried a few time, same result. I've read older topics about this same tablet but couldn't sort out what I should do...

    Some photos of the logs (no idea if they are of any help...) : https://imgur.com/a/NrEsBVd

    Anyone has any idea how I could sort this out ?

    Thanks



  • @nterr
    Hi,
    Have you tried changing your USB cable and USB port ?
    That's a common issue.



  • Perhaps you could try to reflash it using the original ROM and flash-tool, as described in [docs.ubports.com/en/latest/userguide/install.html#install-on-legacy-android-devices] and then try the UBports Installer routine.



  • Ok. Trying both of these options and then I'll get back to tell you how it went... thanks.



  • Your PC's on Linux or windows?

    Did you put FH10 in dev mode before trying?



  • I flashed the same device a few days ago. Before you run the tool from UBports, you will start the SP_flashtool. In my case that did not start, and I looked into the guidance https://wiki.ubuntuusers.de/Ubuntu_Touch/flash_tool/. They mention a BROM-error - as recommended there I disabled the modemmanager, and started the SP_flashtool again. This time it ran through, and after the UBports-tool is successful.



  • Thanks for your answers.

    No better luck so far... tried a different cable and usb port. Still the same...

    Tried installing the original ROM, I don't have any error, flash_tool tells me everything went fine... and the tablet still freezes at the "powered by ubuntu" splash screen...
    Same goes with ubports-installer...





  • Thanks.

    Got the old rom working (OTA15).

    Still can't get ubports-installer to install the update correctly. Still the same problem I described in my first post.
    Basically I'm still stuck at the exact same point.

    I forgot to respond to this :

    • Yes dev mode was activated
    • I'm on linux.


  • @nterr
    when you turned dev mode on did you get The little window and click the " ALLOW " option ,like you do with adb connection.
    i forgot to say ,you should reboot after doing that. ( i have this device and swap OS`s , it can be picky at times).
    if you still have no access to it, reflash Ubuntu with flashtool ( not with the Format all option).
    if you are "bricked" pull the cover off ( no wires are stuck to anything ) disconnect the battery , reflash wth flash tool ,then reconnect battery , and try again.



  • @nterr If you can use the snap installer try that, you can watch in a terminal where the issue arrives. Reboot to recovery and clear cache and try again with the snap installer. We have had a few issues recently with adb dropping out for some reason you could also try checking thats is working ok.



  • Flashed back to the old rom with flash tool (ota15, working fine), checked if dev mode was correctly activated, it was, rebooted just in case, rebooted again, cleared cashed, used ubpoters-installers from the snap repo, rebooted to bootloader, and everything just seems to work fine... This is what I get in the terminal :

    info: Welcome to the UBports Installer version 0.4.18-beta!
    info: Downloaded file 1 of 1
    checked: keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz true
    checked: version-9.tar.xz true
    checked: device-6e23e473ab0b5bd2baa820e442b41d22fe20d76f8ca984e2fb22bf47597a5eb0.tar.xz true
    checked: ubports-a1f443971032f2b6a03ed6f83d3340e026d59bfbe1625b259fb77eb05fa2b6a9.tar.xz true
    info: All done! Your device will now reboot and complete the installation. Enjoy exploring Ubuntu Touch!

    But it's still stuck at "installing ubuntu update."



  • @nterr
    This step can take some time to proceed.
    The installation files were successfully copied to the phone.
    But now it needs to unpack it and put it in the right partitions. I don't remember how long it can take, but it's safer if your phone is fully charged or plugged to a wall socket.

    What is the current status ?



  • Just what you said, plugged to a wall socket and stuck at "installing ubuntu update" for an hour or so... 😉 Last time I waited a couple of hours, since installer says it should take 5 minutes I assumed it was just stuck. I guess I'll try to wait longer this time...



  • Hi!

    Perhaps it would be a good idea to try a manual installation? Unfortunately I can't find the instructions; they used to be on the old device pages, but the link is gone from the new device pages... I just asked over there where to find the instructions nowadays :https://forums.ubports.com/post/31321

    Maybe @AppLee knows where to find them?



  • @hankschwie said in Can't update Aquaris M10 FHD Frieza:

    Maybe @AppLee knows where to find them?

    Sorry : no idea
    I only went through flashing with my N5 one time and with the PinePhone.
    Both were extremely easy.



  • I thought that by doing a manual installation we probably are able to locate the "trouble spot", and get an idea what goes wrong here....

    Hm. Sometimes it helps to use a TWRP recovery to clean the cache thoroughly. Perhaps it is worth a try, https://eu.dl.twrp.me/freezerfhd/

    Or have a look at this post: https://forums.ubports.com/post/1617 The trouble is: not enough space left in the cache...

    Could you try an adb shell df -h command in recovery mode? That should show us the space left on the device, and the cache partition



  • @nterr This is a bit odd. Did you choose the wipe option when installing (if you have backed up your stuff first). Try rebooting to recovery use the options to clear the cache and try again.



  • adb shell "df -h"

    • daemon not running. starting it now on port 5037 *
    • daemon started successfully *
      Filesystem Size Used Available Use% Mounted on
      tmpfs 981.1M 36.0K 981.0M 0% /dev
      tmpfs 981.1M 12.0K 981.0M 0% /tmp
      /dev/block/platform/mtk-msdc.0/by-name/userdata
      9.3G 319.4M 9.0G 3% /data
      /dev/block/platform/mtk-msdc.0/by-name/system
      3.8G 480.2M 3.3G 12% /cache

    Well I tried already before posting what's said in this other post. But I can try all over again just in case I did smthing wrong along the way...
    Tried too to install it a few different ways, using the wipe option or not, rc and stable...

    What's TWRP and how should I use it ?



  • TWRP is an alternative recovery, which offers quite a few things you can perform from "outside" the main system. It is flashed to the recovery partition of the device using fastboot - it replaces the recovery provided by UT or the original OS. It can be used to root android devices, create backups etc, or flash the whole system with custom-ROMs. In this case it could be useful to clear the cache partition completely.

    You would have to download the image from the linked twrp-site, and flash the recovery as described on the the webside. Afterwards you would have to reboot in this recovery (adb reboot recovery), and then use the tools to wipe the cache, or perhaps even erase the whole system to retry with the UBports Installer.


Log in to reply