Oneplus One installation failure

  • The first command did nothing to the phone and gave me this

    ```cliffcoggin@Cliffscomputer ~ $ adb reboot bootloader
    * daemon not running; starting now at tcp:5037
    * daemon started successfully
    error: no devices/emulators found

  • Try to unset and set developer mode
    Be sure you enabled USB-debugging in developer option
    then connect your phone with USB cable it should ask you for permissions.
    If it ask confirm and on PC in terminal type "adb devices".

  • I unset and then set Developer Option, enabled debugging, and plugged in the cable. Still no response from the phone except for the charging light.

  • It's late here. I'll return tomorrow to see if anybody has further ideas.

  • @cliffcoggin Try an other USB cable.

  • The first thing you need to sort is the connection between your phone and pc. Try a few cables and just see if having the phone in file transfer/MTP mode gets that connection up.
    Once thats done you can move to the adb connection. Just keep an eye out for the grant permission box on the device.

  • I have a new cable arriving later today. Initially the old cable was working and the computer detected the phone as A0001, but later attempts told me there was no connection.

  • @Lakotaubp
    The new cable connects the phone to the computer. A0001 is mounted.

    adb reboot bootloader

    caused the phone to go into fastboot mode rather than restart.

    sudo fastboot oem unlock

    plus password gave me OKAY finished in 0.023s.

    fastbboot devices

    caused the phone to factory reset.

    Where do I go from here please?
    PS. Should "ADB over network" be enabled?

  • @cliffcoggin You do need to grant permission for the connection between pc and device that's all. I would just type in a terminal as a check

    adb devices

    Then run the installer if your device is shown that is

  • It doesn't show the phone.

    List of devices attached
    df32588a	unauthorized

    How do I authorise it?

  • I give up. I have tried every combination of instructions I can find, including the terminal command mentioned elsewhere on the forum. I'll get rid of it and stick with my dumb flip phone.

  • @cliffcoggin said in Oneplus One installation failure:

    It doesn't show the phone.

    List of devices attached
    df32588a	unauthorized

    How do I authorise it?

    Enable developper mode i guess...

    EDIT :

    @Lakotaubp said in Oneplus One installation failure:

    @cliffcoggin There should be a popup window asking you to accept the connection. Pretty sure it's on the phone when you connect. Can't remember how long it remains visable.

    Or that more probably...

  • @cliffcoggin There should be a popup window asking you to accept the connection. Pretty sure it's on the phone when you connect. Can't remember how long it remains visable.

  • Just did quick web search so you might want to try others but, with the device connected revoke usb debugging (switch it off or whatever) in Dev options then type in a terminal

    adb kill-server
    adb start-server

    You should get asked to accept the connection. If you do then check with

    adb devices

    If not have a look on the web.

  • @Lakotaubp said in Oneplus One installation failure:

    adb kill-server

    Thanks. There was no request to accept connection.
    The adb kill-server command gave me

    adb kill-server
    cannot connect to daemon at tcp:5037: Connection refused

  • @cliffcoggin Did you go through all the steps ?

    • unplug device
    • adb kill-server
    • adb start-server
    • plug device
      Allow USB debugging in your device when popup

  • If that doesn't fix it would removing adb, updating the system and reinstalling adb fastboot work?

    Edit: Or try another pc beginning to think it might be a Mint issue. Seem to remember using ubuntu sometimes instead.

  • Sorry chaps but I am getting nowhere, and I am not prepared to waste any more time on getting Ubuntu Touch on this phone. I still don't know it the fault is with me, the phone, the installer, or Mint. Sad to say this experiment is a failure. Thanks for your help.

  • I understand you just have give up the installation process. I know it can be somehow tricky depending the device you are using... Believe me, I'm brand new through Linux (since last January), I don't have any computing skills at all, and it took me about 6 days to successfully migrate an old Galaxy Tab 3 to LineageOS. But at the end I ensure you it's really worth it...

    Allow me just helping you with following elements:

    1. ADB drivers (Android Debugging Bridge) as well as fastboot package generally MUST be previously installed on you computer. To install them, open terminal and type:

    sudo apt install adb
    sudo apt install fastboot

    Restart your computer

    1. Turn off device.
      Press and keep vol+ and power about 10 seconds. Than release those bottoms. If you hold them pressed too long the device will boot normally.
      When Bootloader (or TWRP in case of a former custom rom installed) appears:

    Connect your device to USB. Open your terminal and type: sudo fastboot oem unlock

    1. Run UBports Installer, select One Plus One manually in the list and start the installation. If possible, choose "wipe data"

    Wait for about 10 minutes 'till the end of the installation process. (Files are 1rst copied to the mobile, than "updating device" will properly install UT)
    Without those above steps, I would have been unable to install UT on my Nexus 5...

    Good luck!

  • Thank for your revelations Stan, that the installer is not the entire answer to getting UT on the phone, and also that I have been holding buttons in for too long awaiting a response from the phone. If the UBPorts instructions had contained that information maybe I would have been successful, however I am now pursuing the purchase of a phone with Ubuntu Touch already installed.

Log in to reply