Installing UT on oneplus 1 w Cyanogen Mod

  • Is this hard to do w Cyanogen Mod?

  • @Nathan123
    I moved your topic because the Porting section is dedicated to people actually porting UT to another device.

    I'm a total noob in the Android world, but for me Cyanogen Mod is an android release.
    So I don't see how it might help installing UT.

    On the other hand, tools (ADB, fasboot, ...) required to install Cyanogen can be useful but I don't know much about it.

    The easiest way to install UT on a OPO is to utilize the UBports installer.

  • I would have to say the process is pretty finicky. I started this morning and have been struggling for about three hours. OnePlus One Cyanogen, UBPorts installer on a Mac. I'm trying to leave Apple and Google behind, but it seems like the Linux world still requires you to be programmer to have any success. UBports wasn't recognizing the phone, and the phone does not do the rebooter mode when holding down the power and volume up button. Currently the phone seems frozen with some sort of half-done install. It sits there there with the "powered by Ubuntu" start up screen and that's it. Nothing responds with UBports. Is there anyway to just start all over again, or am I stuck with a $200 brick, and lessons learned? Hopefully there is a solution... just be aware the process is nowhere near as simple and reliable as the video clips on UbuntuTouch make it out to be.

  • Search this forum to see several threads, including my own, regarding problems installing on a Oneplus 1.

  • @El-Franko
    Seems like for almost quite all the "frozen" install problems, an ADB driver issue.

  • @Keneda Yes, "ADB is scanning for devices" message over and over again. The phone is in "fastboot" mode now. Should this work, or is fast boot the wrong mode? I have tried numerous different cables.

  • @El-Franko
    For my MX4, on windows, i had to attach ADB driver to phone when booted in each normal, recovery, and fastboot mode.
    Each time boot in one mode, then connect and attach ADB driver when new "device" detected, then deconnect once done, and do this for every mode.
    I failed 3 days or more before understanding the ADB "mode" issue.
    Then, when i succeeded, i only had to connect phone in "normal" mode for ubports to recognize it (wich it wasn't before), and installer did all alone (reboot in fastoot then in recovery, and of course, install ubport image)
    See :

    I recently installed on a Nexus 5 using same method, and succeeded the first try ("full auto" install again).

    Maybe it's not your issue, but it could.

  • @El-Franko I don't have a OPO but I think that you need to put the phone in recovery mode for adb to see it. To enter recovery mode: In fastboot pushing vol+ or vol- until it says Recovery Mode push power button to enter Recovery Mode.

  • @Rondarius FYI, when the phone is in fastboot mode, it doesn't respond to pushing vol+ or vol-. Thanks for the suggestion.

  • @El-Franko If you hold the power button for long enough it will turn off. Then try putting it into recovery and clear the cache or just restart the installer and try again with the wipe option ticked.

  • Actually change of plans. I got a OPO 64g with duel boot Android 10/ and lineage OS. It has TWRP on it.

  • @Keneda So, I made it through the "reboot to bootloader" step in the UBports installer, by selecting "reboot to bootloader" on the phone. This steps completes very quickly, probably less than a second. The next step is called "reboot to recovery" and this is where it hangs up with the "ADB is scanning for devices" message. I have tried the process by selecting different options on the phone, as there isn't one specifically titled "reboot to recovery." It seems that neither "Reboot system now" or "reboot to bootloader" options on the phone work. Both leave UBports hanging. It seems a bit strange as I assume the ADB can find the phone as it passes the first step, but gets stuck on the second step. Any thoughts?

  • This post is deleted!

  • @El-Franko When you get a hold of it, boot it up in recovery mode and when it appears it will start loading the system.

  • @ricardo65 Man, that was kind of painful. Bacon has been installed after being lubricated with a few tears. I have no idea why it started to work, I essentially just started jamming everything through. Had to acknowledge the “lost communication” warning about six times while downloading, even though the Mac and the phone showed data being steadily transferred. I really didn’t have the patience left to methodically continue trouble shooting after several hours. Thanks everyone for their input, clearly a big responsive community here. No SIM in it yet, but otherwise the OPO is running good, just starting to poke around and see what I can set up.

  • @El-Franko
    The only thing you have to do on the phone is enabling developper mode on USB.

    Booting on recovery or fastboot is done when phone is off, then keeping VOL- or VOL+ pushed, and pushing power button untill phone boot and say "recovery" or "fastboot".

    It's very important that you attach ADB driver to device(s) like i said in my last previous post before doing anything else.

    When all is ok, i repeat, ubports installer will do everything FULL AUTO, without touching anything appart from connecting phone, normally booted, to PC, when prompted by ubports installer in the beginning of the procedure.

  • @Keneda
    It is my understanding that the OPO is more unpredictable than most other phones.
    Many people complain about problems and it always seem to be really random and unidentified.

    While with other devices it's more frequently a step missed or hardware issue.

    OPO is well supported but I sense that installation will always be a pain with this device.

Log in to reply