regression in usage of browser tabs



  • With the old navegator app, when I swiped up the from the bottom to add or delete a tab, the actual page as well was converted in a tab and one could delete this marking the x button. With morph browser this got lost.



  • @guru Yeah, the behaviour is different but you can still close the opened tab by clicking the cross that shows up in the app's header.



  • No, the actual window has no X to close it.



  • The cross to close the current tab is on the right of the url bar. (If you're on OTA7)



  • I'm on OTA-5 (no update offered so far) and on the right of the URL is a hamburger menu but with nothing to close.



  • @guru on RC there is the X and then the hamburger menu ... no idea about OTA5 though



  • @guru Have you tried moving to dev channel updating then back to stable? It's fixed it before for updates.



  • I think the close button for the current tab has only been implemented in OTA-7.
    It's a bit different from the previous implementation though but it does work.
    I personally like the old one more but the current will do 🙂



  • Not getting OTA-7 is the real problem so it would be better to change post title.



  • Not getting OTA-7 is another problem.

    The disappearing of the X to close the actual tab, or having it in OTA-7 in another place and not like in all other tabs, is a regression.



  • If your point is to get a fix, at this time not getting OTA-7 (or latest RC) is the actual issue because this well documented issue is fixed with OTA-7 (and with RC).



  • I can confirm that the cross is there in the latest versions(OTA-7) and is as has been said just to the right of the of the address/search box when multiple tabs are open. I'm on OPO dev 699 soon to be 700( it's just downloaded).
    The fix is mentioned in the OTA-7 blog https://ubports.com/blog/ubports-blog-1/post/ubuntu-touch-ota-7-release-192 and it is in the same position (top right of the tab)as all the others when in open tab view. So this cannot be a regression. Please try to get the OTA-7 update as not getting it might be a bigger issue if it is a common occurance.



  • Can someone please post a screen showing 2-3 tabs and the actual tab. When I do understand this here correctly, all tabs look like tabs having a X to be closed and only the actual screen does not look like a tab and has this X between location bar and hamburger menu.

    With the old navigator app all tabs have had the same style. That's why I count this a regression bug. Well, you can also call it a feature, if you want 🙂



  • @guru 0_1547821254496_acad1957-6d0d-4883-9ef2-26f3b2086dcd-image.png
    Is this what you ment.



  • We are in the Support section of this forum.

    It is why I think the reasonable answer is keep your system up to date and get OTA-7.

    If this were a History section, it would be easier for me to consider it relevant to discuss the exact nature of a bug encountered in the past, regression or not.

    The past is the past, let's keep moving forward.



  • @libremax I reply here just to take advantage of the current thread opened by @guru to flag to you I found a similar issue as described by him. I noticed it since a while, I'm not quite sure since when, but for sure after Morph browser stepped in and got the first bunch of fixes. My device is a Pro5 and currently I'm up to date to the devel channel. I'd like to share with you what I see by attaching a picture. As you can see, the closing cross is not shown anymore in the tabs header but I'm still actually able to close each tab if I tap on the place where it was supposed to be.

    0_1547894085206_screenshot20190119_112016290.png



  • @matteo issue 50 in morph browser was about the impossibility to close the current tab (and only the current tab).
    So your issue is another and new issue.

    You should create a report for this new issue at this address:
    https://github.com/ubports/morph-browser/issues

    It would be useful to test Stable channel, and RC channel to determine where the problem is present at the moment for your device type and thus help to correct it.



  • @matteo that sounds to me like you're carrying some debris from past browser installations. Have you tried to clean Morph's cache and config files?



  • @libremax ok but in the thread it was stated that the closing cross has disappear, so I just took advantage of that statement to expose this related issue. By the way, no big deal, don't pay attention to this issue, this could be something peculiar to my phone, maybe correlated to the weird behavior my phone has with certain UT features. Thank you for the reply!

    @advocatux thank you for the hint but I just tried to clear the Morph's cache, data and config file but nothing changed, I'm afraid.



  • @matteo In OTA-5 oxide browser has been replaced by the new morph browser and in this first published version of morph browser there wasn't possible to close the current tab.

    So it was not a matter of disappearance but of non-existence 😉


Log in to reply